summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2003-03-05 00:50:49 +0000
committerPeter Johanson <latexer@gentoo.org>2003-03-05 00:50:49 +0000
commit5384850101a80af3c0f36c8517b2b2295af63734 (patch)
tree71bd3276169ce0c92b69921bcd27204f63b4cc0e /sys-apps/pcmcia-cs-drivers
parentRevision Bump. Fixes missing libwmf.so. (diff)
downloadgentoo-2-5384850101a80af3c0f36c8517b2b2295af63734.tar.gz
gentoo-2-5384850101a80af3c0f36c8517b2b2295af63734.tar.bz2
gentoo-2-5384850101a80af3c0f36c8517b2b2295af63734.zip
Version bump
Diffstat (limited to 'sys-apps/pcmcia-cs-drivers')
-rw-r--r--sys-apps/pcmcia-cs-drivers/ChangeLog7
-rw-r--r--sys-apps/pcmcia-cs-drivers/files/digest-pcmcia-cs-drivers-3.2.42
-rw-r--r--sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild132
3 files changed, 140 insertions, 1 deletions
diff --git a/sys-apps/pcmcia-cs-drivers/ChangeLog b/sys-apps/pcmcia-cs-drivers/ChangeLog
index 8e70fa741c99..df750aea1b76 100644
--- a/sys-apps/pcmcia-cs-drivers/ChangeLog
+++ b/sys-apps/pcmcia-cs-drivers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pcmcia-cs-drivers
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-drivers/ChangeLog,v 1.2 2003/02/12 09:05:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-drivers/ChangeLog,v 1.3 2003/03/05 00:50:49 latexer Exp $
+
+*pcmcia-cs-drivers-3.2.4 (4 Mar 2003)
+
+ 4 Mar 2003; Peter Johanson <latexer@gentoo.org> pcmcia-cs-drivers-3.2.4.ebuild :
+ Version bump and slight cleanup.
*pcmcia-cs-drivers-3.2.3 (23 Jan 2003)
diff --git a/sys-apps/pcmcia-cs-drivers/files/digest-pcmcia-cs-drivers-3.2.4 b/sys-apps/pcmcia-cs-drivers/files/digest-pcmcia-cs-drivers-3.2.4
new file mode 100644
index 000000000000..f6b712230def
--- /dev/null
+++ b/sys-apps/pcmcia-cs-drivers/files/digest-pcmcia-cs-drivers-3.2.4
@@ -0,0 +1,2 @@
+MD5 126e2d87e7a8a12e283db37ae82e9e4c pcmcia-cs-3.2.4.tar.gz 1262994
+MD5 1e97b69319d9c208c3df7c365d0152bd pcmcia-cs-3.2.4-orinoco-patch.diff 33570
diff --git a/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild b/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild
new file mode 100644
index 000000000000..c1f6173982d9
--- /dev/null
+++ b/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs-drivers/pcmcia-cs-drivers-3.2.4.ebuild,v 1.1 2003/03/05 00:50:49 latexer Exp $
+
+inherit eutils
+
+P=${P/-drivers/}
+S=${WORKDIR}/${P}
+DESCRIPTION="pcmcia-cs drivers"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz
+ http://airsnort.shmoo.com/${P}-orinoco-patch.diff"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT="0"
+IUSE="trusted apm pnp nocardbus build"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${DISTDIR}/${P}-orinoco-patch.diff
+
+ cd ${S}
+ mv Configure Configure.orig
+ sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+ chmod ug+x Configure
+ #man pages will now install into /usr/share/man
+
+ einfo `use gtk`
+}
+
+src_compile() {
+ local myconf
+ use trusted && myconf="--trust" || myconf="--notrust"
+ use apm && myconf="$myconf --apm" || myconf="$myconf --noapm"
+ use pnp && myconf="$myconf --pnp" || myconf="$myconf --nopnp"
+ use nocardbus && myconf="$myconf --nocardbus" || myconf="$myconf --cardbus"
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --force \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in
+ # /usr/src/linux rather than the currently-running kernel. It's Gentoo
+ # Linux policy to configure for the kernel in /usr/src/linux
+
+ # This handles the various cardinfo guis. If you have gtk in your USE,
+ # then the gtk version will be installed. If not, but X is in your USE,
+ # then the xaw version will be installed. Otherwise, no gui will be
+ # installed.
+ sed -e "/^HAS_FORMS/d" config.out > config.out.1
+ sed -e "/^HAS_FORMS/d" config.mk > config.mk.1
+ sed -i -e "/^HAS_GTK/d" config.out.1
+ sed -i -e "/^HAS_GTK/d" config.mk.1
+ sed -i -e "/^HAS_XAW/d" config.out.1
+ sed -i -e "/^HAS_XAW/d" config.mk.1
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.out.1 > config.out
+ sed -e "s/^FLIBS=\".*\"/FLIBS=\"\"/" config.mk.1 > config.mk
+ rm -f config.out.1
+ rm -f config.mk.1
+
+
+ # patch version.h so that they won't complain that Card Services is wrong.
+ if [ -n "`grep -E '^CONFIG_PCMCIA\=y' config.mk`" ]; then
+ cd ${S}/include/pcmcia
+
+ # get kernel CS_RELEASE :
+ if [ -f /usr/src/linux/include/pcmcia/version.h ]; then
+ KERNEL_RELEASE=`grep -E '^#define CS_RELEASE ' /usr/src/linux/include/pcmcia/version.h | awk '{print $3}'`
+ KERNEL_RELEASE_CODE=`grep -E '^#define CS_RELEASE_CODE ' /usr/src/linux/include/pcmcia/version.h | awk '{print $3}'`
+ else
+ die "unable to find /usr/src/linux/include/pcmcia/version.h"
+ fi
+
+ # replace CS_PKG_RELEASE :
+ if [ -f version.h ]; then
+ sed "s|\(#define CS_PKG_RELEASE.*\)\".*\"|\1$KERNEL_RELEASE|" version.h > version.h.new
+ sed "s|\(#define CS_PKG_RELEASE_CODE.*\)0x.*|\1$KERNEL_RELEASE_CODE|" version.h.new > version.h
+ fi
+
+ cd ${S}/clients
+ emake all || die "failed compiling"
+ cd ${S}/wireless
+ emake all || die "failed compiling"
+ else
+ eerror "Please enable PCMCIA in your kernel in /usr/src/linux"
+ eend
+ fi
+
+}
+
+src_install () {
+ cd ${S}/clients
+ make PREFIX=${D} install || die "failed installing"
+ cd ${S}/wireless
+ make PREFIX=${D} install || die "failed installing"
+ cd ${S}/man
+ make PREFIX=${D} install-man4 || die "failed installing"
+
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+}
+
+pkg_postinst() {
+ einfo "Please note that some of these drivers are also provided by the kernel. To use a driver installed"
+ einfo "by this ebuild, you must *disable* the corresponding driver in the kernel."
+}