summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-02-01 23:19:34 +0000
committerPeter Johanson <latexer@gentoo.org>2004-02-01 23:19:34 +0000
commitdf6f8632f0c6969fa71f52a46aa41faabdcb0a08 (patch)
treeac42b9f4c9f9fb4961e8a98f5ee080fab1e72aae /sys-apps/pcmcia-cs
parentAdded a fix for module-init-tools (diff)
downloadgentoo-2-df6f8632f0c6969fa71f52a46aa41faabdcb0a08.tar.gz
gentoo-2-df6f8632f0c6969fa71f52a46aa41faabdcb0a08.tar.bz2
gentoo-2-df6f8632f0c6969fa71f52a46aa41faabdcb0a08.zip
Added a fix for module-init-tools
Diffstat (limited to 'sys-apps/pcmcia-cs')
-rw-r--r--sys-apps/pcmcia-cs/ChangeLog8
-rw-r--r--sys-apps/pcmcia-cs/Manifest6
-rw-r--r--sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.5-r13
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.2.5-r1.ebuild170
4 files changed, 183 insertions, 4 deletions
diff --git a/sys-apps/pcmcia-cs/ChangeLog b/sys-apps/pcmcia-cs/ChangeLog
index 38216a94e61c..49e03e5b60e1 100644
--- a/sys-apps/pcmcia-cs/ChangeLog
+++ b/sys-apps/pcmcia-cs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pcmcia-cs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.49 2004/01/19 02:28:42 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.50 2004/02/01 23:19:26 latexer Exp $
+
+*pcmcia-cs-3.2.5-r1 (01 Feb 2004)
+
+ 01 Feb 2004; Peter Johanson <latexer@gentoo.org> pcmcia-cs-3.2.5-r1.ebuild,
+ pcmcia-cs-3.2.5.ebuild:
+ Added a fix for module-init-tools systems
19 Jan 2004; Ciaran McCreesh <ciaranm@gentoo.org>
pcmcia-cs-3.1.34-r8.ebuild, pcmcia-cs-3.2.4.ebuild, pcmcia-cs-3.2.5.ebuild:
diff --git a/sys-apps/pcmcia-cs/Manifest b/sys-apps/pcmcia-cs/Manifest
index f2c7b794c113..08c21d761bf1 100644
--- a/sys-apps/pcmcia-cs/Manifest
+++ b/sys-apps/pcmcia-cs/Manifest
@@ -1,8 +1,8 @@
MD5 b3c2629fd0e60f03cbabcb43345d7876 pcmcia-cs-3.2.4.ebuild 4035
MD5 42b6034692126c56b1775fdae2c56e45 pcmcia-cs-3.1.34-r8.ebuild 4136
-MD5 0e410de19275225164890f23f9fa4cf5 pcmcia-cs-3.2.5-r1.ebuild 4822
-MD5 d4642547ccf30d6858f6e062233b4214 pcmcia-cs-3.2.5.ebuild 4672
-MD5 5b21423d950e73b63938685f1915083c ChangeLog 12062
+MD5 6ec893879465be76e8a1ae662ad7b453 pcmcia-cs-3.2.5-r1.ebuild 4825
+MD5 62511bf5f38cc3ba5035814e7e66b9c7 pcmcia-cs-3.2.5.ebuild 4405
+MD5 e89f2a848380c2633980d71a9aa381cc ChangeLog 12246
MD5 19fd766bac8e110b4620363a1ace26dd metadata.xml 159
MD5 300aadbb4efa9d5933fc0c1fdf004c95 files/digest-pcmcia-cs-3.2.5-r1 233
MD5 398d67e8e892182884b962c8ff2fca2e files/pcmcia.rc 1795
diff --git a/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.5-r1 b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.5-r1
new file mode 100644
index 000000000000..1f80c548e3bc
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.2.5-r1
@@ -0,0 +1,3 @@
+MD5 44dbc0a8978fe618eee242b0bd25392c pcmcia-cs-3.2.5.tar.gz 1266494
+MD5 33325ed642b5277a9695d10bd19b3d7a pcmcia-cs-3.2.5-module-init-tools.diff.gz 460
+MD5 cdf1e5021163432f73bc3ef6cc70daf3 pcmcia-cs-3.2.5-orinoco-monitor.diff.gz 7241
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.2.5-r1.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.5-r1.ebuild
new file mode 100644
index 000000000000..1b3f379bfc69
--- /dev/null
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.2.5-r1.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.2.5-r1.ebuild,v 1.1 2004/02/01 23:19:26 latexer Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+OV="orinoco-0.13e"
+
+DESCRIPTION="PCMCIA tools for Linux"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz
+ http://dev.gentoo.org/~latexer/files/${P}-module-init-tools.diff.gz
+ http://dev.gentoo.org/~latexer/files/${P}-orinoco-monitor.diff.gz"
+
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+IUSE="trusted build apm pnp nocardbus"
+DEPEND="sys-kernel/linux-headers
+ >=sys-apps/sed-4"
+RDEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+
+ unpack ${P}.tar.gz || die "unpack failed"
+ cd ${S} || die "cd ${S} failed"
+
+ # parse out the middle number from the kernel version
+ check_KV
+ okvminor="${KV#*.}" ; okvminor="${okvminor%%.*}"
+ [ -n "${okvminor}" ] || die "couldn't figure out okvminor"
+
+ # 3.2.5 includes the latest orinoco (0.13e), so just patch to add
+ # monitor mode
+ epatch ${DISTDIR}/${P}-orinoco-monitor.diff.gz
+
+ # Fix for module-init-tools only systems
+ epatch ${DISTDIR}/${P}-module-init-tools.diff.gz
+
+ # If we're on 2.5.x or 2.6.x, modversions.h has *moved*
+ if [ "${okvminor}" -ge 5 ]; then
+ sed -i -e "s:include/linux/modvers:include/config/modvers:" Configure \
+ || die "sed Configure failed (1)"
+ fi
+
+ # Install man-pages into /usr/share/man
+ sed -i -e 's:usr/man:usr/share/man:g' Configure \
+ || die "sed Configure failed (2)"
+}
+
+src_compile() {
+ local myconf myarch
+
+ if use trusted; then
+ myconf="${myconf} --trust"
+ else
+ myconf="${myconf} --notrust"
+ fi
+
+ # Note that when built with apm support, pcmcia-cs will require a
+ # kernel with APM support
+ if use apm; then
+ myconf="${myconf} --apm"
+ else
+ myconf="${myconf} --noapm"
+ fi
+
+ # Note that when built with pnp support, pcmcia-cs will require a
+ # kernel with ISA PnP support
+ if use pnp; then
+ myconf="${myconf} --pnp"
+ else
+ myconf="${myconf} --nopnp"
+ fi
+
+ if use nocardbus; then
+ myconf="${myconf} --nocardbus"
+ else
+ myconf="${myconf} --cardbus"
+ fi
+
+ # x86 is not a valid arch for configure... use a case statement
+ # here to make it easy for other arches to add their own
+ # workarounds.
+ case "${ARCH}" in
+ x86) myarch="i386" ;;
+ *) myarch="${ARCH}" ;;
+ esac
+
+ # Use $CFLAGS for user tools, but standard kernel optimizations
+ # for the kernel modules (for compatibility).
+ #
+ # The --srctree option tells pcmcia-cs to configure for the kernel
+ # in /usr/src/linux rather than the currently-running kernel.
+ # It's Gentoo Linux policy to configure for
+ # the kernel in /usr/src/linux
+ ./Configure -n \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${myarch}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+
+ sed -i -e '/^HAS_FORMS/d ; s/^FLIBS=".*"/FLIBS=""/' config.out config.mk
+
+ emake all || die "failed compiling"
+}
+
+src_install () {
+ make PREFIX=${D} install || die "failed installing"
+
+ # remove included rc scripts since we have our own
+ rm -rf ${D}/etc/rc*.d
+
+ # remove X
+ # this is simply much easier than patching configure or the makefiles
+ # not to build them in the first place
+ rm -rf ${D}/usr/X11R6
+ # todo: if they are installed, move them to /usr
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pcmcia.conf pcmcia
+
+ exeinto /etc/pcmcia
+ doexe ${FILESDIR}/network
+
+ # install our own init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcmcia.rc pcmcia
+
+ # documentation
+ if use build; then
+ rm -rf ${D}/usr/share/man
+ else
+ dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
+ README-2.4 SUPPORTED.CARDS doc/*
+ fi
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+
+ # if on ppc set the ppc revised config.opts
+ if [ "${ARCH}" = "ppc" ]; then
+ insinto /etc/pcmcia
+ newins ${FILESDIR}/ppc.config.opts config.opts
+ fi
+}
+
+pkg_postinst() {
+ if [ "${okvminor}" -lt "5" ]
+ then
+ einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the"
+ einfo "PCMCIA support in the kernel. (Otherwise, you might experience"
+ einfo "CardServices version mismatch errors)"
+ einfo ""
+ einfo "Proper kernel config for this package is that PCMCIA/CardBus under"
+ einfo "General Setup is off and Wireless LAN (non-ham radio) is on but"
+ einfo "no modules or drivers turned on under Network Device Support"
+ einfo "if you have wireless."
+ else
+ einfo "For 2.5/2.6 kernels, the PCMCIA support from the kernel should"
+ einfo "be used. Enable PCMCIA and any further drivers you need there,"
+ einfo "and then use this package to install the PCMCIA tools."
+ fi
+}