summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 06:25:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-02 06:25:57 +0000
commit329fa5897b5c44f25222cbf5581a403d1ac34ffe (patch)
treeba42f36e1646df7baac67d1a474fe3e6bad5e731 /sys-apps/pcsc-lite
parentVersion bump. (diff)
downloadgentoo-2-329fa5897b5c44f25222cbf5581a403d1ac34ffe.tar.gz
gentoo-2-329fa5897b5c44f25222cbf5581a403d1ac34ffe.tar.bz2
gentoo-2-329fa5897b5c44f25222cbf5581a403d1ac34ffe.zip
Version bump.
(Portage version: 13874-svn/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog8
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.5.5.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index e2a4dfbd3c5a..37158b310a8c 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pcsc-lite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.71 2009/07/31 14:52:25 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.72 2009/08/02 06:25:57 arfrever Exp $
+
+*pcsc-lite-1.5.5 (02 Aug 2009)
+
+ 02 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pcsc-lite-1.5.5.ebuild:
+ Version bump.
31 Jul 2009; <chainsaw@gentoo.org> pcsc-lite-1.5.4.ebuild:
Marked stable on AMD64 as requested by Arfrever Frehtes Taifersar Arahesis
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.5.5.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.5.5.ebuild
new file mode 100644
index 000000000000..82afc880c624
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.5.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.5.5.ebuild,v 1.1 2009/08/02 06:25:57 arfrever Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit subversion autotools
+ ESVN_REPO_URI="svn://svn.debian.org/pcsclite/trunk"
+ S="${WORKDIR}/trunk"
+else
+ STUPID_NUM="3082"
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="hal static usb"
+
+RDEPEND="usb? ( virtual/libusb:0 )
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use hal && use usb; then
+ ewarn "The usb and hal USE flags cannot be enabled at the same time"
+ ewarn "Disabling the effect of USE=usb"
+ fi
+}
+
+if [[ "${PV}" == "9999" ]]; then
+ src_prepare() {
+ S="${WORKDIR}/trunk/PCSC"
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+ }
+fi
+
+src_configure() {
+ local myconf
+ if use hal; then
+ myconf="--enable-libhal --disable-libusb"
+ else
+ myconf="--disable-libhal $(use_enable usb libusb)"
+ fi
+
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ ${myconf} \
+ $(use_enable static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepalldocs
+
+ dodoc AUTHORS DRIVERS HELP README SECURITY ChangeLog
+
+ newinitd "${FILESDIR}/pcscd-init" pcscd
+ newconfd "${FILESDIR}/pcscd-confd" pcscd
+}