summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-11-11 18:37:59 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-11-11 18:37:59 +0000
commit58d7042a5853e294ac96cb94d6e766377f994c63 (patch)
tree5a7c9cd6874ca67a7c0820f3fb43208cb5bcaef7 /sys-apps/prctl/prctl-1.5.ebuild
parentremove old (diff)
downloadgentoo-2-58d7042a5853e294ac96cb94d6e766377f994c63.tar.gz
gentoo-2-58d7042a5853e294ac96cb94d6e766377f994c63.tar.bz2
gentoo-2-58d7042a5853e294ac96cb94d6e766377f994c63.zip
Initial import, bug #198681, initial ebuild by <blc+gentoo at q dot dyndns dot org>
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-apps/prctl/prctl-1.5.ebuild')
-rw-r--r--sys-apps/prctl/prctl-1.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/prctl/prctl-1.5.ebuild b/sys-apps/prctl/prctl-1.5.ebuild
new file mode 100644
index 000000000000..d47efad10e16
--- /dev/null
+++ b/sys-apps/prctl/prctl-1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to query and modify process behavior"
+HOMEPAGE="http://sourceforge.net/projects/prctl/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64"
+IUSE=""
+DEPEND="sys-apps/groff"
+
+src_compile() {
+ econf || die
+ emake \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ # emake doesn't work
+ dobin prctl
+ doman prctl.1
+ dodoc Changelog
+}