summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-06 12:28:35 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-06 12:28:35 +0000
commit5755352fee7c7247e51f7b2399bde588c5a8f520 (patch)
treeae420f7ac4fba6a64236fc6fdd20f19822960f94 /sys-apps/procps
parentadd patch to fix command line operation with top (diff)
downloadgentoo-2-5755352fee7c7247e51f7b2399bde588c5a8f520.tar.gz
gentoo-2-5755352fee7c7247e51f7b2399bde588c5a8f520.tar.bz2
gentoo-2-5755352fee7c7247e51f7b2399bde588c5a8f520.zip
add patch to fix command line operation with top
Diffstat (limited to 'sys-apps/procps')
-rw-r--r--sys-apps/procps/ChangeLog8
-rw-r--r--sys-apps/procps/Manifest4
-rw-r--r--sys-apps/procps/files/digest-procps-3.1.11-r12
-rw-r--r--sys-apps/procps/files/procps-3.1.11-multipids.patch11
-rw-r--r--sys-apps/procps/procps-3.1.11-r1.ebuild61
5 files changed, 83 insertions, 3 deletions
diff --git a/sys-apps/procps/ChangeLog b/sys-apps/procps/ChangeLog
index a38bb73823a8..ae9e8fc2d48b 100644
--- a/sys-apps/procps/ChangeLog
+++ b/sys-apps/procps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/procps
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.37 2003/07/14 14:54:11 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.38 2003/09/06 12:28:30 liquidx Exp $
+
+*procps-3.1.11-r1 (06 Sep 2003)
+
+ 06 Sep 2003; Alastair Tse <liquidx@gentoo.org> procps-3.1.11-r1.ebuild:
+ adds one-line patch to fix command line options parsing for top. patch thanks
+ to Jason Rhinelander <jason-gentoo@gossamer-threads.com> (#26090)
*procps-3.1.11 (14 Jul 2003)
diff --git a/sys-apps/procps/Manifest b/sys-apps/procps/Manifest
index 17b8edcc0b78..5d1ba6c35aa2 100644
--- a/sys-apps/procps/Manifest
+++ b/sys-apps/procps/Manifest
@@ -1,7 +1,7 @@
-MD5 a24417c856f15e467bf7b8abb101ae73 ChangeLog 6569
+MD5 fb27393e5ba1697aabd78d9bccdf3d63 ChangeLog 6823
MD5 98aea88d73018d7e4780cc247a3abc4f procps-2.0.10-r1.ebuild 1899
MD5 6be8ba2a0b5689f99cb12fce0469ab02 procps-2.0.11.ebuild 1887
-MD5 6933a15f66e27f7a413658564b54021a procps-3.1.11-r1.ebuild 1656
+MD5 328e14b5111c514e96f005858d3cb476 procps-3.1.11-r1.ebuild 1657
MD5 423255e2a65644982497e6e35620ee82 procps-3.1.11.ebuild 1487
MD5 db5b9cf1edf467b0986b52f1af1d3b6c procps-3.1.8.ebuild 1466
MD5 8cc1a60ff8e3d32e3d8cb07fe9ab3771 procps-3.1.9.ebuild 1478
diff --git a/sys-apps/procps/files/digest-procps-3.1.11-r1 b/sys-apps/procps/files/digest-procps-3.1.11-r1
new file mode 100644
index 000000000000..4dc6defd33a7
--- /dev/null
+++ b/sys-apps/procps/files/digest-procps-3.1.11-r1
@@ -0,0 +1,2 @@
+MD5 18d6c40c61fd8a94b315c07e949837ab procps-3.1.11.tar.gz 242320
+MD5 6e144b0f65b2bb67b2ecfabbe5e7dfe1 procps-3.1.8-selinux.patch.bz2 764
diff --git a/sys-apps/procps/files/procps-3.1.11-multipids.patch b/sys-apps/procps/files/procps-3.1.11-multipids.patch
new file mode 100644
index 000000000000..537a7614e3a9
--- /dev/null
+++ b/sys-apps/procps/files/procps-3.1.11-multipids.patch
@@ -0,0 +1,11 @@
+--- top.c 2003-05-24 02:48:47.000000000 +0100
++++ top.multiple_pids_are_OK.c 2003-09-06 11:31:52.000000000 +0100
+@@ -1765,7 +1765,7 @@
+ break;
+ case 'p':
+ do {
+- if (selection_type) std_err("conflicting process selection");
++ if (selection_type && selection_type != 'p') std_err("conflicting process selection");
+ selection_type = 'p';
+ if (cp[1]) cp++;
+ else if (*args) cp = *args++;
diff --git a/sys-apps/procps/procps-3.1.11-r1.ebuild b/sys-apps/procps/procps-3.1.11-r1.ebuild
new file mode 100644
index 000000000000..74140bdcf5c5
--- /dev/null
+++ b/sys-apps/procps/procps-3.1.11-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-3.1.11-r1.ebuild,v 1.1 2003/09/06 12:28:30 liquidx Exp $
+
+IUSE="selinux"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard informational utilities and process-handling tools -ps top tload snice vmstat free w watch uptime pmap skill pkill kill pgrep sysctl"
+SRC_URI="http://${PN}.sf.net/${P}.tar.gz
+ selinux? mirror://gentoo/${PN}-3.1.8-selinux.patch.bz2"
+HOMEPAGE="http://procps.sourceforge.net/"
+
+inherit flag-o-matic
+
+replace-flags "-O3" "-O2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~arm ~mips"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.10.35
+ selinux? ( >=sys-apps/selinux-small-2003011510-r2 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use selinux && epatch ${DISTDIR}/${PN}-3.1.8-selinux.patch.bz2
+
+ # fix multiple-pids for cli top
+ einfo "Applying ${PN}-3.1.11-multipids.patch .."
+ cd ${S}; patch -p0 < ${FILESDIR}/${PN}-3.1.11-multipids.patch || die "patch failed"
+
+ # Use the CFLAGS from /etc/make.conf.
+ for file in `find . -iname "Makefile"`;do
+ mv ${file} ${file}.orig
+ sed -e "s:-O2:${CFLAGS}:" ${file}.orig > ${file}
+ done
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR="${D}"|| die
+
+ dodoc BUGS COPYING COPYING.LIB NEWS TODO
+ docinto proc
+ dodoc proc/COPYING
+ docinto ps
+ dodoc ps/COPYING ps/HACKING
+}
+
+pkg_postinst() {
+ einfo "NOTE: By default \"ps\" and \"top\" no longer"
+ einfo "show threads. You can use the '-m' flag"
+ einfo "in ps or the 'H' key in top to show them"
+}