summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-01 22:07:33 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-01 22:07:33 +0000
commitda0989baa704b30a4486e06d728b940c31e5e8ef (patch)
tree46555b59ec5c607bfcc6734c87761adf4e8e8c70 /sys-apps/psmisc
parentVersion bump. Fixes bugs #71715 and #71837. (Manifest recommit) (diff)
downloadgentoo-2-da0989baa704b30a4486e06d728b940c31e5e8ef.tar.gz
gentoo-2-da0989baa704b30a4486e06d728b940c31e5e8ef.tar.bz2
gentoo-2-da0989baa704b30a4486e06d728b940c31e5e8ef.zip
Version bump.
Diffstat (limited to 'sys-apps/psmisc')
-rw-r--r--sys-apps/psmisc/ChangeLog7
-rw-r--r--sys-apps/psmisc/files/digest-psmisc-21.51
-rw-r--r--sys-apps/psmisc/psmisc-21.5.ebuild53
3 files changed, 60 insertions, 1 deletions
diff --git a/sys-apps/psmisc/ChangeLog b/sys-apps/psmisc/ChangeLog
index b9df4c910348..0ba93098dbab 100644
--- a/sys-apps/psmisc/ChangeLog
+++ b/sys-apps/psmisc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/psmisc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/ChangeLog,v 1.44 2005/01/01 21:16:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/ChangeLog,v 1.45 2005/01/01 22:07:33 vapier Exp $
+
+*psmisc-21.5 (01 Jan 2005)
+
+ 01 Jan 2005; Mike Frysinger <vapier@gentoo.org> +psmisc-21.5.ebuild:
+ Version bump.
01 Jan 2005; Mike Frysinger <vapier@gentoo.org>
-files/psmisc-21.4-no-nls-selinux.patch, files/psmisc-21.4-no-nls.patch,
diff --git a/sys-apps/psmisc/files/digest-psmisc-21.5 b/sys-apps/psmisc/files/digest-psmisc-21.5
new file mode 100644
index 000000000000..18d588766026
--- /dev/null
+++ b/sys-apps/psmisc/files/digest-psmisc-21.5
@@ -0,0 +1 @@
+MD5 c62b09ad5129e2f7e4611019d1d3d4b8 psmisc-21.5.tar.gz 382603
diff --git a/sys-apps/psmisc/psmisc-21.5.ebuild b/sys-apps/psmisc/psmisc-21.5.ebuild
new file mode 100644
index 000000000000..03952924969c
--- /dev/null
+++ b/sys-apps/psmisc/psmisc-21.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/psmisc/psmisc-21.5.ebuild,v 1.1 2005/01/01 22:07:33 vapier Exp $
+
+inherit eutils
+
+SELINUX_PATCH="${P}-selinux.diff.bz2"
+
+DESCRIPTION="A set of tools that use the proc filesystem"
+HOMEPAGE="http://psmisc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/psmisc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls selinux"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}
+ epunt_cxx #73632
+}
+
+src_compile() {
+ local myconf=""
+ use selinux && myconf="${myconf} --enable-flask"
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ # Some packages expect these to use /usr, others to use /
+ dodir /usr/bin
+ cd "${D}"/bin
+ for f in * ; do
+ dosym /bin/${f} /usr/bin/${f}
+ done
+
+ dodoc AUTHORS ChangeLog NEWS README
+}