summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-10-06 13:37:56 +0000
committerMike Frysinger <vapier@gentoo.org>2007-10-06 13:37:56 +0000
commit7c6bed7bee8f3614ccea6ff9462220543284df3b (patch)
tree75e26e32a6507c99de88043e9f6f0469ebfc92c3 /sys-apps/rlocate
parentold (diff)
downloadgentoo-2-7c6bed7bee8f3614ccea6ff9462220543284df3b.tar.gz
gentoo-2-7c6bed7bee8f3614ccea6ff9462220543284df3b.tar.bz2
gentoo-2-7c6bed7bee8f3614ccea6ff9462220543284df3b.zip
Version bump #191073 by Juan Aguado.
(Portage version: 2.1.3.11)
Diffstat (limited to 'sys-apps/rlocate')
-rw-r--r--sys-apps/rlocate/ChangeLog8
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.5.63
-rw-r--r--sys-apps/rlocate/files/rlocated.confd5
-rwxr-xr-xsys-apps/rlocate/files/rlocated.rc8
-rw-r--r--sys-apps/rlocate/rlocate-0.5.6.ebuild52
5 files changed, 71 insertions, 5 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index c4a3a8c710c1..fe313bec3f6e 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.24 2007/06/02 19:01:37 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.25 2007/10/06 13:37:56 vapier Exp $
+
+*rlocate-0.5.6 (06 Oct 2007)
+
+ 06 Oct 2007; Mike Frysinger <vapier@gentoo.org> +files/rlocated.confd,
+ files/rlocated.rc, +rlocate-0.5.6.ebuild:
+ Version bump #191073 by Juan Aguado.
02 Jun 2007; Matthias Schwarzott <zzam@gentoo.org> +files/updatedb.conf,
rlocate-0.5.5.ebuild:
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.5.6 b/sys-apps/rlocate/files/digest-rlocate-0.5.6
new file mode 100644
index 000000000000..c6e99b7de35c
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.5.6
@@ -0,0 +1,3 @@
+MD5 b834e2b1249fba9138bea29a030de46c rlocate-0.5.6.tar.gz 182910
+RMD160 6cbb3d09d3c54a6d8855cee348602b6ba2dc5845 rlocate-0.5.6.tar.gz 182910
+SHA256 5bf35c68234885d84ac5f9df65e99d11012331d6b209c42f16df72100b880bc8 rlocate-0.5.6.tar.gz 182910
diff --git a/sys-apps/rlocate/files/rlocated.confd b/sys-apps/rlocate/files/rlocated.confd
new file mode 100644
index 000000000000..069210d2d233
--- /dev/null
+++ b/sys-apps/rlocate/files/rlocated.confd
@@ -0,0 +1,5 @@
+# /etc/conf.d/rlocated
+
+# Custom options to pass to rlocated
+
+RLOCATED_OPTIONS=""
diff --git a/sys-apps/rlocate/files/rlocated.rc b/sys-apps/rlocate/files/rlocated.rc
index 8a0ea2d1c510..7c5e7d57e996 100755
--- a/sys-apps/rlocate/files/rlocated.rc
+++ b/sys-apps/rlocate/files/rlocated.rc
@@ -1,17 +1,17 @@
#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/files/rlocated.rc,v 1.2 2006/04/18 22:37:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/files/rlocated.rc,v 1.3 2007/10/06 13:37:56 vapier Exp $
start() {
- if [[ ! -e /proc/rlocate ]] ; then
+ if [ ! -e /proc/rlocate ] ; then
ebegin "Loading rlocate kernel module"
modprobe rlocate
eend $? || return 1
fi
ebegin "Starting rlocated"
- rlocated
+ rlocated ${RLOCATED_OPTIONS}
eend $?
}
diff --git a/sys-apps/rlocate/rlocate-0.5.6.ebuild b/sys-apps/rlocate/rlocate-0.5.6.ebuild
new file mode 100644
index 000000000000..73ef502b29d6
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.5.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.6.ebuild,v 1.1 2007/10/06 13:37:56 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/src/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.3-build.patch
+}
+
+src_compile() {
+ econf \
+ --with-kernel=${KV_DIR} \
+ --with-rlocate-group=locate \
+ || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated || die
+ newconfd "${FILESDIR}"/rlocated.confd rlocated || die
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+ keepdir /var/lib/rlocate
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+}