summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-06-02 19:01:37 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-06-02 19:01:37 +0000
commitbcf354457fb3efea95b3d9f8eedf2c96fee64866 (patch)
tree0e7fa745a31870cde84e4bb1eb7d501408f998ac /sys-apps/rlocate
parentP.mask libgii and libggi as it doesn't compile and mask ggi use-flag (diff)
downloadgentoo-2-bcf354457fb3efea95b3d9f8eedf2c96fee64866.tar.gz
gentoo-2-bcf354457fb3efea95b3d9f8eedf2c96fee64866.tar.bz2
gentoo-2-bcf354457fb3efea95b3d9f8eedf2c96fee64866.zip
Added updatedb.conf file of slocate, fixing Bug #162739.
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-apps/rlocate')
-rw-r--r--sys-apps/rlocate/ChangeLog6
-rw-r--r--sys-apps/rlocate/files/updatedb.conf11
-rw-r--r--sys-apps/rlocate/rlocate-0.5.5.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index 945ccad87a33..c4a3a8c710c1 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.23 2007/06/02 10:20:29 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.24 2007/06/02 19:01:37 zzam Exp $
+
+ 02 Jun 2007; Matthias Schwarzott <zzam@gentoo.org> +files/updatedb.conf,
+ rlocate-0.5.5.ebuild:
+ Added updatedb.conf file of slocate, fixing Bug #162739.
02 Jun 2007; Matthias Schwarzott <zzam@gentoo.org> rlocate-0.5.5.ebuild:
Make sure /var/lib/rlocate exists, solving Bug #144229.
diff --git a/sys-apps/rlocate/files/updatedb.conf b/sys-apps/rlocate/files/updatedb.conf
new file mode 100644
index 000000000000..08d2d6eb3417
--- /dev/null
+++ b/sys-apps/rlocate/files/updatedb.conf
@@ -0,0 +1,11 @@
+# /etc/updatedb.conf: config file for slocate/rlocate
+# $Id: updatedb.conf,v 1.1 2007/06/02 19:01:37 zzam Exp $
+
+# This file sets variables that are used by updatedb.
+# For more info, see the updatedb(1) manpage.
+
+# Filesystems that are pruned from updatedb database
+PRUNEFS="afs auto autofs cifs devfs devpts eventpollfs futexfs gfs hugetlbfs iso9660 mqueue ncpfs nfs NFS nfs4 nfsd nnpfs pipefs proc ramfs rpc_pipefs selinuxfs sfs shfs smbfs sockfs subfs supermount sysfs tmpfs udf usbfs vperfctrfs"
+
+# Paths which are pruned from updatedb database
+PRUNEPATHS="/tmp /var/tmp /root/.ccache"
diff --git a/sys-apps/rlocate/rlocate-0.5.5.ebuild b/sys-apps/rlocate/rlocate-0.5.5.ebuild
index f6f050a66656..3afe09b24e92 100644
--- a/sys-apps/rlocate/rlocate-0.5.5.ebuild
+++ b/sys-apps/rlocate/rlocate-0.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.5.ebuild,v 1.2 2007/06/02 10:20:29 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.5.ebuild,v 1.3 2007/06/02 19:01:37 zzam Exp $
inherit eutils linux-mod
@@ -46,4 +46,6 @@ src_install() {
linux-mod_src_install
dodoc AUTHORS ChangeLog* NEWS README
keepdir /var/lib/rlocate
+ insinto /etc
+ doins "${FILESDIR}/updatedb.conf"
}