summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-21 02:53:18 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-21 02:53:18 +0000
commit2fc2a140e22db308dbcba5b960dfa0794b6cf103 (patch)
treed4e5686146f60c1061bddde8bf652b9156cb91c0 /sys-apps/sed/sed-3.02.80-r3.ebuild
parentNewer version along with a fix for building without X (diff)
downloadgentoo-2-2fc2a140e22db308dbcba5b960dfa0794b6cf103.tar.gz
gentoo-2-2fc2a140e22db308dbcba5b960dfa0794b6cf103.tar.bz2
gentoo-2-2fc2a140e22db308dbcba5b960dfa0794b6cf103.zip
binutils will now build man pages correctly out of bootstrap; lilo no longer
looks for /etc/rc.d/config/functions; sed no longer uses "try".
Diffstat (limited to 'sys-apps/sed/sed-3.02.80-r3.ebuild')
-rw-r--r--sys-apps/sed/sed-3.02.80-r3.ebuild53
1 files changed, 22 insertions, 31 deletions
diff --git a/sys-apps/sed/sed-3.02.80-r3.ebuild b/sys-apps/sed/sed-3.02.80-r3.ebuild
index c35d128af82a..92691360217f 100644
--- a/sys-apps/sed/sed-3.02.80-r3.ebuild
+++ b/sys-apps/sed/sed-3.02.80-r3.ebuild
@@ -1,50 +1,41 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80-r3.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-3.02.80-r3.ebuild,v 1.2 2001/12/21 02:53:18 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Super-useful stream editor"
-SRC_URI="ftp://alpha.gnu.org/pub/gnu/sed/${A}"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/sed/${P}.tar.gz"
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --prefix=/usr --host=${CHOST} ${myconf}
- if [ -z "`use static`" ]
- then
- try make ${MAKEOPTS}
- else
- try make ${MAKEOPTS} LDFLAGS=-static
- fi
+ local myconf
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ if [ -z "`use static`" ]
+ then
+ emake || die
+ else
+ emake LDFLAGS=-static || die
+ fi
}
src_install() {
-
- into /
+ into /
dobin sed/sed
dodir /usr/bin
dosym ../../bin/sed /usr/bin/sed
-
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- into /usr
- doinfo doc/sed.info
- doman doc/sed.1
- dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE
+ if [ -z "`use build`" ]
+ then
+ into /usr
+ doinfo doc/sed.info
+ doman doc/sed.1
+ dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE
else
rm -rf ${D}/usr/share
- fi
-
+ fi
}