summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-18 00:51:44 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-18 00:51:44 +0000
commit73f7b7bf4f8b950c9564b6555e4b491210b7a717 (patch)
tree0285d421b310c4608e27ca1c102acd009148602b /sys-apps/sed/sed-4.0.5.ebuild
parentdigest.stray (diff)
downloadgentoo-2-73f7b7bf4f8b950c9564b6555e4b491210b7a717.tar.gz
gentoo-2-73f7b7bf4f8b950c9564b6555e4b491210b7a717.tar.bz2
gentoo-2-73f7b7bf4f8b950c9564b6555e4b491210b7a717.zip
bump
Diffstat (limited to 'sys-apps/sed/sed-4.0.5.ebuild')
-rw-r--r--sys-apps/sed/sed-4.0.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/sed/sed-4.0.5.ebuild b/sys-apps/sed/sed-4.0.5.ebuild
new file mode 100644
index 000000000000..09a425baf6d3
--- /dev/null
+++ b/sys-apps/sed/sed-4.0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.5.ebuild,v 1.1 2002/12/18 00:51:44 lostlogic Exp $
+
+IUSE="nls static build"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Super-useful stream editor"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/sed/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/sed/sed.html"
+KEYWORDS="~x86 -ppc ~sparc ~alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ econf ${myconf} || die
+ if [ -z "`use static`" ]
+ then
+ emake || die
+ else
+ emake LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+ into /
+ dobin sed/sed
+ dodir /usr/bin
+ dosym ../../bin/sed /usr/bin/sed
+ if [ -z "`use build`" ]
+ then
+ into /usr
+ doinfo doc/sed.info*
+ doman doc/sed.1
+ dodoc COPYING NEWS README* THANKS TODO AUTHORS BUGS ANNOUNCE ChangeLog
+ else
+ rm -rf ${D}/usr/share
+ fi
+}