summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-06-29 21:33:51 +0000
committerMike Frysinger <vapier@gentoo.org>2009-06-29 21:33:51 +0000
commit5aecc87e872d031bc917e4ee97301134a7ff91cc (patch)
tree0c3c555ad3447bdf6995d0d9e3398021df6667e5 /sys-apps/sed
parentamd64/x86 stable, bug #275176 (diff)
downloadgentoo-2-5aecc87e872d031bc917e4ee97301134a7ff91cc.tar.gz
gentoo-2-5aecc87e872d031bc917e4ee97301134a7ff91cc.tar.bz2
gentoo-2-5aecc87e872d031bc917e4ee97301134a7ff91cc.zip
Version bump #275781 by Lars Wendler.
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/ChangeLog7
-rw-r--r--sys-apps/sed/sed-4.2.1.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index 00584a0ca8ba..cf779271301b 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sed
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.93 2009/05/29 19:41:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.94 2009/06/29 21:33:51 vapier Exp $
+
+*sed-4.2.1 (29 Jun 2009)
+
+ 29 Jun 2009; Mike Frysinger <vapier@gentoo.org> +sed-4.2.1.ebuild:
+ Version bump #275781 by Lars Wendler.
29 May 2009; Diego E. Pettenò <flameeyes@gentoo.org> sed-4.2.ebuild:
Replace sys-apps/acl dependency with virtual/acl, unbreaking
diff --git a/sys-apps/sed/sed-4.2.1.ebuild b/sys-apps/sed/sed-4.2.1.ebuild
new file mode 100644
index 000000000000..4c7d8ebde418
--- /dev/null
+++ b/sys-apps/sed/sed-4.2.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.2.1.ebuild,v 1.1 2009/06/29 21:33:51 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Super-useful stream editor"
+HOMEPAGE="http://sed.sourceforge.net/"
+SRC_URI="mirror://gnu/sed/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="acl nls static"
+
+RDEPEND="nls? ( virtual/libintl )
+ acl? ( virtual/acl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_bootstrap_sed() {
+ # make sure system-sed works #40786
+ export NO_SYS_SED=""
+ if ! type -p sed > /dev/null ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed "${T}"/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ make clean || die "couldnt clean"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.1.5-alloca.patch
+ # don't use sed here if we have to recover a broken host sed
+}
+
+src_compile() {
+ src_bootstrap_sed
+ # this has to be after the bootstrap portion
+ sed -i \
+ -e '/docdir =/s:=.*/doc:= $(datadir)/doc/'${PF}'/html:' \
+ doc/Makefile.in || die "sed html doc"
+
+ local myconf= bindir=/bin
+ if ! use userland_GNU ; then
+ myconf="--program-prefix=g"
+ bindir=/usr/bin
+ fi
+
+ use static && append-ldflags -static
+ econf \
+ --bindir=${bindir} \
+ $(use_enable acl) \
+ $(use_enable nls) \
+ ${myconf}
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Install failed"
+ dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
+ docinto examples
+ dodoc "${FILESDIR}"/{dos2unix,unix2dos}
+}