summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-06-27 14:38:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-06-27 14:38:10 +0000
commit658bfa99cffe10340f6bcec20272c22f641afd64 (patch)
treea572d1285764aebc4a98b1a7c1509266f5dda41c /sys-apps/sg3_utils
parentMarking dhcp-3.1.1 ppc for bug 227135 (diff)
downloadgentoo-2-658bfa99cffe10340f6bcec20272c22f641afd64.tar.gz
gentoo-2-658bfa99cffe10340f6bcec20272c22f641afd64.tar.bz2
gentoo-2-658bfa99cffe10340f6bcec20272c22f641afd64.zip
Bug #229653, fix need for stdint.h headers thanks to Ed Catmur <ed@catmur.co.uk>.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog9
-rw-r--r--sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch31
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.26-r1.ebuild31
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index a62fd4bdd2d5..577d05f51f76 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.42 2008/06/25 17:33:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.43 2008/06/27 14:38:10 robbat2 Exp $
+
+*sg3_utils-1.26-r1 (27 Jun 2008)
+
+ 27 Jun 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/sg3_utils-1.26-stdint.patch, +sg3_utils-1.26-r1.ebuild:
+ Bug #229653, fix need for stdint.h headers thanks to Ed Catmur
+ <ed@catmur.co.uk>.
*sg3_utils-1.26 (25 Jun 2008)
diff --git a/sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch b/sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch
new file mode 100644
index 000000000000..a82ab6add9a4
--- /dev/null
+++ b/sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch
@@ -0,0 +1,31 @@
+From: Ed Catmur <ed@catmur.co.uk>
+Gentoo-Bug: 229653
+X-Gentoo-URL: http://bugs.gentoo.org/show_bug.cgi?id=229653
+X-Gentoo-URL: http://bugs.gentoo.org/attachment.cgi?id=158565&action=view
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+For uint64_t to be available, <stdint.h> must be included:
+http://www.opengroup.org/onlinepubs/009695399/basedefs/stdint.h.html
+
+--- include/sg_cmds_basic.h 2008/06/26 23:27:40 1.1
++++ include/sg_cmds_basic.h 2008/06/26 23:28:06
+@@ -30,6 +30,8 @@
+ *
+ */
+
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+--- include/sg_cmds_extra.h 2008/06/26 23:27:40 1.1
++++ include/sg_cmds_extra.h 2008/06/26 23:29:02
+@@ -30,6 +30,8 @@
+ *
+ */
+
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
diff --git a/sys-apps/sg3_utils/sg3_utils-1.26-r1.ebuild b/sys-apps/sg3_utils/sg3_utils-1.26-r1.ebuild
new file mode 100644
index 000000000000..e864a089c7b5
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.26-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.26-r1.ebuild,v 1.1 2008/06/27 14:38:10 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://www.torque.net/sg/"
+SRC_URI="http://www.torque.net/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_install() {
+ dodoc ChangeLog AUTHORS COVERAGE CREDITS README*
+ dodoc doc/README.doc examples/*.txt
+ newdoc scripts/README README.scripts
+ make install DESTDIR="${D}" || die "make install failed"
+ dosbin scripts/{scsi,sas}*
+}