summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
commit36d7d63fc8e533a54bc3008fe078d25b06cc0d55 (patch)
treebbf6a3f305a5e307e2b8b191680365bd8b5a23b2 /sys-apps/sh-utils
parent*** empty log message *** (diff)
downloadgentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.gz
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.bz2
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-apps/sh-utils')
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0j-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/sh-utils/sh-utils-2.0j-r2.ebuild b/sys-apps/sh-utils/sh-utils-2.0j-r2.ebuild
new file mode 100644
index 000000000000..91711e7d9a52
--- /dev/null
+++ b/sys-apps/sh-utils/sh-utils-2.0j-r2.ebuild
@@ -0,0 +1,48 @@
+
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r2.ebuild,v 1.1 2001/02/07 15:51:28 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Your standard GNU shell utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gettext-0.10.35-r2"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ cp sys2.h sys2.h.orig
+ sed -e "s:^char \*strndup://:" sys2.h.orig > sys2.h
+}
+
+src_compile() {
+
+ try CFLAGS=\"${CFLAGS}\" ./configure --host=${CHOST} --build=${CHOST} \
+ --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
+ --without-included-regex
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ rm -rf ${D}/usr/lib
+ dodir /bin
+ cd ${D}/usr/bin
+ # We must use hostname from net-base
+ rm hostname
+ mv date echo false pwd stty su true uname ${D}/bin
+
+ cd ${S}
+ dodoc AUTHORS COPYING ChangeLog ChangeLog.0 \
+ NEWS README THANKS TODO
+}
+
+
+