summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-18 04:53:03 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-18 04:53:03 +0000
commit0f82baf16d976167db6ca734efb28152e61fe0c2 (patch)
treeb2b46ee0c3b1ae26f892faf92f725dd059980743 /sys-apps/smartmontools
parentAdd mips love #406917 by Jim Faulkner. (diff)
downloadgentoo-2-0f82baf16d976167db6ca734efb28152e61fe0c2.tar.gz
gentoo-2-0f82baf16d976167db6ca734efb28152e61fe0c2.tar.bz2
gentoo-2-0f82baf16d976167db6ca734efb28152e61fe0c2.zip
Add systemd support #371367 by Opportunist. Also add USE=selinux support.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog6
-rw-r--r--sys-apps/smartmontools/smartmontools-5.43.ebuild23
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild23
3 files changed, 21 insertions, 31 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index c8984c5d8651..968b33954f9c 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.114 2012/08/18 04:44:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.115 2012/08/18 04:53:03 vapier Exp $
+
+ 18 Aug 2012; Mike Frysinger <vapier@gentoo.org> smartmontools-5.43.ebuild,
+ smartmontools-9999.ebuild:
+ Add systemd support #371367 by Opportunist. Also add USE=selinux support.
18 Aug 2012; Mike Frysinger <vapier@gentoo.org> smartmontools-5.43.ebuild,
smartmontools-9999.ebuild:
diff --git a/sys-apps/smartmontools/smartmontools-5.43.ebuild b/sys-apps/smartmontools/smartmontools-5.43.ebuild
index 98d0f244405c..c86a8e32e5f0 100644
--- a/sys-apps/smartmontools/smartmontools-5.43.ebuild
+++ b/sys-apps/smartmontools/smartmontools-5.43.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.43.ebuild,v 1.2 2012/08/18 04:44:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.43.ebuild,v 1.3 2012/08/18 04:53:03 vapier Exp $
EAPI="3"
-inherit flag-o-matic
+inherit flag-o-matic systemd
if [[ ${PV} == "9999" ]] ; then
ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
ESVN_PROJECT="smartmontools"
@@ -20,9 +20,10 @@ HOMEPAGE="http://smartmontools.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="static minimal caps"
+IUSE="caps minimal selinux static"
-DEPEND="!minimal? ( caps? ( sys-libs/libcap-ng ) )"
+DEPEND="caps? ( sys-libs/libcap-ng )
+ selinux? ( sys-libs/libselinux )"
RDEPEND="${DEPEND}
!minimal? ( virtual/mailx )"
@@ -34,22 +35,14 @@ src_prepare() {
}
src_configure() {
- local myconf
use minimal && einfo "Skipping the monitoring daemon for minimal build."
use static && append-ldflags -static
-
- if ! use minimal; then
- myconf="${myconf} $(use_with caps libcap-ng)"
- else
- # disable it so that we stay safe
- myconf="${myconf} --without-libcap-ng"
- fi
-
econf \
--with-docdir="${EPREFIX}/usr/share/doc/${PF}" \
--with-initscriptdir="/toss-it-away" \
- ${myconf} \
- || die
+ $(use_with caps libcap-ng) \
+ $(use_with selinux) \
+ $(systemd_with_unitdir)
}
src_install() {
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index 8e4678c922fc..6cff77b8f3aa 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-9999.ebuild,v 1.9 2012/08/18 04:44:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-9999.ebuild,v 1.10 2012/08/18 04:53:03 vapier Exp $
EAPI="3"
-inherit flag-o-matic
+inherit flag-o-matic systemd
if [[ ${PV} == "9999" ]] ; then
ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
ESVN_PROJECT="smartmontools"
@@ -20,9 +20,10 @@ HOMEPAGE="http://smartmontools.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="static minimal caps"
+IUSE="caps minimal selinux static"
-DEPEND="!minimal? ( caps? ( sys-libs/libcap-ng ) )"
+DEPEND="caps? ( sys-libs/libcap-ng )
+ selinux? ( sys-libs/libselinux )"
RDEPEND="${DEPEND}
!minimal? ( virtual/mailx )"
@@ -34,22 +35,14 @@ src_prepare() {
}
src_configure() {
- local myconf
use minimal && einfo "Skipping the monitoring daemon for minimal build."
use static && append-ldflags -static
-
- if ! use minimal; then
- myconf="${myconf} $(use_with caps libcap-ng)"
- else
- # disable it so that we stay safe
- myconf="${myconf} --without-libcap-ng"
- fi
-
econf \
--with-docdir="${EPREFIX}/usr/share/doc/${PF}" \
--with-initscriptdir="/toss-it-away" \
- ${myconf} \
- || die
+ $(use_with caps libcap-ng) \
+ $(use_with selinux) \
+ $(systemd_with_unitdir)
}
src_install() {