summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-10-21 22:30:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-10-21 22:30:14 +0000
commit80796f24bc564e4bb0ec28266a5f0be813443ffe (patch)
treeeae327fab8595c592e3f4cbed92bd6018f3a30ee /sys-apps/smartmontools
parentVersion bump. Fix build with USE=-introspection, bug #383561. (diff)
downloadgentoo-2-80796f24bc564e4bb0ec28266a5f0be813443ffe.tar.gz
gentoo-2-80796f24bc564e4bb0ec28266a5f0be813443ffe.tar.bz2
gentoo-2-80796f24bc564e4bb0ec28266a5f0be813443ffe.zip
Version bump.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog8
-rw-r--r--sys-apps/smartmontools/smartmontools-5.42.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 312cf8231bcc..9c85ec423563 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.105 2011/09/15 07:58:50 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.106 2011/10/21 22:30:14 robbat2 Exp $
+
+*smartmontools-5.42 (21 Oct 2011)
+
+ 21 Oct 2011; Robin H. Johnson <robbat2@gentoo.org>
+ +smartmontools-5.42.ebuild:
+ Version bump.
*smartmontools-5.41-r1 (15 Sep 2011)
diff --git a/sys-apps/smartmontools/smartmontools-5.42.ebuild b/sys-apps/smartmontools/smartmontools-5.42.ebuild
new file mode 100644
index 000000000000..8aa32244bc64
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.42.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.42.ebuild,v 1.1 2011/10/21 22:30:14 robbat2 Exp $
+
+EAPI="3"
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux"
+fi
+
+DESCRIPTION="Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.) monitoring tools"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static minimal caps"
+
+DEPEND="!minimal? ( caps? ( sys-libs/libcap-ng ) )"
+RDEPEND="${DEPEND}
+ !minimal? ( virtual/mailx )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ #./autogen.sh
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+
+ if ! use minimal; then
+ myconf="${myconf} $(use_with caps libcap-ng)"
+ else
+ # disable it so that we stay safe
+ myconf="${myconf} --without-libcap-ng"
+ fi
+
+ econf \
+ --with-docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-initscriptdir="/toss-it-away" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ if use minimal ; then
+ dosbin smartctl || die
+ doman smartctl.8
+ else
+ emake install DESTDIR="${D}" || die
+ rm -rf "${D}"/toss-it-away
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}