summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-17 15:05:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-17 15:05:43 +0000
commitb078bbe3f680be8d7259b6e27191209d8f248da1 (patch)
tree26b1da60253012aeea3cd922affc8e3ecba7056d /sys-apps/smartmontools
parentMask caps USE flag for smartmontools until libcap-ng is keyworded. (diff)
downloadgentoo-2-b078bbe3f680be8d7259b6e27191209d8f248da1.tar.gz
gentoo-2-b078bbe3f680be8d7259b6e27191209d8f248da1.tar.bz2
gentoo-2-b078bbe3f680be8d7259b6e27191209d8f248da1.zip
Add a caps USE flag to avoid automagic dependency over libcap-ng. Thanks to Joost Ruis and Rafał Mużyło in bug #348951.
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog7
-rw-r--r--sys-apps/smartmontools/smartmontools-5.40.ebuild19
-rw-r--r--sys-apps/smartmontools/smartmontools-9999.ebuild19
3 files changed, 38 insertions, 7 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index f24c8eb0f561..a22879ec174b 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.93 2010/11/13 16:09:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.94 2010/12/17 15:05:43 flameeyes Exp $
+
+ 17 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ smartmontools-5.40.ebuild, smartmontools-9999.ebuild:
+ Add a caps USE flag to avoid automagic dependency over libcap-ng. Thanks to
+ Joost Ruis and Rafał Mużyło in bug #348951.
13 Nov 2010; Raúl Porcel <armin76@gentoo.org>
smartmontools-5.39.1.ebuild:
diff --git a/sys-apps/smartmontools/smartmontools-5.40.ebuild b/sys-apps/smartmontools/smartmontools-5.40.ebuild
index 3c9230672cfa..98d56168a72a 100644
--- a/sys-apps/smartmontools/smartmontools-5.40.ebuild
+++ b/sys-apps/smartmontools/smartmontools-5.40.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.40.ebuild,v 1.2 2010/10/27 14:37:56 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.40.ebuild,v 1.3 2010/12/17 15:05:43 flameeyes Exp $
EAPI="2"
@@ -20,9 +20,12 @@ HOMEPAGE="http://smartmontools.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="static minimal"
+IUSE="static minimal caps"
-RDEPEND="!minimal? ( virtual/mailx )"
+RDEPEND="!minimal? (
+ virtual/mailx
+ caps? ( sys-libs/libcap-ng )
+ )"
DEPEND=""
src_unpack() {
@@ -41,11 +44,21 @@ src_prepare() {
}
src_configure() {
+ local myconf
use minimal && einfo "Skipping the monitoring daemon for minimal build."
use static && append-ldflags -static
+
+ if ! use minimal; then
+ myconf="${myconf} $(use_with caps libcap-ng)"
+ else
+ # disable it so that we stay safe
+ myconf="${myconf} --without-libcap-ng"
+ fi
+
econf \
--with-docdir="/usr/share/doc/${PF}" \
--with-initscriptdir="/toss-it-away" \
+ ${myconf} \
|| die
}
diff --git a/sys-apps/smartmontools/smartmontools-9999.ebuild b/sys-apps/smartmontools/smartmontools-9999.ebuild
index 0eb01ab6d028..2ad3a162f88e 100644
--- a/sys-apps/smartmontools/smartmontools-9999.ebuild
+++ b/sys-apps/smartmontools/smartmontools-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-9999.ebuild,v 1.2 2010/01/05 03:44:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-9999.ebuild,v 1.3 2010/12/17 15:05:43 flameeyes Exp $
EAPI="2"
@@ -20,9 +20,12 @@ HOMEPAGE="http://smartmontools.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="static minimal"
+IUSE="static minimal caps"
-RDEPEND="!minimal? ( virtual/mailx )"
+RDEPEND="!minimal? (
+ virtual/mailx
+ caps? ( sys-libs/libcap-ng )
+ )"
DEPEND=""
src_unpack() {
@@ -41,11 +44,21 @@ src_prepare() {
}
src_configure() {
+ local myconf
use minimal && einfo "Skipping the monitoring daemon for minimal build."
use static && append-ldflags -static
+
+ if ! use minimal; then
+ myconf="${myconf} $(use_with caps libcap-ng)"
+ else
+ # disable it so that we stay safe
+ myconf="${myconf} --without-libcap-ng"
+ fi
+
econf \
--with-docdir="/usr/share/doc/${PF}" \
--with-initscriptdir="/toss-it-away" \
+ ${myconf} \
|| die
}