summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-24 02:48:44 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-24 02:48:44 +0000
commit6cbe8a2b21c9fdc03d5773f83cf3cb4de054f0ff (patch)
tree4d86b176149de859b4dd3c80b68daf924abc3d70 /sys-apps/stat
parentoops (diff)
downloadgentoo-2-6cbe8a2b21c9fdc03d5773f83cf3cb4de054f0ff.tar.gz
gentoo-2-6cbe8a2b21c9fdc03d5773f83cf3cb4de054f0ff.tar.bz2
gentoo-2-6cbe8a2b21c9fdc03d5773f83cf3cb4de054f0ff.zip
added selinux support
Diffstat (limited to 'sys-apps/stat')
-rw-r--r--sys-apps/stat/ChangeLog5
-rw-r--r--sys-apps/stat/files/digest-stat-2.51
-rw-r--r--sys-apps/stat/stat-2.5.ebuild14
3 files changed, 16 insertions, 4 deletions
diff --git a/sys-apps/stat/ChangeLog b/sys-apps/stat/ChangeLog
index 7a633d6710f7..fb7e57f4787e 100644
--- a/sys-apps/stat/ChangeLog
+++ b/sys-apps/stat/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for sys-apps/stat
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/stat/ChangeLog,v 1.5 2003/02/12 09:08:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/stat/ChangeLog,v 1.6 2003/03/24 02:48:44 method Exp $
*stat-2.5 (2002-02-08)
+ 23 Mar 2003; Joshua Brindle <method@gentoo.org> stat-2.5.ebuild:
+ added selinux support, thanks pebenito
+
14 Jul 2002; phoen][x <phoenix@gentoo.org> stat-2.5.ebuild :
Added LICENSE, KEYWORDS, SLOT.
diff --git a/sys-apps/stat/files/digest-stat-2.5 b/sys-apps/stat/files/digest-stat-2.5
index dfab1b146c6f..15e1d60593ab 100644
--- a/sys-apps/stat/files/digest-stat-2.5
+++ b/sys-apps/stat/files/digest-stat-2.5
@@ -1 +1,2 @@
MD5 6331813b455c254ee88347db459d5912 stat-2.5.tar.gz 11860
+MD5 283e5e1d791983ee4e57396867093f8b stat-2.5-selinux.patch.bz2 1229
diff --git a/sys-apps/stat/stat-2.5.ebuild b/sys-apps/stat/stat-2.5.ebuild
index 37e7d6b65620..9fbb2d0b964c 100644
--- a/sys-apps/stat/stat-2.5.ebuild
+++ b/sys-apps/stat/stat-2.5.ebuild
@@ -1,21 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/stat/stat-2.5.ebuild,v 1.7 2003/02/13 16:15:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/stat/stat-2.5.ebuild,v 1.8 2003/03/24 02:48:44 method Exp $
+IUSE="selinux"
S=${WORKDIR}/${P}
DESCRIPTION="A command-line stat() wrapper."
-SRC_URI="ftp://metalab.unc.edu/pub/linux/utils/file/${P}.tar.gz"
+SRC_URI="ftp://metalab.unc.edu/pub/linux/utils/file/${P}.tar.gz
+ selinux? mirror://gentoo/${P}-selinux.patch.bz2"
HOMEPAGE="http://www.gnu.org/directory/stat.html"
KEYWORDS="x86"
SLOT="0"
LICENSE="GPL-2"
-DEPEND="virtual/glibc"
+DEPEND="virtual/glibc
+ selinux? ( sys-apps/selinux-small )"
+inherit eutils
src_unpack() {
unpack ${A}
cd ${S}
+
+ use selinux && epatch ${DISTDIR}/${P}-selinux.patch.bz2
+
cp Makefile Makefile.orig
sed -e "s:-O2 -g:${CFLAGS}:" Makefile.orig > Makefile
+
}
src_compile() {