summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-19 03:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-19 03:21:25 +0000
commit1677350f96f4266a6979abe93bd38bcb42853488 (patch)
tree4f1a43f67e5deb531cbde46d4ba801a715be7e72 /sys-apps/subterfugue
parentlintool fixes for #9258 (diff)
downloadgentoo-2-1677350f96f4266a6979abe93bd38bcb42853488.tar.gz
gentoo-2-1677350f96f4266a6979abe93bd38bcb42853488.tar.bz2
gentoo-2-1677350f96f4266a6979abe93bd38bcb42853488.zip
lintool fixes for #9258
Diffstat (limited to 'sys-apps/subterfugue')
-rw-r--r--sys-apps/subterfugue/subterfugue-0.2-r1.ebuild66
1 files changed, 29 insertions, 37 deletions
diff --git a/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild b/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild
index bbcf9d6a0ad9..3e54858418ad 100644
--- a/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild
+++ b/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild
@@ -1,64 +1,56 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild,v 1.9 2002/10/05 05:39:25 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild,v 1.10 2002/10/19 03:21:24 vapier Exp $
IUSE="gtk"
S=${WORKDIR}/${P}
-
DESCRIPTION="strace meets expect"
-
-SRC_URI="mirror://sourceforge/subterfugue/subterfugue-0.2.tgz"
-
-HOMEPAGE="http://www.subterfugue.org"
+SRC_URI="mirror://sourceforge/subterfugue/${P}.tgz"
+HOMEPAGE="http://www.subterfugue.org/"
KEYWORDS="x86 -ppc"
SLOT="0"
LICENSE="GPL-2"
DEPEND=">=dev-lang/python-2.0
gtk? ( =x11-libs/gtk+-1.2* )"
+RDEPEND="${DEPEND}"
src_unpack() {
+ unpack ${A}
- unpack ${P}.tgz
-
- cd ${S}
+ cd ${S}
- cp Makefile Makefile.orig
- sed "s/python1.5/python2.0/" < Makefile.orig > Makefile
+ cp Makefile Makefile.orig
+ sed "s/python1.5/python2.0/" < Makefile.orig > Makefile
}
src_compile() {
-
- # breaks down with emake
- make || die
-
- cp dsf dsf.orig
- sed -e "s:SUBTERFUGUE_ROOT=.*:SUBTERFUGUE_ROOT=/usr/share/subterfuge/:" \
- < dsf.orig > sf
+ # breaks down with emake
+ make || die
+ cp dsf dsf.orig
+ sed -e "s:SUBTERFUGUE_ROOT=.*:SUBTERFUGUE_ROOT=/usr/share/subterfuge/:" \
+ < dsf.orig > sf
}
-src_install () {
-
- into /usr
+src_install() {
+ into /usr
- dobin sf
-
- dodoc COPYING CREDITS GNU-entry INSTALL INTERNALS NEWS README TODO
-
- doman doc/sf.1
+ dobin sf
- SH=/usr/share/subterfuge
-
- exeinto ${SH}
- doexe *.{py,pyc}
+ dodoc COPYING CREDITS GNU-entry INSTALL INTERNALS NEWS README TODO
- exeinto ${SH}/tricks
- doexe tricks/*.{py,pyc}
-
- exeinto ${SH}/modules
- doexe modules/*.so
-
-}
+ doman doc/sf.1
+
+ SH=/usr/share/subterfuge
+ exeinto ${SH}
+ doexe *.{py,pyc}
+
+ exeinto ${SH}/tricks
+ doexe tricks/*.{py,pyc}
+
+ exeinto ${SH}/modules
+ doexe modules/*.so
+}