summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-03 04:16:12 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-03 04:16:12 +0000
commit768cc8fee930253b00821ba69f9f7f543774b1ac (patch)
tree0f86d983c6945d1d73fbd82c448e417e83a70ba2 /sys-apps/syslinux
parentold (diff)
downloadgentoo-2-768cc8fee930253b00821ba69f9f7f543774b1ac.tar.gz
gentoo-2-768cc8fee930253b00821ba69f9f7f543774b1ac.tar.bz2
gentoo-2-768cc8fee930253b00821ba69f9f7f543774b1ac.zip
compile fix with latest nasm #23481
Diffstat (limited to 'sys-apps/syslinux')
-rw-r--r--sys-apps/syslinux/ChangeLog10
-rw-r--r--sys-apps/syslinux/files/2.06-nasm.patch25
-rw-r--r--sys-apps/syslinux/syslinux-2.05.ebuild10
-rw-r--r--sys-apps/syslinux/syslinux-2.06.ebuild10
4 files changed, 50 insertions, 5 deletions
diff --git a/sys-apps/syslinux/ChangeLog b/sys-apps/syslinux/ChangeLog
index 69c58fa556ae..a6d640e190e5 100644
--- a/sys-apps/syslinux/ChangeLog
+++ b/sys-apps/syslinux/ChangeLog
@@ -1,14 +1,22 @@
# ChangeLog for sys-apps/syslinux
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Id: ChangeLog,v 1.12 2003/09/01 17:19:43 mholzer Exp $
+# $Id: ChangeLog,v 1.13 2003/09/03 04:16:12 vapier Exp $
*syslinux-2.06 (01 Sep 2003)
+ 02 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add patch to compile against latest nasm #23481.
+ Patch made by bartron <bartron@gmx.net>.
+
01 Sep 2003; Martin Holzer <mholzer@gentoo.org> syslinux-2.06.ebuild:
Version bumped.
*syslinux-2.05 (31 Aug 2003)
+ 02 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add patch to compile against latest nasm #23481.
+ Patch made by bartron <bartron@gmx.net>.
+
31 Aug 2003; Martin Holzer <mholzer@gentoo.org> syslinux-2.05.ebuild:
Version bumped.
diff --git a/sys-apps/syslinux/files/2.06-nasm.patch b/sys-apps/syslinux/files/2.06-nasm.patch
new file mode 100644
index 000000000000..21ed9a1bdc82
--- /dev/null
+++ b/sys-apps/syslinux/files/2.06-nasm.patch
@@ -0,0 +1,25 @@
+diff -urN syslinux-2.04.orig/memdisk/Makefile syslinux-2.04/memdisk/Makefile
+--- syslinux-2.04.orig/memdisk/Makefile 2003-04-15 00:28:04.000000000 +0200
++++ syslinux-2.04/memdisk/Makefile 2003-09-01 00:29:23.000000000 +0200
+@@ -60,10 +60,10 @@
+ echo '.code16gcc' | cat - $< > $@
+
+ %.s: %.S
+- $(CC) -x c $(INCLUDE) $(CFLAGS) -traditional -E -o $@ $<
++ $(CC) -x assembler-with-cpp $(INCLUDE) $(CFLAGS) -traditional -E -o $@ $<
+
+ %.s16: %.S16
+- $(CC) -x c $(INCLUDE) $(CFLAGS) -traditional -E -o $@ $<
++ $(CC) -x assembler-with-cpp $(INCLUDE) $(CFLAGS) -traditional -E -o $@ $<
+
+ %.s: %.c
+ $(CC) $(INCLUDE) $(CFLAGS) -S -o $@ $<
+@@ -98,7 +98,7 @@
+ .depend:
+ rm -f .depend
+ for csrc in *.c ; do $(CC) $(INCLUDE) -MM $$csrc | sed -e 's/\.o/\.s/' >> .depend ; done
+- for ssrc in $(SSRC) ; do $(CC) $(INCLUDE) -x c -traditional -MM $$ssrc | sed -e 's/\.S16\.o/\.o16/' >> .depend ; done
++ for ssrc in $(SSRC) ; do $(CC) $(INCLUDE) -x assembler-with-cpp -traditional -MM $$ssrc | sed -e 's/\.o/\.o16/' >> .depend ; done
+ for nsrc in $(NASMSRC) ; do $(NASM) -DDEPEND $(NINCLUDE) -o `echo $$nsrc | sed -e 's/\.asm/\.bin/'` -M $$nsrc >> .depend ; done
+
+ depend:
diff --git a/sys-apps/syslinux/syslinux-2.05.ebuild b/sys-apps/syslinux/syslinux-2.05.ebuild
index ccb258ca8588..15b1d63f6c6e 100644
--- a/sys-apps/syslinux/syslinux-2.05.ebuild
+++ b/sys-apps/syslinux/syslinux-2.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslinux/syslinux-2.05.ebuild,v 1.1 2003/08/31 19:14:52 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslinux/syslinux-2.05.ebuild,v 1.2 2003/09/03 04:16:12 vapier Exp $
DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
HOMEPAGE="http://syslinux.zytor.com/"
@@ -13,8 +13,14 @@ SLOT="0"
DEPEND="dev-lang/nasm
app-admin/mtools"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/2.06-nasm.patch
sed -i 's:$(MAKE) -C win32 all::' Makefile
+}
+
+src_compile() {
emake || die
}
diff --git a/sys-apps/syslinux/syslinux-2.06.ebuild b/sys-apps/syslinux/syslinux-2.06.ebuild
index 52a6f68c5a23..8144e1ac9278 100644
--- a/sys-apps/syslinux/syslinux-2.06.ebuild
+++ b/sys-apps/syslinux/syslinux-2.06.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslinux/syslinux-2.06.ebuild,v 1.2 2003/09/01 17:21:04 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslinux/syslinux-2.06.ebuild,v 1.3 2003/09/03 04:16:12 vapier Exp $
DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
HOMEPAGE="http://syslinux.zytor.com/"
@@ -13,8 +13,14 @@ SLOT="0"
DEPEND="dev-lang/nasm
app-admin/mtools"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-nasm.patch
sed -i 's:$(MAKE) -C win32 all::' Makefile
+}
+
+src_compile() {
emake || die
}