summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNate Underwood <natey@gentoo.org>2003-06-26 23:21:32 +0000
committerNate Underwood <natey@gentoo.org>2003-06-26 23:21:32 +0000
commitef7fcafa31220ced98347a2b41c54788a540dc30 (patch)
treecc6bd6378a8b1a98f17d0d852b5a8c3a85a74197 /sys-apps/systrace/systrace-1.0-r4.ebuild
parentEbuild bump for new userland sources. Modified ACCEPT_KEYWORDS back to ~x86 (diff)
downloadgentoo-2-ef7fcafa31220ced98347a2b41c54788a540dc30.tar.gz
gentoo-2-ef7fcafa31220ced98347a2b41c54788a540dc30.tar.bz2
gentoo-2-ef7fcafa31220ced98347a2b41c54788a540dc30.zip
Ebuild bump for new userland sources. Modified ACCEPT_KEYWORDS back to ~x86
Diffstat (limited to 'sys-apps/systrace/systrace-1.0-r4.ebuild')
-rw-r--r--sys-apps/systrace/systrace-1.0-r4.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/systrace/systrace-1.0-r4.ebuild b/sys-apps/systrace/systrace-1.0-r4.ebuild
new file mode 100644
index 000000000000..e84685004049
--- /dev/null
+++ b/sys-apps/systrace/systrace-1.0-r4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systrace/systrace-1.0-r4.ebuild,v 1.1 2003/06/26 23:21:23 natey Exp $
+
+DESCRIPTION="Systrace userland binary"
+HOMEPAGE="http://www.systrace.org"
+SRC_URI="http://www.citi.umich.edu/u/provos/systrace/usr-systrace-2003-06-23.tar.gz
+ http://cvs.gentoo.org/~natey/systrace/patches/systrace.c-no_x11-1.0.patch.gz"
+SLOT="0"
+LICENSE="GPL-2"
+PATCH1="systrace.c-no_x11-1.0.patch"
+INCLUDE="/usr/include/linux/systrace.h"
+S="${WORKDIR}/${P}"
+
+KEYWORDS="~x86"
+IUSE="gtk"
+DEPEND="dev-libs/libevent
+ =sys-devel/autoconf-2.57
+ gtk? ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2* )"
+
+pkg_setup() {
+ if ! [ -f ${INCLUDE} ] ;
+ then
+ einfo
+ einfo "ERROR: It does not look like you have a systrace capable kernel. If"
+ einfo "this is incorrect, please copy /usr/src/linux/include/linux/systrace.h"
+ einfo "to /usr/include/linux/ and restart the build."
+ einfo
+ einfo "The latest systrace Linux kernel patches can be found at:"
+ einfo
+ einfo "http://www.citi.umich.edu/u/provos/systrace/linux.html"
+ einfo
+ exit 1
+ fi
+}
+
+src_compile() {
+ if [ "`use gtk`" ]
+ then
+ einfo
+ einfo "You are building systrace with gtk support; this version will not"
+ einfo "function without the sys-apps/gtk-systrace package installed. Please"
+ einfo "set the USE=\"-gtk\" to build the non-gui capable version of systrace."
+ einfo
+ sleep 7
+ autoconf-2.57
+ ./configure || die
+ elif [ -z "`use gtk`" ]
+ then
+ einfo
+ einfo "You are building systrace without gtk support; please set USE=\"gtk\""
+ einfo "to build the gui capable version of systrace."
+ einfo
+ sleep 7
+ cd ${S}
+ epatch ../${PATCH1} || die
+ autoconf-2.57
+ ./configure || die
+ fi
+
+ emake || die
+}
+
+src_install() {
+ dobin systrace
+ exeinto /usr/bin
+
+ doman systrace.1
+}