summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-10 02:58:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-10 02:58:04 +0000
commit08f54215d0d8fb030cb1981935cdd93dcb270d1d (patch)
treeae24d2b17c97f7269b3fb8eb2d75e324dda3028a /sys-apps/sysvinit
parentNew version: 19.0. Added 18.49 to x86. Removed old version: 18.38. (diff)
downloadgentoo-2-08f54215d0d8fb030cb1981935cdd93dcb270d1d.tar.gz
gentoo-2-08f54215d0d8fb030cb1981935cdd93dcb270d1d.tar.bz2
gentoo-2-08f54215d0d8fb030cb1981935cdd93dcb270d1d.zip
update shutdown docs #91724
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-apps/sysvinit')
-rw-r--r--sys-apps/sysvinit/files/sysvinit-2.86-docs.patch73
-rw-r--r--sys-apps/sysvinit/files/sysvinit-2.86-shutdown-usage.patch10
-rw-r--r--sys-apps/sysvinit/sysvinit-2.86.ebuild7
3 files changed, 88 insertions, 2 deletions
diff --git a/sys-apps/sysvinit/files/sysvinit-2.86-docs.patch b/sys-apps/sysvinit/files/sysvinit-2.86-docs.patch
new file mode 100644
index 000000000000..1ee20d9c7a9d
--- /dev/null
+++ b/sys-apps/sysvinit/files/sysvinit-2.86-docs.patch
@@ -0,0 +1,73 @@
+Sync both the content and style of `shutdown -h` and `man shutdown`.
+
+http://bugs.gentoo.org/91724
+
+--- man/shutdown.8
++++ man/shutdown.8
+@@ -11,7 +11,7 @@
+ .B /sbin/shutdown
++.RB [ \-akrhPHfFnc ]
+ .RB [ \-t
+ .IR sec ]
+-.RB [ \-arkhncfFHP ]
+ .I time
+-.RI [ warning-message ]
++.RI [ "warning message" ]
+ .\"}}}
+@@ -41,7 +41,2 @@
+ .\"}}}
+-.\"{{{ -t sec
+-.IP "\fB\-t\fP \fIsec\fP"
+-Tell \fBinit\fP(8) to wait \fIsec\fP seconds between sending processes the
+-warning and the kill signal, before changing to another runlevel.
+-.\"}}}
+ .\"{{{ -k
+@@ -58,7 +53,2 @@
+ .\"}}}
+-.\"{{{ -H
+-.IP \fB\-H\fP
+-Halt action is to halt or drop into boot monitor on systems that
+-support it.
+-.\"}}}
+ .\"{{{ -P
+@@ -67,7 +57,6 @@
+ .\"}}}
+-.\"{{{ -n
+-.IP \fB\-n\fP
+-[DEPRECATED] Don't call \fBinit\fP(8) to do the shutdown but do it ourself.
+-The use of this option is discouraged, and its results are not always what
+-you'd expect.
++.\"{{{ -H
++.IP \fB\-H\fP
++Halt action is to halt or drop into boot monitor on systems that
++support it.
+ .\"}}}
+@@ -81,2 +70,8 @@
+ .\"}}}
++.\"{{{ -n
++.IP \fB\-n\fP
++[DEPRECATED] Don't call \fBinit\fP(8) to do the shutdown but do it ourself.
++The use of this option is discouraged, and its results are not always what
++you'd expect.
++.\"}}}
+ .\"{{{ -c
+@@ -87,2 +82,7 @@
+ .\"}}}
++.\"{{{ -t sec
++.IP "\fB\-t\fP \fIsec\fP"
++Tell \fBinit\fP(8) to wait \fIsec\fP seconds between sending processes the
++warning and the kill signal, before changing to another runlevel.
++.\"}}}
+ .\"{{{ time
+@@ -92,3 +92,3 @@
+ .\"{{{ warning-message
+-.IP \fIwarning-message\fP
++.IP "\fIwarning message\fP"
+ Message to send to all users.
+--- src/shutdown.c
++++ src/shutdown.c
+@@ -104,3 +104,3 @@
+ fprintf(stderr,
+- "Usage:\t shutdown [-akrhHPfnc] [-t secs] time [warning message]\n"
++ "Usage:\t shutdown [-akrhPHfFnc] [-t sec] time [warning message]\n"
+ "\t\t -a: use /etc/shutdown.allow\n"
diff --git a/sys-apps/sysvinit/files/sysvinit-2.86-shutdown-usage.patch b/sys-apps/sysvinit/files/sysvinit-2.86-shutdown-usage.patch
new file mode 100644
index 000000000000..e69abc205fd8
--- /dev/null
+++ b/sys-apps/sysvinit/files/sysvinit-2.86-shutdown-usage.patch
@@ -0,0 +1,10 @@
+Allow non-root users to at least see the help output.
+
+http://bugs.gentoo.org/91724
+
+--- src/shutdown.c
++++ src/shutdown.c
+@@ -462,2 +462,3 @@
+ fprintf(stderr, "shutdown: you must be root to do that!\n");
++ usage();
+ exit(1);
diff --git a/sys-apps/sysvinit/sysvinit-2.86.ebuild b/sys-apps/sysvinit/sysvinit-2.86.ebuild
index 26c564c0f7ec..f45d44e983a7 100644
--- a/sys-apps/sysvinit/sysvinit-2.86.ebuild
+++ b/sys-apps/sysvinit/sysvinit-2.86.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86.ebuild,v 1.5 2005/02/21 15:31:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86.ebuild,v 1.6 2005/05/10 02:58:04 vapier Exp $
inherit eutils toolchain-funcs
@@ -20,7 +20,10 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd "${S}"/src
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-docs.patch
+ epatch "${FILESDIR}"/${P}-shutdown-usage.patch
+ cd src
epatch "${FILESDIR}"/${PV}-gentoo.patch
use selinux && epatch "${FILESDIR}"/${PV}-selinux.patch
}