summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-12-17 11:58:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-12-17 11:58:24 +0000
commitb903fb8023765f91d2acdf09cafd93e91fcac5ab (patch)
tree9349a30fd9ca5acb6caa650ff6e6f054e713a8cf /sys-apps/tcng/files
parentnew version upstream, major fixes, fix bug #35851, full tcsim support, block ... (diff)
downloadgentoo-2-b903fb8023765f91d2acdf09cafd93e91fcac5ab.tar.gz
gentoo-2-b903fb8023765f91d2acdf09cafd93e91fcac5ab.tar.bz2
gentoo-2-b903fb8023765f91d2acdf09cafd93e91fcac5ab.zip
new version upstream, major fixes, fix bug #35851, full tcsim support, block old version out as it was badly badly broken
Diffstat (limited to 'sys-apps/tcng/files')
-rw-r--r--sys-apps/tcng/files/digest-tcng-9i4
-rw-r--r--sys-apps/tcng/files/tcng-9i-fixes.patch90
-rw-r--r--sys-apps/tcng/files/tcng-9i-gentoo.patch12
3 files changed, 106 insertions, 0 deletions
diff --git a/sys-apps/tcng/files/digest-tcng-9i b/sys-apps/tcng/files/digest-tcng-9i
new file mode 100644
index 000000000000..cfcadd9c5459
--- /dev/null
+++ b/sys-apps/tcng/files/digest-tcng-9i
@@ -0,0 +1,4 @@
+MD5 50f497a7539e4c03c5783b410b132127 tcng-9i.tar.gz 514370
+MD5 b05a4e375d9468be3a1dd3f0e83daee8 iproute2-2.4.7-now-ss010824.tar.gz 140139
+MD5 ac343233aa5d745341da9e4ec22475af iproute_20010824-11.diff.gz 44736
+MD5 642af5ab5e1fc63685fde85e9ae601e4 linux-2.4.23.tar.bz2 29832609
diff --git a/sys-apps/tcng/files/tcng-9i-fixes.patch b/sys-apps/tcng/files/tcng-9i-fixes.patch
new file mode 100644
index 000000000000..f5d77e17a5bb
--- /dev/null
+++ b/sys-apps/tcng/files/tcng-9i-fixes.patch
@@ -0,0 +1,90 @@
+diff -ur tcng.orig/tcc/tcc.c tcng/tcc/tcc.c
+--- tcng.orig/tcc/tcc.c 2002-10-10 09:52:41.000000000 -0700
++++ tcng/tcc/tcc.c 2003-12-17 02:13:25.000000000 -0800
+@@ -219,7 +219,7 @@
+ *
+ * (and we'd actually need one less, because we count argv[0] twice)
+ */
+- cpp_argv[cpp_argc++] = "-$";
++ //cpp_argv[cpp_argc++] = "-$";
+ tcng_topdir = getenv("TCNG_TOPDIR");
+ include = alloc_sprintf("%s/" TCNG_INC_DIR,
+ tcng_topdir ? tcng_topdir : TOPDIR);
+@@ -333,7 +333,11 @@
+ if (optind < argc) usage(argv[0]);
+ }
+ if (input) cpp_argv[cpp_argc++] = input;
+- cpp_argv[0] = argv[0];
++
++ // ARGV[0] must be the program that execvp is calling!
++ //cpp_argv[0] = argv[0];
++ cpp_argv[0] = CPP;
++
+ if (include_default) {
+ cpp_argv[cpp_argc++] = "-include";
+ cpp_argv[cpp_argc++] = alloc_sprintf("%s/default.tc",include);
+diff -ur tcng.orig/tcsim/setup.ulib tcng/tcsim/setup.ulib
+--- tcng.orig/tcsim/setup.ulib 2003-01-14 07:25:05.000000000 -0800
++++ tcng/tcsim/setup.ulib 2003-12-17 02:03:06.000000000 -0800
+@@ -199,4 +199,7 @@
+ perl -pi -e 's/exit\(0\);/return 0;/;' iproute2/tc/$n
+ done
+
++# Sometimes 'offsetof' is NOT defined, and we need to import it
++sed -i iproute2/tc/tc_qdisc.c -e '1i#include <stddef.h>'
++
+ touch .ready
+diff -ur tcng.orig/tcsim/tcsim.c tcng/tcsim/tcsim.c
+--- tcng.orig/tcsim/tcsim.c 2002-11-14 07:49:52.000000000 -0800
++++ tcng/tcsim/tcsim.c 2003-12-17 02:13:16.000000000 -0800
+@@ -299,7 +299,7 @@
+ * +2 for -i dev
+ * +1 for terminating NULL
+ */
+- cpp_argv[cpp_argc++] = "-$";
++ //cpp_argv[cpp_argc++] = "-$";
+ tcng_topdir = getenv("TCNG_TOPDIR");
+ include = alloc_sprintf("%s/lib/tcng/include",
+ tcng_topdir ? tcng_topdir : TOPDIR);
+@@ -380,7 +380,11 @@
+ if (set_printk_threshold != -1) printk_threshold = set_printk_threshold;
+ if (kernel_init()) errorf("oops, trouble");
+ if (verbose) setup_tracing();
+- cpp_argv[0] = argv[0];
++
++ // ARGV[0] must be the program that execvp is calling!
++ //cpp_argv[0] = argv[0];
++ cpp_argv[0] = CPP;
++
+ if (include_default) {
+ cpp_argv[cpp_argc++] = "-include";
+ cpp_argv[cpp_argc++] = alloc_sprintf("%s/default.tcsim",include);;
+--- tcng.orig/tests/tstcond 2002-09-19 12:14:55.000000000 -0700
++++ tcng/tests/tstcond 2003-12-17 02:55:09.000000000 -0800
+@@ -142,7 +142,7 @@
+ ERROR
+ EOF in conditional block
+ # conditional tests: neither warn nor skip ------------------------------------
+-runtests | tail -1
++runtests | tail -n 1
+ |BEGIN CONDITIONAL
+ |true
+ |EOF
+@@ -153,7 +153,7 @@
+ EOF
+ Passed the test
+ # conditional tests: warn only ------------------------------------------------
+-runtests | tail -1
++runtests | tail -n 1
+ |BEGIN CONDITIONAL
+ |true
+ |EOF
+@@ -166,7 +166,7 @@
+ EOF
+ Passed the test (1 warning)
+ # conditional tests: warn and skip --------------------------------------------
+-runtests | tail -1
++runtests | tail -n 1
+ |BEGIN CONDITIONAL
+ |false
+ |EOF
diff --git a/sys-apps/tcng/files/tcng-9i-gentoo.patch b/sys-apps/tcng/files/tcng-9i-gentoo.patch
new file mode 100644
index 000000000000..908c83136508
--- /dev/null
+++ b/sys-apps/tcng/files/tcng-9i-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ur tcng.orig/tcsim/Makefile.unclean tcng/tcsim/Makefile.unclean
+--- tcng.orig/tcsim/Makefile.unclean 2003-11-21 19:51:01.000000000 -0800
++++ tcng/tcsim/Makefile.unclean 2003-12-17 02:05:38.000000000 -0800
+@@ -33,7 +33,7 @@
+ -I../shared
+
+ LDFLAGS=-Wl,-E
+-LIBS=-lfl -lm -ldl -L../shared -ltcngmisc $(LD_OPTS)
++LIBS=-lfl -lm -ldl -latm -L../shared -ltcngmisc $(LD_OPTS)
+
+ .PHONY: modules depend dep
+