summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-12-27 00:03:49 +0000
committerJason Wever <weeve@gentoo.org>2003-12-27 00:03:49 +0000
commit2d31b1178a346ebd0b99e2c536e83be2c97c5395 (patch)
treec7a54e4dd051c12a8dcea5f42f1894500a91ff4e /sys-apps/ucspi-unix/files
parentAdded linux-headers 2.6.0 support. (diff)
downloadgentoo-2-2d31b1178a346ebd0b99e2c536e83be2c97c5395.tar.gz
gentoo-2-2d31b1178a346ebd0b99e2c536e83be2c97c5395.tar.bz2
gentoo-2-2d31b1178a346ebd0b99e2c536e83be2c97c5395.zip
Added ~sparc keyword and a patch for 0.36 to fix the change in head syntax.
Diffstat (limited to 'sys-apps/ucspi-unix/files')
-rw-r--r--sys-apps/ucspi-unix/files/ucspi-unix-gentoo-head.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/ucspi-unix/files/ucspi-unix-gentoo-head.patch b/sys-apps/ucspi-unix/files/ucspi-unix-gentoo-head.patch
new file mode 100644
index 000000000000..fa360e53c1f1
--- /dev/null
+++ b/sys-apps/ucspi-unix/files/ucspi-unix-gentoo-head.patch
@@ -0,0 +1,33 @@
+--- ucspi-unix-0.36/Makefile.orig 2003-12-26 18:50:34.000000000 -0500
++++ ucspi-unix-0.36/Makefile 2003-12-26 18:50:56.000000000 -0500
+@@ -18,18 +18,18 @@
+ ( echo '#!/bin/sh'; \
+ echo 'source=$$1; shift'; \
+ echo 'base=`echo "$$source" | sed -e s:\\\\.c$$::`'; \
+- echo exec `head -1 conf-cc` '-I. -o $${base}.o -c $$source $${1+"$$@"}'; \
++ echo exec `head -n 1 conf-cc` '-I. -o $${base}.o -c $$source $${1+"$$@"}'; \
+ ) >compile
+ chmod 755 compile
+
+ conf_bin.c: conf-bin
+- head -1 conf-bin | \
++ head -n 1 conf-bin | \
+ sed -e 's/"/\\"/g' \
+ -e 's/^/const char conf_bin[] = "/' \
+ -e 's/$$/";/' >conf_bin.c
+
+ conf_man.c: conf-man
+- head -1 conf-man | \
++ head -n 1 conf-man | \
+ sed -e 's/"/\\"/g' \
+ -e 's/^/const char conf_man[] = "/' \
+ -e 's/$$/";/' >conf_man.c
+@@ -55,7 +55,7 @@
+ load: conf-ld
+ ( echo '#!/bin/sh';\
+ echo 'main="$$1"; shift';\
+- echo exec `head -1 conf-ld` '-o "$$main" "$$main.o" $${1+"$$@"}' -lsysdeps;\
++ echo exec `head -n 1 conf-ld` '-o "$$main" "$$main.o" $${1+"$$@"}' -lsysdeps;\
+ ) >load
+ chmod 755 load
+