summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-24 02:52:39 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-24 02:52:39 +0000
commit1685341ed78e2dfa821f02aed0f37e7a74646e26 (patch)
treec570062629d9656c4e9e0368051ecabde2c310eb /sys-apps/util-linux/util-linux-2.20.1-r1.ebuild
parentInherit eutils for epatch. (diff)
downloadgentoo-2-1685341ed78e2dfa821f02aed0f37e7a74646e26.tar.gz
gentoo-2-1685341ed78e2dfa821f02aed0f37e7a74646e26.tar.bz2
gentoo-2-1685341ed78e2dfa821f02aed0f37e7a74646e26.zip
Sync git-2 updates between all versions, and merge KEYWORDS code paths.
(Portage version: 2.2.0_alpha107_p3/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.20.1-r1.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.20.1-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild b/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild
index 75379a8bcf5c..3993cc35f94c 100644
--- a/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild
@@ -1,13 +1,18 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild,v 1.9 2012/05/12 15:56:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.20.1-r1.ebuild,v 1.10 2012/05/24 02:52:39 vapier Exp $
EAPI="3"
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
AUTOTOOLS_AUTO_DEPEND="no"
inherit eutils toolchain-funcs libtool flag-o-matic autotools
-[[ ${PV} == "9999" ]] && inherit git autotools
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-2 autotools
+ #KEYWORDS=""
+else
+ KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-linux"
+fi
MY_PV=${PV/_/-}
MY_P=${PN}-${MY_PV}
@@ -17,11 +22,9 @@ DESCRIPTION="Various useful Linux utilities"
HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
- #KEYWORDS=""
else
SRC_URI="mirror://kernel/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.bz2
loop-aes? ( http://loop-aes.sourceforge.net/updates/util-linux-2.20-20110905.diff.bz2 )"
- KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-linux"
fi
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"