summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-10 23:14:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-10 23:14:12 +0000
commit41e8021ea48a4d0d6cbc738f60c86db28e5b232c (patch)
treeb8f055ffa3351974c1d2ce271fc1f131695a717d /sys-apps/util-linux
parentmerged from apache-herd svn tree (Manifest recommit) (diff)
downloadgentoo-2-41e8021ea48a4d0d6cbc738f60c86db28e5b232c.tar.gz
gentoo-2-41e8021ea48a4d0d6cbc738f60c86db28e5b232c.tar.bz2
gentoo-2-41e8021ea48a4d0d6cbc738f60c86db28e5b232c.zip
update pic/swap patches
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.12-r52
-rw-r--r--sys-apps/util-linux/files/util-linux-2.12i-pic.patch6
-rw-r--r--sys-apps/util-linux/files/util-linux-2.12p-swapon-check-symlinks.patch2
-rw-r--r--sys-apps/util-linux/util-linux-2.12-r5.ebuild137
4 files changed, 4 insertions, 143 deletions
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.12-r5 b/sys-apps/util-linux/files/digest-util-linux-2.12-r5
deleted file mode 100644
index cedffcb9a126..000000000000
--- a/sys-apps/util-linux/files/digest-util-linux-2.12-r5
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 997adf78b98d9d1c5db4f37ea982acff util-linux-2.12.tar.gz 1857871
-MD5 1734111e696acfb6d08f52f1e1b3d024 util-linux-2.12-cryptoapi-losetup.patch.bz2 4871
diff --git a/sys-apps/util-linux/files/util-linux-2.12i-pic.patch b/sys-apps/util-linux/files/util-linux-2.12i-pic.patch
index 2725682ad9f3..8fb91be8b795 100644
--- a/sys-apps/util-linux/files/util-linux-2.12i-pic.patch
+++ b/sys-apps/util-linux/files/util-linux-2.12i-pic.patch
@@ -17,7 +17,7 @@ diff -ur util-linux-2.12i.orig/fdisk/llseek.c util-linux-2.12i/fdisk/llseek.c
-#if defined(__alpha__) || defined(__ia64__) || defined(__s390x__)
+/* do not use assembler to put together syscalls at compile time (for llseek for example) when using PIC */
-+#if defined(__alpha__) || defined(__ia64__) || defined(__s390x__) || defined(__hppa__) \
++#if defined(__alpha__) || defined(__ia64__) || defined(__s390x__) \
+ || defined(__PIC__) || defined(__pic__)
#define my_llseek lseek
@@ -39,7 +39,7 @@ diff -ur util-linux-2.12i.orig/fdisk/sfdisk.c util-linux-2.12i/fdisk/sfdisk.c
#undef use_lseek
-#if defined (__alpha__) || defined (__ia64__) || defined (__x86_64__) || defined (__s390x__)
+/* do not use the assembler constructed syscalls for seeking if compiled as PIC */
-+#if defined (__alpha__) || defined (__ia64__) || defined (__x86_64__) || defined (__s390x__) || defined (__hppa__) \
++#if defined (__alpha__) || defined (__ia64__) || defined (__x86_64__) || defined (__s390x__) \
+ || defined(__PIC__) && defined(__pic__)
#define use_lseek
#endif
@@ -52,7 +52,7 @@ diff -ur util-linux-2.12i.orig/partx/partx.c util-linux-2.12i/partx/partx.c
* sseek: seek to specified sector
*/
-#if !defined (__alpha__) && !defined (__ia64__) && !defined (__s390x__) && !defined(__x86_64__)
-+#if !defined (__alpha__) && !defined (__ia64__) && !defined (__s390x__) && !defined(__x86_64__) && !defined(__hppa__) \
++#if !defined (__alpha__) && !defined (__ia64__) && !defined (__s390x__) && !defined(__x86_64__) \
+ && !defined(__PIC__) && !defined(__pic__)
#define NEED__llseek
#endif
diff --git a/sys-apps/util-linux/files/util-linux-2.12p-swapon-check-symlinks.patch b/sys-apps/util-linux/files/util-linux-2.12p-swapon-check-symlinks.patch
index e53b84e83da4..31d78594c06a 100644
--- a/sys-apps/util-linux/files/util-linux-2.12p-swapon-check-symlinks.patch
+++ b/sys-apps/util-linux/files/util-linux-2.12p-swapon-check-symlinks.patch
@@ -24,7 +24,7 @@
+ struct stat swapstatbuf;
+ for (i = 0; i < numSwaps; i++)
+ if (swapFiles[i] && !stat(swapFiles[i], &swapstatbuf) && \
-+ swapstatbuf.st_dev == fstatbuf.st_dev)
++ swapstatbuf.st_rdev == fstatbuf.st_rdev)
+ return 1;
+ }
+
diff --git a/sys-apps/util-linux/util-linux-2.12-r5.ebuild b/sys-apps/util-linux/util-linux-2.12-r5.ebuild
deleted file mode 100644
index 9e4b68d54647..000000000000
--- a/sys-apps/util-linux/util-linux-2.12-r5.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12-r5.ebuild,v 1.20 2005/01/10 02:56:52 vapier Exp $
-
-inherit eutils flag-o-matic
-
-CRYPT_PATCH_P="${P}-cryptoapi-losetup"
-SELINUX_PATCH="util-linux-2.12-selinux.diff.bz2"
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.gz
- ftp://ftp.cwi.nl/pub/aeb/${PN}/${P}.tar.gz
- crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390 sh"
-IUSE="crypt nls static pam selinux uclibc"
-
-DEPEND="virtual/libc
- >=sys-libs/ncurses-5.2-r2
- selinux? ( sys-libs/libselinux )
- pam? ( sys-apps/pam-login )
- crypt? ( app-crypt/hashalot )"
-RDEPEND="${DEPEND}
- dev-lang/perl
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # CryptoAPI losetup patch for the cryptoapi sepecific
- # to the 2.6 linux kernel. Needs hashalot.
- # Original patch location:
- # http://www.stwing.org/~sluskyb/util-linux/losetup-combined.patch
- # Mailing list post with info:
- # http://www.kerneli.org/pipermail/cryptoapi-devel/2003-September/000634.html
- # Follow thread for usage.
- use crypt && epatch ${WORKDIR}/${CRYPT_PATCH_P}.patch
-
- # Fix rare failures with -j4 or higher
- epatch ${FILESDIR}/${PN}-2.11z-parallel-make.patch
-
- # Fix unreadable df output
- epatch ${FILESDIR}/no-symlink-resolve.patch
-
- # access() is a macro which uses R_OK however
- # R_OK is not defined on sparc during a bootstrap
- # unless we actually include unistd.h -solar (May 07 2004)
- epatch ${FILESDIR}/${PN}-2.12-swapon-unistd.patch
-
- # Add the O option to agetty to display DNS domainname in the issue
- # file, thanks to Marius Mauch <genone@genone.de>, bug #22275.
- #
- # NOTE: Removing this will break future baselayout, so PLEASE
- # consult with me before doing so.
- #
- # <azarah@gentoo.og> (17 Jul 2003)
- epatch ${FILESDIR}/${PN}-2.11z-agetty-domainname-option.patch
-
- # Add NFS4 support (kernel 2.5/2.6).
-# use crypt \
-# && epatch ${FILESDIR}/${PN}-2.11z-01-nfsv4-crypt.dif \
-# ||
- epatch ${FILESDIR}/${PN}-2.11z-01-nfsv4.dif
-
- # <solar@gentoo.org> This patch should allow us to remove -fPIC
- # out of the filter-flags we need this be able to emit position
- # independent code so we can link our elf executables as shared
- # objects. "prelink" should now also be able to take advantage
- epatch ${FILESDIR}/${PN}-2.11z-pic.patch
-
- ## see below for details on pic.patch
- case ${ARCH} in
- "x86"|"hppa"|"sparc"|"ppc"|"amd64")
- ;;
- *)
- filter-flags -fPIC
- ;;
- esac
-
- # Allow util-linux to compile with 2.6.x headers #31286
- epatch ${FILESDIR}/${P}-kernel-2.6.patch
-
- # Add support to read fat/fat32 labels, bug #36722
- epatch ${FILESDIR}/${P}-fat-LABEL-support.patch
-
- # Add support for gcloop
- epatch ${FILESDIR}/${P}-gcloop.patch
-
- # Enable pam only if we use it
- use pam && sed -i "s:HAVE_PAM=no:HAVE_PAM=yes:" MCONFIG
-
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}
-
- sed -i \
- -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
- -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
- -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
- -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
- -e "s:usr/man:usr/share/man:" \
- -e "s:usr/info:usr/share/info:" \
- -e "s:SUIDMODE=.*4755:SUIDMODE=4711:" \
- MCONFIG || die "MCONFIG sed"
-
- if ! use nls ; then
- sed -i -e 's/DISABLE_NLS=no/DISABLE_NLS=yes/' MCONFIG ||
- die "MCONFIG nls sed"
- fi
-
- # /bin/kill is provided by procps ONLY
- epatch ${FILESDIR}/${PN}-no-kill.patch
-
- # Install rdev on amd64 platform
- epatch ${FILESDIR}/${P}-amd64_rdev_installation.patch
-
- use uclibc && sed -e 's/sys_siglist\[sig\]/strsignal(sig)/' -i ${S}/mount/fstab.c
-}
-
-src_compile() {
- use static && append-ldflags -static
- econf || die "configure failed"
- emake || die "emake failed"
- cd sys-utils && makeinfo *.texi || die "makeinfo failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "install failed"
-
- dodoc HISTORY MAINTAINER README VERSION
- docinto licenses
- dodoc licenses/* HISTORY
- docinto examples
- dodoc example.files/*
-}