summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-11-09 09:10:56 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-11-09 09:10:56 +0000
commit4f44fd385c5f745a78d790fa5312596cf2a1f563 (patch)
tree609ea5686e59646e13f553b45aa45740d2cec235 /sys-apps/util-linux
parenttest phase re-invoked with known and filed failed tests excluded (diff)
downloadgentoo-2-4f44fd385c5f745a78d790fa5312596cf2a1f563.tar.gz
gentoo-2-4f44fd385c5f745a78d790fa5312596cf2a1f563.tar.bz2
gentoo-2-4f44fd385c5f745a78d790fa5312596cf2a1f563.zip
Fixed unconditional call of python-single-r1_pkg_setup (bug #490778)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog5
-rw-r--r--sys-apps/util-linux/util-linux-2.24.ebuild6
2 files changed, 9 insertions, 2 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 6ae92ef39b35..762a57e1e918 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.440 2013/10/29 20:25:08 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.441 2013/11/09 09:10:56 polynomial-c Exp $
+
+ 09 Nov 2013; Lars Wendler <polynomial-c@gentoo.org> util-linux-2.24.ebuild:
+ Fixed unconditional call of python-single-r1_pkg_setup (bug #490778).
29 Oct 2013; Lars Wendler <polynomial-c@gentoo.org> util-linux-2.24.ebuild,
util-linux-9999.ebuild:
diff --git a/sys-apps/util-linux/util-linux-2.24.ebuild b/sys-apps/util-linux/util-linux-2.24.ebuild
index 3464adf04278..358102e059f9 100644
--- a/sys-apps/util-linux/util-linux-2.24.ebuild
+++ b/sys-apps/util-linux/util-linux-2.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.24.ebuild,v 1.2 2013/10/29 20:25:08 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.24.ebuild,v 1.3 2013/11/09 09:10:56 polynomial-c Exp $
EAPI=5
@@ -51,6 +51,10 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_prepare() {
if [[ ${PV} == 9999 ]] ; then
po/update-potfiles