summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-06 06:30:17 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-06 06:30:17 +0000
commitbb502f661ea921a68bf58f38f3b2e73f88413fc5 (patch)
tree0931f24fd55ba5dcde81e4d55531f2ad4257cca0 /sys-apps/watchdog
parentInstall unit file (#466088, thanks to Doug and base-system herd for allowing ... (diff)
downloadgentoo-2-bb502f661ea921a68bf58f38f3b2e73f88413fc5.tar.gz
gentoo-2-bb502f661ea921a68bf58f38f3b2e73f88413fc5.tar.bz2
gentoo-2-bb502f661ea921a68bf58f38f3b2e73f88413fc5.zip
Install unit file (#475870, thanks to Doug and base-system herd for allowing it).
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-apps/watchdog')
-rw-r--r--sys-apps/watchdog/ChangeLog9
-rw-r--r--sys-apps/watchdog/files/watchdog.service10
-rw-r--r--sys-apps/watchdog/watchdog-5.13-r1.ebuild38
3 files changed, 56 insertions, 1 deletions
diff --git a/sys-apps/watchdog/ChangeLog b/sys-apps/watchdog/ChangeLog
index 65da6325cd53..38f312e30503 100644
--- a/sys-apps/watchdog/ChangeLog
+++ b/sys-apps/watchdog/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/watchdog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/ChangeLog,v 1.34 2013/02/08 08:18:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/ChangeLog,v 1.35 2013/07/06 06:30:17 pacho Exp $
+
+*watchdog-5.13-r1 (06 Jul 2013)
+
+ 06 Jul 2013; Pacho Ramos <pacho@gentoo.org> +files/watchdog.service,
+ +watchdog-5.13-r1.ebuild:
+ Install unit file (#475870, thanks to Doug and base-system herd for allowing
+ it).
*watchdog-5.13 (08 Feb 2013)
diff --git a/sys-apps/watchdog/files/watchdog.service b/sys-apps/watchdog/files/watchdog.service
new file mode 100644
index 000000000000..9ec1076e6689
--- /dev/null
+++ b/sys-apps/watchdog/files/watchdog.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=watchdog daemon
+After=syslog.target
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/watchdog
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/watchdog/watchdog-5.13-r1.ebuild b/sys-apps/watchdog/watchdog-5.13-r1.ebuild
new file mode 100644
index 000000000000..cfcffb76c16c
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.13-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.13-r1.ebuild,v 1.1 2013/07/06 06:30:17 pacho Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic systemd
+
+DESCRIPTION="A software watchdog and /dev/watchdog daemon"
+HOMEPAGE="http://sourceforge.net/projects/watchdog/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="nfs"
+
+DEPEND="nfs? ( net-libs/libtirpc )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ if use nfs ; then
+ tc-export PKG_CONFIG
+ append-cppflags $(${PKG_CONFIG} libtirpc --cflags)
+ export LIBS+=" $(${PKG_CONFIG} libtirpc --libs)"
+ fi
+ econf $(use_enable nfs)
+}
+
+src_install() {
+ default
+ docinto examples
+ dodoc examples/*
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+ systemd_dounit "${FILESDIR}"/watchdog.service
+}