summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-02-11 00:13:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-02-11 00:13:35 +0000
commit2645c7ac9f59e207a6d0f9dadd292474085187b1 (patch)
tree82e7458a9432ffdcd8e6474956bcd62eb57f43bc /sys-apps/x86info
parentFix the dosed/sed line to expand the shell otherwise it'll fail install. (diff)
downloadgentoo-2-2645c7ac9f59e207a6d0f9dadd292474085187b1.tar.gz
gentoo-2-2645c7ac9f59e207a6d0f9dadd292474085187b1.tar.bz2
gentoo-2-2645c7ac9f59e207a6d0f9dadd292474085187b1.zip
Version bump.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/ChangeLog9
-rw-r--r--sys-apps/x86info/x86info-1.24.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index 4a7a185d31f6..1af124ef8829 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/x86info
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.21 2008/12/29 23:50:35 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.22 2009/02/11 00:13:35 robbat2 Exp $
+
+*x86info-1.24 (11 Feb 2009)
+
+ 11 Feb 2009; Robin H. Johnson <robbat2@gentoo.org> +x86info-1.24.ebuild:
+ Version bump.
*x86info-1.23 (29 Dec 2008)
diff --git a/sys-apps/x86info/x86info-1.24.ebuild b/sys-apps/x86info/x86info-1.24.ebuild
new file mode 100644
index 000000000000..3de179524226
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.24.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.24.ebuild,v 1.1 2009/02/11 00:13:35 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.21-pic.patch
+}
+
+src_compile() {
+ emake x86info CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin x86info || die
+
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info
+
+ dodoc TODO README ChangeLog
+ doman x86info.1
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}