summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2011-11-11 18:21:44 +0000
committerZac Medico <zmedico@gentoo.org>2011-11-11 18:21:44 +0000
commit06d9fccd63b99716e4325d0d6709f30a9fc858eb (patch)
treec840a0c86e8d26346effc309d4d492d48568750c /sys-apps
parenthttp://my.opera.com/desktopteam/blog/2011/11/11/the-first-opera-11-60-post-be... (diff)
downloadgentoo-2-06d9fccd63b99716e4325d0d6709f30a9fc858eb.tar.gz
gentoo-2-06d9fccd63b99716e4325d0d6709f30a9fc858eb.tar.bz2
gentoo-2-06d9fccd63b99716e4325d0d6709f30a9fc858eb.zip
Remove obsolete less dependency (bug #384663) and tweak style of preinst/postinst boolean conditions.
(Portage version: 2.2.0_alpha73_p1/cvs/Linux i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/ChangeLog6
-rw-r--r--sys-apps/portage/portage-9999.ebuild29
2 files changed, 19 insertions, 16 deletions
diff --git a/sys-apps/portage/ChangeLog b/sys-apps/portage/ChangeLog
index feda66395a77..2edd124820c2 100644
--- a/sys-apps/portage/ChangeLog
+++ b/sys-apps/portage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/portage
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.902 2011/11/10 16:18:28 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.903 2011/11/11 18:21:44 zmedico Exp $
+
+ 11 Nov 2011; Zac Medico <zmedico@gentoo.org> portage-9999.ebuild:
+ Remove obsolete less dependency (bug #384663) and tweak style of
+ preinst/postinst boolean conditions.
10 Nov 2011; Zac Medico <zmedico@gentoo.org> portage-2.1.6.13.ebuild,
portage-2.1.6.7.ebuild:
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index c2ca9aa02fc5..0950f02022bc 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.31 2011/11/02 05:26:03 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-9999.ebuild,v 1.32 2011/11/11 18:21:44 zmedico Exp $
EAPI=3
inherit git-2 eutils multilib python
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="build doc epydoc +ipc +less python2 python3 selinux"
+IUSE="build doc epydoc +ipc python2 python3 selinux"
# Import of the io module in python-2.6 raises ImportError for the
# thread module if threading is disabled.
@@ -40,7 +40,6 @@ RDEPEND="${python_dep}
!<app-admin/logrotate-3.8.0"
PDEPEND="
!build? (
- less? ( sys-apps/less )
>=net-misc/rsync-2.6.4
userland_GNU? ( >=sys-apps/coreutils-6.4 )
)"
@@ -295,21 +294,21 @@ pkg_preinst() {
rm -f "${EROOT}/etc/make.globals"
fi
- has_version "<${CATEGORY}/${PN}-2.2_alpha"
- MINOR_UPGRADE=$?
+ has_version "<${CATEGORY}/${PN}-2.2_alpha" \
+ && MINOR_UPGRADE=true || MINOR_UPGRADE=false
- has_version "<=${CATEGORY}/${PN}-2.2_pre5"
- WORLD_MIGRATION_UPGRADE=$?
+ has_version "<=${CATEGORY}/${PN}-2.2_pre5" \
+ && WORLD_MIGRATION_UPGRADE=true || WORLD_MIGRATION_UPGRADE=false
# If portage-2.1.6 is installed and the preserved_libs_registry exists,
# assume that the NEEDED.ELF.2 files have already been generated.
has_version "<=${CATEGORY}/${PN}-2.2_pre7" && \
! ( [ -e "${EROOT}"var/lib/portage/preserved_libs_registry ] && \
- has_version ">=${CATEGORY}/${PN}-2.1.6_rc" )
- NEEDED_REBUILD_UPGRADE=$?
+ has_version ">=${CATEGORY}/${PN}-2.1.6_rc" ) \
+ && NEEDED_REBUILD_UPGRADE=true || NEEDED_REBUILD_UPGRADE=false
- [[ -n $PORTDIR_OVERLAY ]] && has_version "<${CATEGORY}/${PN}-2.1.6.12"
- REPO_LAYOUT_CONF_WARN=$?
+ [[ -n $PORTDIR_OVERLAY ]] && has_version "<${CATEGORY}/${PN}-2.1.6.12" \
+ && REPO_LAYOUT_CONF_WARN=true || REPO_LAYOUT_CONF_WARN=false
}
pkg_postinst() {
@@ -317,14 +316,14 @@ pkg_postinst() {
# will be identified and removed in postrm.
python_mod_optimize /usr/$(get_libdir)/portage/pym
- if [ $WORLD_MIGRATION_UPGRADE = 0 ] ; then
+ if $WORLD_MIGRATION_UPGRADE ; then
einfo "moving set references from the worldfile into world_sets"
cd "${EROOT}/var/lib/portage/"
grep "^@" world >> world_sets
sed -i -e '/^@/d' world
fi
- if [ $NEEDED_REBUILD_UPGRADE = 0 ] ; then
+ if $NEEDED_REBUILD_UPGRADE ; then
einfo "rebuilding NEEDED.ELF.2 files"
for cpv in "${EROOT}/var/db/pkg"/*/*; do
if [ -f "${cpv}/NEEDED" ]; then
@@ -343,7 +342,7 @@ pkg_postinst() {
done
fi
- if [ $REPO_LAYOUT_CONF_WARN = 0 ] ; then
+ if $REPO_LAYOUT_CONF_WARN ; then
ewarn
echo "If you want overlay eclasses to override eclasses from" \
"other repos then see the portage(5) man page" \
@@ -358,7 +357,7 @@ pkg_postinst() {
einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
einfo
- if [ $MINOR_UPGRADE = 0 ] ; then
+ if $MINOR_UPGRADE ; then
elog "If you're upgrading from a pre-2.2 version of portage you might"
elog "want to remerge world (emerge -e world) to take full advantage"
elog "of some of the new features in 2.2."