summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-10-20 07:12:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-10-20 07:12:46 +0000
commit074d382c01ef27d9e987f9d14edf5d1abc822cd0 (patch)
tree1adca7c525a16cdf798e1fa27f5cfa180d8078cf /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-074d382c01ef27d9e987f9d14edf5d1abc822cd0.tar.gz
gentoo-2-074d382c01ef27d9e987f9d14edf5d1abc822cd0.tar.bz2
gentoo-2-074d382c01ef27d9e987f9d14edf5d1abc822cd0.zip
Forward /etc/modprobe.d/usb-load-ehci-first.conf from module-init-tools to kmod wrt #260139
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kmod/ChangeLog9
-rw-r--r--sys-apps/kmod/kmod-10-r1.ebuild87
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild10
3 files changed, 104 insertions, 2 deletions
diff --git a/sys-apps/kmod/ChangeLog b/sys-apps/kmod/ChangeLog
index e64905460662..f288668b2ce6 100644
--- a/sys-apps/kmod/ChangeLog
+++ b/sys-apps/kmod/ChangeLog
@@ -1,5 +1,12 @@
# ChangeLog for sys-apps/kmod
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.51 2012/09/20 12:18:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.52 2012/10/20 07:12:46 ssuominen Exp $
+
+*kmod-10-r1 (20 Oct 2012)
+
+ 20 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> +kmod-10-r1.ebuild,
+ kmod-9999.ebuild:
+ Forward /etc/modprobe.d/usb-load-ehci-first.conf from module-init-tools to
+ kmod wrt #260139
20 Sep 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove extraneous character from email address.
diff --git a/sys-apps/kmod/kmod-10-r1.ebuild b/sys-apps/kmod/kmod-10-r1.ebuild
new file mode 100644
index 000000000000..4699b1d3b527
--- /dev/null
+++ b/sys-apps/kmod/kmod-10-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-10-r1.ebuild,v 1.1 2012/10/20 07:12:46 ssuominen Exp $
+
+EAPI=4
+
+inherit autotools eutils toolchain-funcs libtool
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
+ inherit git-2
+else
+ SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="library and tools for managing linux kernel modules"
+HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug doc lzma static-libs +tools zlib"
+
+# Upstream does not support running the test suite with custom configure flags.
+# I was also told that the test suite is intended for kmod developers.
+# So we have to restrict it.
+# See bug #408915.
+RESTRICT="test"
+
+RDEPEND="!sys-apps/module-init-tools
+ !sys-apps/modutils
+ lzma? ( app-arch/xz-utils )
+ zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ lzma? ( virtual/pkgconfig )
+ zlib? ( virtual/pkgconfig )"
+
+src_prepare()
+{
+ if [ ! -e configure ]; then
+ if use doc; then
+ gtkdocize --copy --docdir libkmod/docs || die
+ else
+ touch libkmod/docs/gtk-doc.make
+ fi
+ eautoreconf
+ else
+ elibtoolize
+ fi
+}
+
+src_configure()
+{
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable tools) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_with lzma xz) \
+ $(use_with zlib)
+}
+
+src_install()
+{
+ default
+ prune_libtool_files
+
+ if use tools; then
+ local cmd
+ for cmd in depmod insmod lsmod modinfo modprobe rmmod; do
+ dosym kmod /usr/bin/${cmd}
+ done
+ # Compability symlink(s):
+ # These are both hardcoded in the Linux kernel source tree wrt #426698
+ dosym /usr/bin/kmod /sbin/depmod
+ dosym /usr/bin/kmod /sbin/modprobe
+ fi
+
+ cat <<-EOF > "${T}"/usb-load-ehci-first.conf
+ install ohci_hcd /usr/bin/modprobe ehci_hcd ; /usr/bin/modprobe --ignore-install ohci_hcd \$CMDLINE_OPTS
+ install uhci_hcd /usr/bin/modprobe ehci_hcd ; /usr/bin/modprobe --ignore-install uhci_hcd \$CMDLINE_OPTS
+ EOF
+
+ insinto /etc/modprobe.d
+ doins "${T}"/usb-load-ehci-first.conf #260139
+}
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index 1f6fbdbec248..334c8a13ced0 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.33 2012/09/09 17:38:10 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.34 2012/10/20 07:12:46 ssuominen Exp $
EAPI=4
@@ -76,4 +76,12 @@ src_install()
dosym /usr/bin/kmod /sbin/depmod
dosym /usr/bin/kmod /sbin/modprobe
fi
+
+ cat <<-EOF > "${T}"/usb-load-ehci-first.conf
+ install ohci_hcd /usr/bin/modprobe ehci_hcd ; /usr/bin/modprobe --ignore-install ohci_hcd \$CMDLINE_OPTS
+ install uhci_hcd /usr/bin/modprobe ehci_hcd ; /usr/bin/modprobe --ignore-install uhci_hcd \$CMDLINE_OPTS
+ EOF
+
+ insinto /etc/modprobe.d
+ doins "${T}"/usb-load-ehci-first.conf #260139
}