summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-07 01:36:03 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-07 01:36:03 +0000
commit0a37764302fca67a72d833f762d55dfe50a960c5 (patch)
treed650290778f77cde004a0e66aa056d9153135868 /sys-apps
parentFixed sandbox error. (diff)
downloadgentoo-2-0a37764302fca67a72d833f762d55dfe50a960c5.tar.gz
gentoo-2-0a37764302fca67a72d833f762d55dfe50a960c5.tar.bz2
gentoo-2-0a37764302fca67a72d833f762d55dfe50a960c5.zip
a little tweak for build image creation.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/portage-1.8.16.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-apps/portage/portage-1.8.16.ebuild b/sys-apps/portage/portage-1.8.16.ebuild
index 8c382c58898f..a51328f870ad 100644
--- a/sys-apps/portage/portage-1.8.16.ebuild
+++ b/sys-apps/portage/portage-1.8.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc. Distributed under the terms
# of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.8.16.ebuild,v 1.2 2002/04/04 19:57:08 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.8.16.ebuild,v 1.3 2002/04/07 01:36:03 drobbins Exp $
S=${WORKDIR}/${P}
SLOT="0"
@@ -122,7 +122,10 @@ pkg_postinst() {
rm -rf ${ROOT}/usr/lib/sandbox
fi
- #upgrade /var/db/pkg library
- cd ${ROOT}/var/db/pkg
- python2.2 ${ROOT}/usr/lib/portage/bin/db-update.py `find -name VIRTUAL`
+ #upgrade /var/db/pkg library; conditional required for build image creation
+ if [ -d ${ROOT}var/db/pkg ]
+ then
+ cd ${ROOT}var/db/pkg
+ python2.2 ${ROOT}usr/lib/portage/bin/db-update.py `find -name VIRTUAL`
+ fi
}