summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-05-31 08:58:15 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-05-31 08:58:15 +0000
commit0e612baf2b887a5bceb4dbf628287bf607de6ed6 (patch)
tree346af80d7f868d7da5e9650adc0604d26982d062 /sys-apps
parenttidy ebuild and rev bump (diff)
downloadgentoo-2-0e612baf2b887a5bceb4dbf628287bf607de6ed6.tar.gz
gentoo-2-0e612baf2b887a5bceb4dbf628287bf607de6ed6.tar.bz2
gentoo-2-0e612baf2b887a5bceb4dbf628287bf607de6ed6.zip
tidy ebuild and rev bump
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/ChangeLog13
-rw-r--r--sys-apps/man/Manifest4
-rw-r--r--sys-apps/man/files/digest-man-1.5l-r41
-rw-r--r--sys-apps/man/man-1.5l-r4.ebuild97
4 files changed, 112 insertions, 3 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 5345e4645091..aa7edecafc58 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-apps/man
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.29 2003/05/25 15:10:30 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.30 2003/05/31 08:58:10 msterret Exp $
+
+*man-1.5l-r4 (31 May 2003)
+
+ 31 May 2003; <msterret@gentoo.org> man-1.5l-r4.ebuild:
+ Add nls to IUSE
+ Use sed -i and add sed to DEPEND
+ Use emake -j1 so it's clear it doesn't build right in parallel.
+ Error messages for die
+ Rearranged src_install() to cd less
+ Trim trailing white space
+ Masked all archs in case I messed something up
25 May 2003; Martin Holzer <mholzer@gentoo.org> man-1.5i-r3.ebuild,
man-1.5k-r1.ebuild, man-1.5l-r3.ebuild:
diff --git a/sys-apps/man/Manifest b/sys-apps/man/Manifest
index 1333a88c92e2..3a26479df910 100644
--- a/sys-apps/man/Manifest
+++ b/sys-apps/man/Manifest
@@ -1,7 +1,7 @@
-MD5 f74451a12d46464871851e5515d16d1b ChangeLog 4877
+MD5 0a80f35e4cf832742dc40d051b1ccfad ChangeLog 5223
MD5 5fab5adb6ab180e1c26c782966ff9e7c man-1.5i-r3.ebuild 1716
MD5 e451f5410b1871afa0ed7796b92d0ba1 man-1.5k-r1.ebuild 2556
-MD5 90be3b06553f8119914e25d5fb577153 man-1.5l-r4.ebuild 2351
+MD5 44dbc5da4d1a1d867dd624988563a8c9 man-1.5l-r4.ebuild 2353
MD5 02821b16aa57da05402ec64cd442441d man-1.5l-r3.ebuild 2304
MD5 c40cc9207adc44cb98bf59a1e9e90766 files/digest-man-1.5i-r3 61
MD5 00f30e0e111b386b879a36f64180026c files/digest-man-1.5k-r1 60
diff --git a/sys-apps/man/files/digest-man-1.5l-r4 b/sys-apps/man/files/digest-man-1.5l-r4
new file mode 100644
index 000000000000..1d4a35da11da
--- /dev/null
+++ b/sys-apps/man/files/digest-man-1.5l-r4
@@ -0,0 +1 @@
+MD5 07fa5ab41c39afcd59cdef5139ef563b man-1.5l.tar.gz 218249
diff --git a/sys-apps/man/man-1.5l-r4.ebuild b/sys-apps/man/man-1.5l-r4.ebuild
new file mode 100644
index 000000000000..548e26ae0590
--- /dev/null
+++ b/sys-apps/man/man-1.5l-r4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5l-r4.ebuild,v 1.1 2003/05/31 08:58:10 msterret Exp $
+
+IUSE="nls"
+
+inherit eutils
+
+NV="${PV}"
+S="${WORKDIR}/${PN}-${NV}"
+DESCRIPTION="Standard commands to read man pages"
+SRC_URI="mirror://kernel/linux/utils/man/man-${NV}.tar.gz"
+HOMEPAGE="http://freshmeat.net/projects/man/"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4"
+
+RDEPEND="sys-apps/cronbase
+ >=sys-apps/groff-1.18"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S} && \
+ sed -i \
+ -e 's:/usr/lib/locale:$(prefix)/usr/lib/locale:g' \
+ -e 's!/usr/bin:/usr/ucb:!/usr/bin:!' \
+ configure || die "configure sed failed"
+
+ sed -i -e 's:cc -o:$(CC) -o:' gencat/Makefile \
+ || die "gencat/Makefile sed failed"
+
+ # Fix search order in man.conf so that system installed manpages
+ # will be found first ...
+ epatch ${FILESDIR}/${P}-search-order.patch
+
+ # For groff-1.18 or later we need to call nroff with '-c'
+ epatch ${FILESDIR}/${P}-groff-1.18.patch
+
+ # Fix wierd failing in rare cases
+ epatch ${FILESDIR}/${P}-wrong-quotes-v2.patch
+
+ # Fix a crash when calling man with: man -k "foo bar" (bug #9761).
+ # <azarah@gentoo.org> (26 Dec 2002).
+ epatch ${FILESDIR}/${P}-util_c-segfault.patch
+
+ # Various fixes from Redhat
+ epatch ${FILESDIR}/${P}-redhat-patches.patch
+
+ # Do not print the 'man: No such file or directory' error if
+ # 'man -d' was called and the NLS catalogue was not found, as
+ # it confuses people, and be more informative ... (bug #6360)
+ # <azarah@gentoo.org> (26 Dec 2002).
+ epatch ${FILESDIR}/${P}-locale-debug-info.patch
+}
+
+src_compile() {
+ local myconf=
+
+ use nls && myconf="+lang all"
+
+ ./configure -confdir=/etc \
+ +sgid +fhs \
+ ${myconf} || die "configure failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/{bin,sbin}
+ cd ${S}
+ make PREFIX=${D} install || die "make install failed"
+
+ insinto /etc
+ doins src/man.conf
+
+ dodoc COPYING LSM README* TODO
+
+ if [ -n "`use nls`" ]
+ then
+ cd ${S}/msgs
+ ./inst.sh ?? ${D}/usr/share/locale/%L/%N
+ fi
+
+ chown root.man ${D}/usr/bin/man
+ chmod 2555 ${D}/usr/bin/man
+
+ # Needed for makewhatis
+ keepdir /var/cache/man
+
+ exeinto /etc/cron.daily
+ doexe ${FILESDIR}/makewhatis.cron
+}