summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-11 13:36:53 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-11 13:36:53 +0000
commit102825063e517aaf1b90b3ed9805d9e05567bbce (patch)
tree766a416027676be842250c9ce33fbd51634872b2 /sys-apps
parentRemoving old and vulnerable versions. (diff)
downloadgentoo-2-102825063e517aaf1b90b3ed9805d9e05567bbce.tar.gz
gentoo-2-102825063e517aaf1b90b3ed9805d9e05567bbce.tar.bz2
gentoo-2-102825063e517aaf1b90b3ed9805d9e05567bbce.zip
Initial import wrt bug 299818. Ebuild written by Ruggero Morsucci <mors_1tflops@yahoo.it>
(Portage version: 2.1.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwloc/ChangeLog11
-rw-r--r--sys-apps/hwloc/hwloc-1.0.2.ebuild32
-rw-r--r--sys-apps/hwloc/metadata.xml17
3 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
new file mode 100644
index 000000000000..68afa7da7259
--- /dev/null
+++ b/sys-apps/hwloc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-apps/hwloc
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.1 2010/09/11 13:36:53 xarthisius Exp $
+
+*hwloc-1.0.2 (11 Sep 2010)
+
+ 11 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org> +hwloc-1.0.2.ebuild,
+ +metadata.xml:
+ Initial import wrt bug 299818. Ebuild written by Ruggero Morsucci
+ <mors_1tflops@yahoo.it>
+
diff --git a/sys-apps/hwloc/hwloc-1.0.2.ebuild b/sys-apps/hwloc/hwloc-1.0.2.ebuild
new file mode 100644
index 000000000000..cea89f1ef6d7
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.0.2.ebuild,v 1.1 2010/09/11 13:36:53 xarthisius Exp $
+
+EAPI=2
+
+inherit base
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/hwloc/v1.0/downloads/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo svg xml X"
+SLOT="0"
+LICENSE="BSD"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_configure() {
+ econf \
+ $(use_enable cairo) \
+ $(use_enable xml) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
diff --git a/sys-apps/hwloc/metadata.xml b/sys-apps/hwloc/metadata.xml
new file mode 100644
index 000000000000..57f2fcfe3768
--- /dev/null
+++ b/sys-apps/hwloc/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <longdescription>
+ The Portable Hardware Locality (hwloc) software package provides a portable abstraction
+ (across OS, versions, architectures, ...) of the hierarchical topology of modern architectures,
+ including NUMA memory nodes, sockets, shared caches, cores and simultaneous multithreading.
+ It also gathers various system attributes such as cache and memory information.
+ It primarily aims at helping applications with gathering information about modern computing
+ hardware so as to exploit it accordingly and efficiently.
+ </longdescription>
+</pkgmetadata>