summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-11-10 04:27:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-11-10 04:27:36 +0000
commit11a37f21694d039896d533304398f1117775f86f (patch)
tree5a4d5beb1909dc7bf073924a9327fb577396c245 /sys-apps
parentBump for 7.2RC2. Brings manpage cleanups and Solaris fixes. (diff)
downloadgentoo-2-11a37f21694d039896d533304398f1117775f86f.tar.gz
gentoo-2-11a37f21694d039896d533304398f1117775f86f.tar.bz2
gentoo-2-11a37f21694d039896d533304398f1117775f86f.zip
Adding D-Bus 1.0.0
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dbus/ChangeLog8
-rw-r--r--sys-apps/dbus/dbus-1.0.0.ebuild103
-rw-r--r--sys-apps/dbus/files/digest-dbus-1.0.03
3 files changed, 113 insertions, 1 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index a22914d70eb9..0663a2d00eb4 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.146 2006/11/09 14:42:09 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.147 2006/11/10 04:27:36 cardoe Exp $
+
+*dbus-1.0 (10 Nov 2006)
+
+ 10 Nov 2006; Doug Goldstein <cardoe@gentoo.org> -dbus-0.94.ebuild,
+ +dbus-1.0.0.ebuild:
+ Adding D-Bus 1.0.0
09 Nov 2006; Gustavo Zacarias <gustavoz@gentoo.org> dbus-0.62-r1.ebuild:
Stable on sparc wrt #154522
diff --git a/sys-apps/dbus/dbus-1.0.0.ebuild b/sys-apps/dbus/dbus-1.0.0.ebuild
new file mode 100644
index 000000000000..3f3a1ab68126
--- /dev/null
+++ b/sys-apps/dbus/dbus-1.0.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.0.0.ebuild,v 1.1 2006/11/10 04:27:36 cardoe Exp $
+
+WANT_AUTOCONF=2.5
+inherit eutils multilib debug autotools
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc selinux X"
+
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
+ selinux? ( sys-libs/libselinux )
+ >=dev-libs/expat-1.95.8
+ !<sys-apps/dbus-0.91"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto )"
+
+src_compile() {
+ local myconf=""
+
+ hasq test ${FEATURES} && myconf="${myconf} --enable-tests=yes"
+
+ econf \
+ $(use_with X x) \
+ $(use_enable kernel_linux dnotify) \
+ $(use_enable kernel_FreeBSD kqueue) \
+ $(use_enable selinux) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug asserts) \
+ --with-xml=expat \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ ${myconf} \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_test() {
+ DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # initscript
+ newinitd "${FILESDIR}"/dbus.init-0.95 dbus
+
+ # dbus X session script (#77504)
+ # turns out to only work for GDM. has been merged into other desktop
+ # (kdm and such scripts)
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/30-dbus
+
+ # needs to exist for the system socket
+ keepdir /var/run/dbus
+ # needs to exist for machine id
+ keepdir /var/lib/dbus
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+ if use doc; then
+ dohtml doc/*html
+ fi
+}
+
+pkg_preinst() {
+ enewgroup messagebus || die "Problem adding messagebus group"
+ enewuser messagebus -1 "-1" -1 messagebus || die "Problem adding messagebus user"
+}
+
+pkg_postinst() {
+ elog "To start the D-Bus system-wide messagebus by default"
+ elog "you should add it to the default runlevel :"
+ elog "\`rc-update add dbus default\`"
+ elog "Currently have it installed and running?"
+ elog "Run etc-update and then run the following:"
+ elog "\`/etc/init.d/dbus reload\`"
+ elog "This will cause it to reload it's configs but"
+ elog "not run the newest version you just installed."
+ elog "You must tell it to restart for that to happen,"
+ elog "however not all apps can handle a D-Bus restart."
+}
diff --git a/sys-apps/dbus/files/digest-dbus-1.0.0 b/sys-apps/dbus/files/digest-dbus-1.0.0
new file mode 100644
index 000000000000..e186573a89a5
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-1.0.0
@@ -0,0 +1,3 @@
+MD5 8261b2abac8281007fd3176930017302 dbus-1.0.0.tar.gz 1405045
+RMD160 d4cfc0dafc5c0bcc283f55267bb24b351b8bf377 dbus-1.0.0.tar.gz 1405045
+SHA256 b3e1f6f54dab565267a507b1a18af002aad8dc3f3bb89cd7e9c795895944f3d8 dbus-1.0.0.tar.gz 1405045