summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-26 02:21:30 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-26 02:21:30 +0000
commit1939ef88c7b98b399a288e0870663975ae3bbe95 (patch)
tree5161bb70de9af2058e47f89292f38c796ae25449 /sys-apps
parentRevision bump to add patch to fix yahoo login. Thanks to Patrick McLean for ... (diff)
downloadgentoo-2-1939ef88c7b98b399a288e0870663975ae3bbe95.tar.gz
gentoo-2-1939ef88c7b98b399a288e0870663975ae3bbe95.tar.bz2
gentoo-2-1939ef88c7b98b399a288e0870663975ae3bbe95.zip
thinkpad group #35706
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/thinkpad/ChangeLog8
-rw-r--r--sys-apps/thinkpad/thinkpad-4.3-r1.ebuild18
-rw-r--r--sys-apps/thinkpad/thinkpad-4.8.ebuild72
3 files changed, 20 insertions, 78 deletions
diff --git a/sys-apps/thinkpad/ChangeLog b/sys-apps/thinkpad/ChangeLog
index 489502354afd..b683536a6ebf 100644
--- a/sys-apps/thinkpad/ChangeLog
+++ b/sys-apps/thinkpad/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for sys-apps/thinkpad
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.10 2003/12/25 10:36:55 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/ChangeLog,v 1.11 2004/01/26 02:21:30 vapier Exp $
*thinkpad-4.8 (25 Dec 2003)
+ 25 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add thinkpad group for devfs #35706.
+
25 Dec 2003; Robin H. Johnson <robbat2@gentoo.org> thinkpad-4.8.ebuild:
version bump
@@ -14,6 +17,9 @@
*thinkpad-4.3-r1 (27 Jun 2003)
+ 25 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add thinkpad group for devfs #35706.
+
27 Jun 2003; Karl Trygve Kalleberg <karltk@gentoo.org> thinkpad-4.3-r1.ebuild :
version bump, installs man page now.
diff --git a/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild b/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild
index c0a46f359451..633ea922c444 100644
--- a/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild
+++ b/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild
@@ -1,20 +1,26 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild,v 1.2 2003/11/28 13:22:39 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.3-r1.ebuild,v 1.3 2004/01/26 02:21:30 vapier Exp $
+
+inherit eutils
#transform P to match tarball versioning
MYPV=${PV/_beta/beta}
MYP="${PN}_${MYPV}"
DESCRIPTION="Thinkpad system control kernel modules"
-SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
-KEYWORDS="x86 amd64 -ppc -mips -sparc"
-SLOT="0"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86 amd64"
-#virtual/glibc should depend on specific kernel headers
DEPEND="virtual/glibc"
+pkg_setup() {
+ enewgroup thinkpad
+}
+
src_unpack() {
check_KV
unpack ${A} || die
diff --git a/sys-apps/thinkpad/thinkpad-4.8.ebuild b/sys-apps/thinkpad/thinkpad-4.8.ebuild
index c79e747a0499..75f81544c88e 100644
--- a/sys-apps/thinkpad/thinkpad-4.8.ebuild
+++ b/sys-apps/thinkpad/thinkpad-4.8.ebuild
@@ -1,71 +1 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.8.ebuild,v 1.1 2003/12/25 10:36:55 robbat2 Exp $
-
-#transform P to match tarball versioning
-MYPV=${PV/_beta/beta}
-MYP="${PN}_${MYPV}"
-DESCRIPTION="Thinkpad system control kernel modules"
-SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
-HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
-KEYWORDS="~x86 amd64 -ppc -mips -sparc"
-SLOT="0"
-LICENSE="GPL-2"
-
-#virtual/glibc should depend on specific kernel headers
-DEPEND="virtual/glibc"
-
-src_unpack() {
- check_KV
- unpack ${A} || die
- cd ${S}
-
- # Use the correct drivers for your kernel. The standard distro comes
- # with 2.5.
- mkdir 2.5
- mv drivers include 2.5
- # Use your kernel version to build.
- local ver=${KV:0:3} # first 3 chars of $KV, thank you bash :)
- ln -s $ver/drivers drivers
- ln -s $ver/include include
-}
-
-src_compile() {
- check_KV
- emake DIR_MOD_VER=/lib/modules/${KV} \
- DIR_MODULES_VER=/lib/modules/${KV} \
- || die "Make failed"
-
-}
-
-src_install() {
- dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
- dodir /lib/modules/${KV}/thinkpad
- cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
- ${D}/lib/modules/${KV}/thinkpad
- dodir /etc/modules.d
- sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad
- dodir /etc/devfs.d
- echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664' \
- > ${D}/etc/devfs.d/thinkpad
- doman man/*.4
-}
-
-pkg_postinst() {
- /usr/sbin/update-modules || return 0
- if ! grep -q '^ *INCLUDE.*devfs\.d' /etc/devfsd.conf; then
- ewarn 'Your /etc/devfsd.conf is missing the include for'
- ewarn '/etc/devfs.d/! Please fix this by adding'
- ewarn 'INCLUDE /etc/devfs.d'
- ewarn 'to your /etc/devfs.conf'
- fi
- if grep -q thinkpad /etc/devfsd.conf; then
- ewarn 'The thinkpad devfsd entry has moved to'
- ewarn '/etc/devfs.d/thinkpad, so you can remove it from'
- ewarn '/etc/devfsd.conf if you like.'
- fi
-}
-
-pkg_prerm() {
- /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
-}
+# Copyright 1999-2004 Gentoo Technologies, Inc. # Distributed under the terms of the GNU General Public License v2 # $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-4.8.ebuild,v 1.2 2004/01/26 02:21:30 vapier Exp $ inherit eutils #transform P to match tarball versioning MYPV=${PV/_beta/beta} MYP="${PN}_${MYPV}" DESCRIPTION="Thinkpad system control kernel modules" HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm" SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz" LICENSE="GPL-2" SLOT="0" KEYWORDS="-* ~x86 amd64" DEPEND="virtual/glibc" pkg_setup() { enewgroup thinkpad } src_unpack() { check_KV unpack ${A} || die cd ${S} # Use the correct drivers for your kernel. The standard distro comes # with 2.5. mkdir 2.5 mv drivers include 2.5 # Use your kernel version to build. local ver=${KV:0:3} # first 3 chars of $KV, thank you bash :) ln -s $ver/drivers drivers ln -s $ver/include include } src_compile() { check_KV emake DIR_MOD_VER=/lib/modules/${KV} \ DIR_MODULES_VER=/lib/modules/${KV} \ || die "Make failed" } src_install() { dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES dodir /lib/modules/${KV}/thinkpad cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \ ${D}/lib/modules/${KV}/thinkpad dodir /etc/modules.d sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad dodir /etc/devfs.d echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664' \ > ${D}/etc/devfs.d/thinkpad doman man/*.4 } pkg_postinst() { /usr/sbin/update-modules || return 0 if ! grep -q '^ *INCLUDE.*devfs\.d' /etc/devfsd.conf; then ewarn 'Your /etc/devfsd.conf is missing the include for' ewarn '/etc/devfs.d/! Please fix this by adding' ewarn 'INCLUDE /etc/devfs.d' ewarn 'to your /etc/devfs.conf' fi if grep -q thinkpad /etc/devfsd.conf; then ewarn 'The thinkpad devfsd entry has moved to' ewarn '/etc/devfs.d/thinkpad, so you can remove it from' ewarn '/etc/devfsd.conf if you like.' fi } pkg_prerm() { /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad } \ No newline at end of file