summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-14 14:28:23 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-14 14:28:23 +0000
commit1de4380eb24766fc5160035f8822862960bcaa9c (patch)
treea46906abd1eb69aa52524e1aef551a0e53dbcc0e /sys-apps
parentInstall unit file, drop old (diff)
downloadgentoo-2-1de4380eb24766fc5160035f8822862960bcaa9c.tar.gz
gentoo-2-1de4380eb24766fc5160035f8822862960bcaa9c.tar.bz2
gentoo-2-1de4380eb24766fc5160035f8822862960bcaa9c.zip
Version bump. Update kernel checks. Do not check for HOTPLUG on 3.7+ wrt bug #476464. Run tests for native ABI only.
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog9
-rw-r--r--sys-apps/systemd/systemd-207.ebuild309
-rw-r--r--sys-apps/systemd/systemd-9999-r1.ebuild29
3 files changed, 335 insertions, 12 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index ce2237e45837..f642b750f09f 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.172 2013/09/14 08:47:56 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.173 2013/09/14 14:28:23 mgorny Exp $
+
+*systemd-207 (14 Sep 2013)
+
+ 14 Sep 2013; Michał Górny <mgorny@gentoo.org> +systemd-207.ebuild,
+ systemd-9999-r1.ebuild:
+ Version bump. Update kernel checks. Do not check for HOTPLUG on 3.7+ wrt bug
+ #476464. Run tests for native ABI only.
*systemd-206-r5 (14 Sep 2013)
diff --git a/sys-apps/systemd/systemd-207.ebuild b/sys-apps/systemd/systemd-207.ebuild
new file mode 100644
index 000000000000..e09bb26f59d1
--- /dev/null
+++ b/sys-apps/systemd/systemd-207.ebuild
@@ -0,0 +1,309 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-207.ebuild,v 1.1 2013/09/14 14:28:23 mgorny Exp $
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+PYTHON_COMPAT=( python2_7 )
+inherit autotools-utils bash-completion-r1 fcaps linux-info multilib \
+ multilib-minimal pam python-single-r1 systemd toolchain-funcs udev \
+ user
+
+DESCRIPTION="System and service manager for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="acl audit cryptsetup doc +firmware-loader gcrypt gudev http introspection
+ +kmod lzma openrc pam policykit python qrcode selinux tcpd test
+ vanilla xattr"
+
+MINKV="3.0"
+
+COMMON_DEPEND=">=sys-apps/dbus-1.6.8-r1
+ >=sys-apps/util-linux-2.20
+ sys-libs/libcap
+ acl? ( sys-apps/acl )
+ audit? ( >=sys-process/audit-2 )
+ cryptsetup? ( >=sys-fs/cryptsetup-1.6 )
+ gcrypt? ( >=dev-libs/libgcrypt-1.4.5 )
+ gudev? ( >=dev-libs/glib-2[${MULTILIB_USEDEP}] )
+ http? ( net-libs/libmicrohttpd )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+ kmod? ( >=sys-apps/kmod-14-r1 )
+ lzma? ( app-arch/xz-utils[${MULTILIB_USEDEP}] )
+ pam? ( virtual/pam )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? ( media-gfx/qrencode )
+ selinux? ( sys-libs/libselinux )
+ tcpd? ( sys-apps/tcp-wrappers )
+ xattr? ( sys-apps/attr )
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r9
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
+
+# baselayout-2.2 has /run
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/baselayout-2.2
+ openrc? ( >=sys-fs/udev-init-scripts-25 )
+ || (
+ >=sys-apps/util-linux-2.22
+ <sys-apps/sysvinit-2.88-r4
+ )
+ !vanilla? ( sys-apps/gentoo-systemd-integration )
+ !sys-auth/nss-myhostname
+ !<sys-libs/glibc-2.10
+ !sys-fs/udev"
+
+PDEPEND=">=sys-apps/hwids-20130717-r1[udev]
+ policykit? ( sys-auth/polkit )"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gperf
+ >=dev-util/intltool-0.50
+ >=sys-devel/binutils-2.23.1
+ >=sys-devel/gcc-4.6
+ >=sys-kernel/linux-headers-${MINKV}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~AUTOFS4_FS ~BLK_DEV_BSG ~CGROUPS ~DEVTMPFS
+ ~EPOLL ~FANOTIFY ~FHANDLE ~INOTIFY_USER ~IPV6 ~NET ~PROC_FS
+ ~SECCOMP ~SIGNALFD ~SYSFS ~TIMERFD
+ ~!IDE ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2"
+
+ use acl && CONFIG_CHECK+=" ~TMPFS_POSIX_ACL"
+ use pam && CONFIG_CHECK+=" ~AUDITSYSCALL"
+ kernel_is -lt 3 7 && CONFIG_CHECK+=" ~HOTPLUG"
+ use firmware-loader || CONFIG_CHECK+=" ~!FW_LOADER_USER_HELPER"
+
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) -lt 4
+ || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ) ]]
+ then
+ eerror "systemd requires at least gcc 4.6 to build. Please switch the active"
+ eerror "gcc version using gcc-config."
+ die "systemd requires at least gcc 4.6"
+ fi
+ fi
+
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ if kernel_is -lt ${MINKV//./ }; then
+ ewarn "Kernel version at least ${MINKV} required"
+ fi
+
+ if ! use firmware-loader && kernel_is -lt 3 8; then
+ ewarn "You seem to be using kernel older than 3.8. Those kernel versions"
+ ewarn "require systemd with USE=firmware-loader to support loading"
+ ewarn "firmware. Missing this flag may cause some hardware not to work."
+ fi
+
+ check_extra_config
+ fi
+}
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var
+ --with-pamlibdir=$(getpam_mod_dir)
+ # avoid bash-completion dep
+ --with-bashcompletiondir="$(get_bashcompdir)"
+ # make sure we get /bin:/sbin in $PATH
+ --enable-split-usr
+ # disable sysv compatibility
+ --with-sysvinit-path=
+ --with-sysvrcnd-path=
+ # no deps
+ --enable-efi
+ --enable-ima
+ # optional components/dependencies
+ $(use_enable acl)
+ $(use_enable audit)
+ $(use_enable cryptsetup libcryptsetup)
+ $(use_enable doc gtk-doc)
+ $(use_enable gcrypt)
+ $(use_enable gudev)
+ $(use_enable http microhttpd)
+ $(use_enable introspection)
+ $(use_enable kmod)
+ $(use_enable lzma xz)
+ $(use_enable pam)
+ $(use_enable policykit polkit)
+ $(use_enable python python-devel)
+ $(use python && echo PYTHON_CONFIG=/usr/bin/python-config-${EPYTHON#python})
+ $(use_enable qrcode qrencode)
+ $(use_enable selinux)
+ $(use_enable tcpd tcpwrap)
+ $(use_enable test tests)
+ $(use_enable xattr)
+
+ # not supported (avoid automagic deps in the future)
+ --disable-chkconfig
+
+ # hardcode a few paths to spare some deps
+ QUOTAON=/usr/sbin/quotaon
+ QUOTACHECK=/usr/sbin/quotacheck
+ )
+
+ # Keep using the one where the rules were installed.
+ MY_UDEVDIR=$(get_udevdir)
+
+ if use firmware-loader; then
+ myeconfargs+=(
+ --with-firmware-path="/lib/firmware/updates:/lib/firmware"
+ )
+ fi
+
+ if ! multilib_is_native_abi; then
+ myeconfargs+=(
+ ac_cv_search_cap_init=
+ ac_cv_header_sys_capability_h=yes
+ DBUS_CFLAGS=' '
+ DBUS_LIBS=' '
+
+ --disable-acl
+ --disable-audit
+ --disable-gcrypt
+ --disable-gtk-doc
+ --disable-introspection
+ --disable-kmod
+ --disable-libcryptsetup
+ --disable-microhttpd
+ --disable-pam
+ --disable-polkit
+ --disable-qrencode
+ --disable-selinux
+ --disable-tcpwrap
+ --disable-tests
+ --disable-xattr
+ --disable-xz
+ --without-python
+ )
+ fi
+
+ # Work around bug 463846.
+ tc-export CC
+
+ autotools-utils_src_configure
+}
+
+multilib_src_compile() {
+ local mymakeopts=(
+ udevlibexecdir="${MY_UDEVDIR}"
+ )
+
+ if multilib_is_native_abi; then
+ emake "${mymakeopts[@]}"
+ else
+ # prerequisites for gudev
+ use gudev && emake src/gudev/gudev{enumtypes,marshal}.{c,h}
+
+ echo 'gentoo: $(lib_LTLIBRARIES) $(pkgconfiglib_DATA)' | \
+ emake "${mymakeopts[@]}" -f Makefile -f - gentoo
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi || continue
+
+ default
+}
+
+multilib_src_install() {
+ local mymakeopts=(
+ udevlibexecdir="${MY_UDEVDIR}"
+ dist_udevhwdb_DATA=
+ DESTDIR="${D}"
+ )
+
+ if multilib_is_native_abi; then
+ emake "${mymakeopts[@]}" install
+ else
+ mymakeopts+=(
+ install-libLTLIBRARIES
+ install-pkgconfiglibDATA
+ install-includeHEADERS
+ # safe to call unconditionally, 'installs' empty list
+ install-libgudev_includeHEADERS
+ install-pkgincludeHEADERS
+ )
+
+ emake "${mymakeopts[@]}"
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --modules
+
+ # we just keep sysvinit tools, so no need for the mans
+ rm "${D}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
+ || die
+ rm "${D}"/usr/share/man/man1/init.1 || die
+
+ # Disable storing coredumps in journald, bug #433457
+ mv "${D}"/usr/lib/sysctl.d/50-coredump.conf{,.disabled} || die
+
+ # Preserve empty dirs in /etc & /var, bug #437008
+ keepdir /etc/binfmt.d /etc/modules-load.d /etc/tmpfiles.d \
+ /etc/systemd/ntp-units.d /etc/systemd/user /var/lib/systemd
+
+ # Symlink /etc/sysctl.conf for easy migration.
+ dosym ../sysctl.conf /etc/sysctl.d/99-sysctl.conf
+}
+
+pkg_postinst() {
+ # for udev rules
+ enewgroup dialout
+
+ enewgroup systemd-journal
+ if use http; then
+ enewgroup systemd-journal-gateway
+ enewuser systemd-journal-gateway -1 -1 -1 systemd-journal-gateway
+ fi
+ systemd_update_catalog
+
+ # Keep this here in case the database format changes so it gets updated
+ # when required. Despite that this file is owned by sys-apps/hwids.
+ if has_version "sys-apps/hwids[udev]"; then
+ udevadm hwdb --update --root="${ROOT%/}"
+ fi
+
+ if [[ ${ROOT} == "" || ${ROOT} == "/" ]]; then
+ udevadm control --reload
+ fi
+
+ # Bug 468876
+ fcaps cap_dac_override,cap_sys_ptrace=ep usr/bin/systemd-detect-virt
+
+ if [[ ! -L "${ROOT}"/etc/mtab ]]; then
+ ewarn "Upstream mandates the /etc/mtab file should be a symlink to /proc/mounts."
+ ewarn "Not having it is not supported by upstream and will cause tools like 'df'"
+ ewarn "and 'mount' to not work properly. Please run:"
+ ewarn " # ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
+ ewarn
+ fi
+
+ if ! has_version sys-apps/systemd-ui; then
+ elog "To get additional features, a number of optional runtime dependencies may"
+ elog "be installed:"
+ elog "- sys-apps/systemd-ui: for GTK+ systemadm UI and gnome-ask-password-agent"
+ fi
+}
+
+pkg_prerm() {
+ # If removing systemd completely, remove the catalog database.
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ rm -f -v "${EROOT}"/var/lib/systemd/catalog/database
+ fi
+}
diff --git a/sys-apps/systemd/systemd-9999-r1.ebuild b/sys-apps/systemd/systemd-9999-r1.ebuild
index 1e98b6a6006c..4f2fd3762281 100644
--- a/sys-apps/systemd/systemd-9999-r1.ebuild
+++ b/sys-apps/systemd/systemd-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999-r1.ebuild,v 1.14 2013/09/13 11:27:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999-r1.ebuild,v 1.15 2013/09/14 14:28:23 mgorny Exp $
EAPI=5
@@ -22,7 +22,7 @@ DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
-LICENSE="GPL-2 LGPL-2.1 MIT"
+LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="acl audit cryptsetup doc +firmware-loader gcrypt gudev http introspection
@@ -99,12 +99,14 @@ src_prepare() {
pkg_pretend() {
local CONFIG_CHECK="~AUTOFS4_FS ~BLK_DEV_BSG ~CGROUPS ~DEVTMPFS
- ~FANOTIFY ~HOTPLUG ~INOTIFY_USER ~IPV6 ~NET ~PROC_FS ~SIGNALFD
- ~SYSFS ~!IDE ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2"
-# ~!FW_LOADER_USER_HELPER"
+ ~EPOLL ~FANOTIFY ~FHANDLE ~INOTIFY_USER ~IPV6 ~NET ~PROC_FS
+ ~SECCOMP ~SIGNALFD ~SYSFS ~TIMERFD
+ ~!IDE ~!SYSFS_DEPRECATED ~!SYSFS_DEPRECATED_V2"
use acl && CONFIG_CHECK+=" ~TMPFS_POSIX_ACL"
use pam && CONFIG_CHECK+=" ~AUDITSYSCALL"
+ kernel_is -lt 3 7 && CONFIG_CHECK+=" ~HOTPLUG"
+ use firmware-loader || CONFIG_CHECK+=" ~!FW_LOADER_USER_HELPER"
if [[ ${MERGE_TYPE} != binary ]]; then
if [[ $(gcc-major-version) -lt 4
@@ -162,7 +164,7 @@ multilib_src_configure() {
$(use_enable lzma xz)
$(use_enable pam)
$(use_enable policykit polkit)
- $(use_with python)
+ $(use_enable python python-devel)
$(use python && echo PYTHON_CONFIG=/usr/bin/python-config-${EPYTHON#python})
$(use_enable qrcode qrencode)
$(use_enable selinux)
@@ -236,6 +238,12 @@ multilib_src_compile() {
fi
}
+multilib_src_test() {
+ multilib_is_native_abi || continue
+
+ default
+}
+
multilib_src_install() {
local mymakeopts=(
udevlibexecdir="${MY_UDEVDIR}"
@@ -244,7 +252,7 @@ multilib_src_install() {
)
if multilib_is_native_abi; then
- emake "${mymakeopts[@]}" -j1 install
+ emake "${mymakeopts[@]}" install
else
mymakeopts+=(
install-libLTLIBRARIES
@@ -262,10 +270,6 @@ multilib_src_install() {
multilib_src_install_all() {
prune_libtool_files --modules
- # zsh completion
- insinto /usr/share/zsh/site-functions
- doins shell-completion/zsh/_*
-
# we just keep sysvinit tools, so no need for the mans
rm "${D}"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8 \
|| die
@@ -277,6 +281,9 @@ multilib_src_install_all() {
# Preserve empty dirs in /etc & /var, bug #437008
keepdir /etc/binfmt.d /etc/modules-load.d /etc/tmpfiles.d \
/etc/systemd/ntp-units.d /etc/systemd/user /var/lib/systemd
+
+ # Symlink /etc/sysctl.conf for easy migration.
+ dosym ../sysctl.conf /etc/sysctl.d/99-sysctl.conf
}
pkg_postinst() {