summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-21 02:32:23 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-21 02:32:23 +0000
commit2962220054673d670dfcc873e024d7a8733c5f84 (patch)
treefdbbf3fd5961ce5f054793b2861bbf6cc813e828 /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-2962220054673d670dfcc873e024d7a8733c5f84.tar.gz
gentoo-2-2962220054673d670dfcc873e024d7a8733c5f84.tar.bz2
gentoo-2-2962220054673d670dfcc873e024d7a8733c5f84.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/the_silver_searcher/ChangeLog8
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.21.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/the_silver_searcher/ChangeLog b/sys-apps/the_silver_searcher/ChangeLog
index 5adc55ad285f..a76dbe806628 100644
--- a/sys-apps/the_silver_searcher/ChangeLog
+++ b/sys-apps/the_silver_searcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/the_silver_searcher
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.36 2014/03/13 01:05:23 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.37 2014/03/21 02:32:23 radhermit Exp $
+
+*the_silver_searcher-0.21.0 (21 Mar 2014)
+
+ 21 Mar 2014; Tim Harder <radhermit@gentoo.org>
+ +the_silver_searcher-0.21.0.ebuild:
+ Version bump.
13 Mar 2014; Tim Harder <radhermit@gentoo.org>
the_silver_searcher-0.20.0.ebuild:
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.21.0.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.21.0.ebuild
new file mode 100644
index 000000000000..270763a49d34
--- /dev/null
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-0.21.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.21.0.ebuild,v 1.1 2014/03/21 02:32:23 radhermit Exp $
+
+EAPI=5
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A code-searching tool similar to ack, but faster"
+HOMEPAGE="http://github.com/ggreer/the_silver_searcher"
+SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="lzma zlib"
+
+RDEPEND="dev-libs/libpcre
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README.md"
+
+src_prepare() {
+ sed -i '/^dist_bashcomp/d' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lzma) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+ newbashcomp ag.bashcomp.sh ag
+}