summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-04-18 05:36:01 +0000
committerMichał Górny <mgorny@gentoo.org>2013-04-18 05:36:01 +0000
commit317369bf940ffd027348c9bb7fef64e5b85d95dd (patch)
treed13cca5945197ec47e5cea7599a3578e1499db72 /sys-apps
parentAdd a gcc version check wrt bug #466160. (diff)
downloadgentoo-2-317369bf940ffd027348c9bb7fef64e5b85d95dd.tar.gz
gentoo-2-317369bf940ffd027348c9bb7fef64e5b85d95dd.tar.bz2
gentoo-2-317369bf940ffd027348c9bb7fef64e5b85d95dd.zip
Update the firmware-loader CONFIG_CHECK for 3.9 kernel. Thanks to WilliamH for noticing.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog7
-rw-r--r--sys-apps/systemd/systemd-201.ebuild8
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild8
3 files changed, 18 insertions, 5 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 4d3f2c1d4467..708cff321bc1 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.124 2013/04/18 05:31:07 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.125 2013/04/18 05:36:01 mgorny Exp $
+
+ 18 Apr 2013; Michał Górny <mgorny@gentoo.org> systemd-201.ebuild,
+ systemd-9999.ebuild:
+ Update the firmware-loader CONFIG_CHECK for 3.9 kernel. Thanks to WilliamH for
+ noticing.
18 Apr 2013; Michał Górny <mgorny@gentoo.org> systemd-201.ebuild,
systemd-9999.ebuild:
diff --git a/sys-apps/systemd/systemd-201.ebuild b/sys-apps/systemd/systemd-201.ebuild
index 256979b345e9..4c6071b0240d 100644
--- a/sys-apps/systemd/systemd-201.ebuild
+++ b/sys-apps/systemd/systemd-201.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-201.ebuild,v 1.10 2013/04/18 05:31:07 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-201.ebuild,v 1.11 2013/04/18 05:36:01 mgorny Exp $
EAPI=5
@@ -86,7 +86,11 @@ pkg_pretend() {
fi
if use firmware-loader; then
- CONFIG_CHECK+=" ~FW_LOADER"
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK+=" ~FW_LOADER_USER_HELPER"
+ else
+ CONFIG_CHECK+=" ~FW_LOADER"
+ fi
elif kernel_is -lt 3 8; then
ewarn "You seem to be using kernel older than 3.8. Those kernel versions"
ewarn "require systemd with USE=firmware-loader to support loading"
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 66f79497914f..037738dbf36a 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.51 2013/04/18 05:31:07 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.52 2013/04/18 05:36:01 mgorny Exp $
EAPI=5
@@ -110,7 +110,11 @@ pkg_pretend() {
fi
if use firmware-loader; then
- CONFIG_CHECK+=" ~FW_LOADER"
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK+=" ~FW_LOADER_USER_HELPER"
+ else
+ CONFIG_CHECK+=" ~FW_LOADER"
+ fi
elif kernel_is -lt 3 8; then
ewarn "You seem to be using kernel older than 3.8. Those kernel versions"
ewarn "require systemd with USE=firmware-loader to support loading"