summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-15 02:24:07 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-15 02:24:07 +0000
commit3302ad897917c333c57fce0abd0c6f98a176f00f (patch)
treebea6449096f5dc39949840e4c9aeb47cde11c615 /sys-apps
parentstandardize local builddir var name/usage (diff)
downloadgentoo-2-3302ad897917c333c57fce0abd0c6f98a176f00f.tar.gz
gentoo-2-3302ad897917c333c57fce0abd0c6f98a176f00f.tar.bz2
gentoo-2-3302ad897917c333c57fce0abd0c6f98a176f00f.zip
Version bump.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/rlocate/ChangeLog8
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.5.03
-rw-r--r--sys-apps/rlocate/files/rlocate-0.5.0-build.patch36
-rw-r--r--sys-apps/rlocate/rlocate-0.5.0.ebuild48
4 files changed, 94 insertions, 1 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index e863cafb1ae9..b21712632519 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.12 2006/02/11 22:54:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.13 2006/04/15 02:24:07 vapier Exp $
+
+*rlocate-0.5.0 (15 Apr 2006)
+
+ 15 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/rlocate-0.5.0-build.patch, +rlocate-0.5.0.ebuild:
+ Version bump.
*rlocate-0.4.3 (11 Feb 2006)
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.5.0 b/sys-apps/rlocate/files/digest-rlocate-0.5.0
new file mode 100644
index 000000000000..49fd85a59b60
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.5.0
@@ -0,0 +1,3 @@
+MD5 4e27e57d315c908f5dd67104f0c40a2d rlocate-0.5.0.tar.gz 178201
+RMD160 5cffda20db76de7d6bd7c362c8aa9aa992639ea4 rlocate-0.5.0.tar.gz 178201
+SHA256 ea003868f59111932c85fa1d560fa2d315b16f0e5c2db2ffab4846c3f0c640b5 rlocate-0.5.0.tar.gz 178201
diff --git a/sys-apps/rlocate/files/rlocate-0.5.0-build.patch b/sys-apps/rlocate/files/rlocate-0.5.0-build.patch
new file mode 100644
index 000000000000..a948bd114f78
--- /dev/null
+++ b/sys-apps/rlocate/files/rlocate-0.5.0-build.patch
@@ -0,0 +1,36 @@
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -192,9 +192,9 @@
+ rlocate.h rlocate.c cmds.c cmds.h conf.c conf.h utils.c \
+ utils.h
+
+-SUBDIRS = rlocate-daemon rlocate-module rlocate-scripts
++SUBDIRS = rlocate-daemon rlocate-scripts
+ EXTRA_DIST = rlocate.cron rlocate-scripts
+-AM_CFLAGS = -O2 -Wall
++AM_CFLAGS = -Wall
+ all: all-recursive
+
+ .SUFFIXES:
+--- src/rlocate-daemon/Makefile.in
++++ src/rlocate-daemon/Makefile.in
+@@ -171,7 +171,7 @@
+ -DRLOCATE_GRP=\"$(rlocate_group)\"
+
+ rlocated_SOURCES = ../pidfile.h ../pidfile.c rlocated.c
+-AM_CFLAGS = -O2 -Wall
++AM_CFLAGS = -Wall
+ all: all-am
+
+ .SUFFIXES:
+--- src/rlocate-scripts/Makefile.in
++++ src/rlocate-scripts/Makefile.in
+@@ -345,8 +345,6 @@
+ rm $(srcdir)/rlocate-checkpoint.temp
+
+ install-exec-hook:
+-@FREEBSD_TRUE@ -/usr/sbin/pw groupadd $(rlocate_group)
+-@FREEBSD_FALSE@ -/usr/sbin/groupadd $(rlocate_group)
+ chown $(root_uid):$(rlocate_group) $(DESTDIR)$(bindir)/rlocate-checkpoint
+ chmod 2755 $(DESTDIR)$(bindir)/rlocate-checkpoint
+
diff --git a/sys-apps/rlocate/rlocate-0.5.0.ebuild b/sys-apps/rlocate/rlocate-0.5.0.ebuild
new file mode 100644
index 000000000000..b1aa163a64e1
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.0.ebuild,v 1.1 2006/04/15 02:24:07 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/src/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.0-build.patch
+}
+
+src_compile() {
+ econf \
+ --with-kernel=${KV_DIR} \
+ --with-rlocate-group=locate \
+ || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}