summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-14 15:51:13 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-14 15:51:13 +0000
commit361d0ce065c83de1dcca171769648ed4abfb1278 (patch)
tree40f1000d16b95df8e194b71717d24cbb7e583325 /sys-apps
parentcorrected java-config calls in the startup script. fixes bug #77912. (Manifes... (diff)
downloadgentoo-2-361d0ce065c83de1dcca171769648ed4abfb1278.tar.gz
gentoo-2-361d0ce065c83de1dcca171769648ed4abfb1278.tar.bz2
gentoo-2-361d0ce065c83de1dcca171769648ed4abfb1278.zip
changed the multilib part of src_install to just du* rather than use make as the 'make' way was too ugly/kludgey...
(Portage version: 2.0.51-r12)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/portage-2.0.51-r10.ebuild23
-rw-r--r--sys-apps/portage/portage-2.0.51-r11.ebuild23
-rw-r--r--sys-apps/portage/portage-2.0.51-r12.ebuild23
3 files changed, 33 insertions, 36 deletions
diff --git a/sys-apps/portage/portage-2.0.51-r10.ebuild b/sys-apps/portage/portage-2.0.51-r10.ebuild
index 6987c7f2f54f..da213091d6de 100644
--- a/sys-apps/portage/portage-2.0.51-r10.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r10.ebuild,v 1.6 2005/01/14 15:12:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r10.ebuild,v 1.7 2005/01/14 15:51:13 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -134,20 +134,19 @@ src_install() {
if use ppc-macos || use x86-fbsd; then
ewarn "Not installing sandbox on ${ARCH}"
elif [ -n "${MULTILIB_ABIS}" ]; then
+ into /
OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
- cp libsandbox.so.${ABI} libsandbox.so
- touch libsandbox.so
- make DESTDIR="${D}" install || \
- die "Failed to install sandbox"
- if [ "$(get_libdir)" = "lib" ]; then
- mv ${D}/lib/libsandbox.so ${D}/lib/libsandbox.so.lib
- else
- dodir /$(get_libdir)
- mv ${D}/lib/libsandbox.so ${D}/$(get_libdir)
- fi
+ newlib.so libsandbox.so.${ABI} libsandbox.so
done
- [ -f "${D}/lib/libsandbox.so.lib" ] && mv ${D}/lib/libsandbox.so.lib ${D}/lib/libsandbox.so
+ into /usr
+
+ exeinto /usr/lib/portage/bin
+ doexe sandbox
+
+ insinto /usr/lib/portage/lib
+ doins sandbox.bashrc
+
ABI="${OABI}"
elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
check_multilib
diff --git a/sys-apps/portage/portage-2.0.51-r11.ebuild b/sys-apps/portage/portage-2.0.51-r11.ebuild
index 5dd301c2d1d1..afba0a42c91b 100644
--- a/sys-apps/portage/portage-2.0.51-r11.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r11.ebuild,v 1.3 2005/01/14 15:12:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r11.ebuild,v 1.4 2005/01/14 15:51:13 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -134,20 +134,19 @@ src_install() {
if use ppc-macos || use x86-fbsd; then
ewarn "Not installing sandbox on ${ARCH}"
elif [ -n "${MULTILIB_ABIS}" ]; then
+ into /
OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
- cp libsandbox.so.${ABI} libsandbox.so
- touch libsandbox.so
- make DESTDIR="${D}" install || \
- die "Failed to install sandbox"
- if [ "$(get_libdir)" = "lib" ]; then
- mv ${D}/lib/libsandbox.so ${D}/lib/libsandbox.so.lib
- else
- dodir /$(get_libdir)
- mv ${D}/lib/libsandbox.so ${D}/$(get_libdir)
- fi
+ newlib.so libsandbox.so.${ABI} libsandbox.so
done
- [ -f "${D}/lib/libsandbox.so.lib" ] && mv ${D}/lib/libsandbox.so.lib ${D}/lib/libsandbox.so
+ into /usr
+
+ exeinto /usr/lib/portage/bin
+ doexe sandbox
+
+ insinto /usr/lib/portage/lib
+ doins sandbox.bashrc
+
ABI="${OABI}"
elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
check_multilib
diff --git a/sys-apps/portage/portage-2.0.51-r12.ebuild b/sys-apps/portage/portage-2.0.51-r12.ebuild
index 2aa63db76358..4c9662f500d8 100644
--- a/sys-apps/portage/portage-2.0.51-r12.ebuild
+++ b/sys-apps/portage/portage-2.0.51-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r12.ebuild,v 1.3 2005/01/14 15:12:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51-r12.ebuild,v 1.4 2005/01/14 15:51:13 eradicator Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -134,20 +134,19 @@ src_install() {
if use ppc-macos || use x86-fbsd; then
ewarn "Not installing sandbox on ${ARCH}"
elif [ -n "${MULTILIB_ABIS}" ]; then
+ into /
OABI="${ABI}"
for ABI in ${MULTILIB_ABIS}; do
- cp libsandbox.so.${ABI} libsandbox.so
- touch libsandbox.so
- make DESTDIR="${D}" install || \
- die "Failed to install sandbox"
- if [ "$(get_libdir)" = "lib" ]; then
- mv ${D}/lib/libsandbox.so ${D}/lib/libsandbox.so.lib
- else
- dodir /$(get_libdir)
- mv ${D}/lib/libsandbox.so ${D}/$(get_libdir)
- fi
+ newlib.so libsandbox.so.${ABI} libsandbox.so
done
- [ -f "${D}/lib/libsandbox.so.lib" ] && mv ${D}/lib/libsandbox.so.lib ${D}/lib/libsandbox.so
+ into /usr
+
+ exeinto /usr/lib/portage/bin
+ doexe sandbox
+
+ insinto /usr/lib/portage/lib
+ doins sandbox.bashrc
+
ABI="${OABI}"
elif [ "${ARCH}" == "amd64" -a -z "${MULTILIB_ABIS}" ]; then
check_multilib