summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-06 02:37:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-06 02:37:55 +0000
commit39cd4f60534a0e6c2d2ae7c3581639172885fb0a (patch)
tree8b346b358332fc774b7b1a74cca122493d4ca65f /sys-apps
parentAdded optional depend on xine-ui instead of mplayer. Deleted old version (diff)
downloadgentoo-2-39cd4f60534a0e6c2d2ae7c3581639172885fb0a.tar.gz
gentoo-2-39cd4f60534a0e6c2d2ae7c3581639172885fb0a.tar.bz2
gentoo-2-39cd4f60534a0e6c2d2ae7c3581639172885fb0a.zip
Respect more man sections #149857.
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man-db/ChangeLog8
-rw-r--r--sys-apps/man-db/files/digest-man-db-2.4.3-r13
-rw-r--r--sys-apps/man-db/files/man-db-2.4.3-sections.patch8
-rw-r--r--sys-apps/man-db/man-db-2.4.3-r1.ebuild46
4 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index 0f3aa04066f7..82bcb6b61536 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.1 2006/02/22 00:14:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.2 2006/10/06 02:37:55 vapier Exp $
+
+*man-db-2.4.3-r1 (06 Oct 2006)
+
+ 06 Oct 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/man-db-2.4.3-sections.patch, +man-db-2.4.3-r1.ebuild:
+ Respect more man sections #149857.
*man-db-2.4.3 (21 Feb 2006)
diff --git a/sys-apps/man-db/files/digest-man-db-2.4.3-r1 b/sys-apps/man-db/files/digest-man-db-2.4.3-r1
new file mode 100644
index 000000000000..bb21bfb2a78e
--- /dev/null
+++ b/sys-apps/man-db/files/digest-man-db-2.4.3-r1
@@ -0,0 +1,3 @@
+MD5 30814a47f209f43b152659ba51fc7937 man-db-2.4.3.tar.gz 816545
+RMD160 809bdb51f3b60113dbf24c214cc4de419edf1235 man-db-2.4.3.tar.gz 816545
+SHA256 872973bfcf500c1af2c2fe79d9b0099443a9969a86017711f166cc70853553ed man-db-2.4.3.tar.gz 816545
diff --git a/sys-apps/man-db/files/man-db-2.4.3-sections.patch b/sys-apps/man-db/files/man-db-2.4.3-sections.patch
new file mode 100644
index 000000000000..8547e799d3dd
--- /dev/null
+++ b/sys-apps/man-db/files/man-db-2.4.3-sections.patch
@@ -0,0 +1,8 @@
+--- src/man_db.conf.in
++++ src/man_db.conf.in
+@@ -109,4 +109,4 @@
+ # is that you only need to explicitly list extensions if you want to force a
+ # particular order. Sections with extensions should usually be adjacent to
+ # their main section (e.g. "1 1mh 8 ...").
+-SECTION 1 n l 8 3 2 5 4 9 6 7
++SECTION 1 1p n l 8 3 3p 2 5 4 9 6 7 0p 1x 2x 3x 4x 5x 6x 7x 8x
diff --git a/sys-apps/man-db/man-db-2.4.3-r1.ebuild b/sys-apps/man-db/man-db-2.4.3-r1.ebuild
new file mode 100644
index 000000000000..321d34d0fc8a
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.4.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.4.3-r1.ebuild,v 1.1 2006/10/06 02:37:55 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="http://download.savannah.nongnu.org/releases/man-db/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-libs/db"
+RDEPEND="sys-libs/db
+ !sys-apps/man"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-sections.patch
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ # the dependency rules are all wrong unless we build
+ # in the src dir ... so we run in parallel in src first
+ # to prevent any race conditions ...
+ mkdir -p {src,libdb}/.depend
+ emake -C src || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc README docs/{ChangeLog,NEWS,ToDo}
+}