summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-25 21:30:53 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-25 21:30:53 +0000
commit3daab4d72dbf321b2087c09d83c77701b68fc9f2 (patch)
treeb8c7ce9071397e3ff10dc86bcccab74a903837dd /sys-apps
parentold (diff)
downloadgentoo-2-3daab4d72dbf321b2087c09d83c77701b68fc9f2.tar.gz
gentoo-2-3daab4d72dbf321b2087c09d83c77701b68fc9f2.tar.bz2
gentoo-2-3daab4d72dbf321b2087c09d83c77701b68fc9f2.zip
Version bump #251548 by Lars (Polynomial-C).
(Portage version: 2.2_rc18/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/ChangeLog7
-rw-r--r--sys-apps/findutils/findutils-4.5.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 7c7e179aed5f..133cbf078ba6 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.176 2008/11/30 16:01:19 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.177 2008/12/25 21:30:53 vapier Exp $
+
+*findutils-4.5.3 (25 Dec 2008)
+
+ 25 Dec 2008; Mike Frysinger <vapier@gentoo.org> +findutils-4.5.3.ebuild:
+ Version bump #251548 by Lars (Polynomial-C).
30 Nov 2008; Markus Meier <maekke@gentoo.org> findutils-4.2.33.ebuild:
amd64 stable, bug #249136
diff --git a/sys-apps/findutils/findutils-4.5.3.ebuild b/sys-apps/findutils/findutils-4.5.3.ebuild
new file mode 100644
index 000000000000..7cb7d1ebb60d
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.5.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.5.3.ebuild,v 1.1 2008/12/25 21:30:53 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+SELINUX_PATCH="findutils-4.3.12-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
+ mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
+ myconf="${myconf} --without-included-regex"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ --libexecdir=/usr/$(get_libdir)/find \
+ ${myconf} \
+ || die "configure failed"
+ emake AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README TODO ChangeLog
+}