summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-20 06:16:33 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-20 06:16:33 +0000
commit426b4a5e49dc9a2ae8b84a325c54b9a2e7c338d0 (patch)
tree7b1bc3fdf10c9487b5e1d0d8a9ca7b91df46c2dc /sys-apps
parentVersion bump (diff)
downloadgentoo-2-426b4a5e49dc9a2ae8b84a325c54b9a2e7c338d0.tar.gz
gentoo-2-426b4a5e49dc9a2ae8b84a325c54b9a2e7c338d0.tar.bz2
gentoo-2-426b4a5e49dc9a2ae8b84a325c54b9a2e7c338d0.zip
Version bump #192647 and apply libtool fixup #158068. Also update NFS patch #162664 #192844.
(Portage version: 2.1.3.9)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/acl/ChangeLog10
-rw-r--r--sys-apps/acl/acl-2.2.45.ebuild63
-rw-r--r--sys-apps/acl/files/acl-2.2.42-nfs-glue.patch20
-rw-r--r--sys-apps/acl/files/acl-2.2.45-libtool.patch40
-rw-r--r--sys-apps/acl/files/digest-acl-2.2.456
5 files changed, 138 insertions, 1 deletions
diff --git a/sys-apps/acl/ChangeLog b/sys-apps/acl/ChangeLog
index f9c2b3ffe0b7..6ad46a76d18a 100644
--- a/sys-apps/acl/ChangeLog
+++ b/sys-apps/acl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/acl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.72 2007/06/13 23:37:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/ChangeLog,v 1.73 2007/09/20 06:16:33 vapier Exp $
+
+*acl-2.2.45 (20 Sep 2007)
+
+ 20 Sep 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/acl-2.2.42-nfs-glue.patch, +files/acl-2.2.45-libtool.patch,
+ +acl-2.2.45.ebuild:
+ Version bump #192647 and apply libtool fixup #158068. Also update NFS patch
+ #162664 #192844.
13 Jun 2007; Mike Frysinger <vapier@gentoo.org>
+files/acl-2.2.44-LDFLAGS.patch, acl-2.2.44.ebuild:
diff --git a/sys-apps/acl/acl-2.2.45.ebuild b/sys-apps/acl/acl-2.2.45.ebuild
new file mode 100644
index 000000000000..0b6d3e06ac6c
--- /dev/null
+++ b/sys-apps/acl/acl-2.2.45.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acl/acl-2.2.45.ebuild,v 1.1 2007/09/20 06:16:33 vapier Exp $
+
+inherit eutils autotools toolchain-funcs
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="Access control list utilities, libraries and headers"
+HOMEPAGE="http://oss.sgi.com/projects/xfs/"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz
+ ftp://xfs.org/mirror/SGI/cmd_tars/${MY_P}.tar.gz
+ nfs? ( http://www.citi.umich.edu/projects/nfsv4/linux/acl-patches/2.2.42-1/acl-2.2.42-CITI_NFS4_ALL-1.dif )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nfs nls"
+
+RDEPEND=">=sys-apps/attr-2.4
+ nfs? ( net-libs/libnfsidmap )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+ if use nfs ; then
+ cp "${DISTDIR}"/acl-2.2.42-CITI_NFS4_ALL-1.dif . || die
+ epatch \
+ "${FILESDIR}"/acl-2.2.42-nfs-glue.patch \
+ acl-2.2.42-CITI_NFS4_ALL-1.dif
+ fi
+ epatch "${FILESDIR}"/${PN}-2.2.45-libtool.patch #158068
+ epatch "${FILESDIR}"/${PN}-2.2.32-only-symlink-when-needed.patch
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
+ include/builddefs.in \
+ || die "failed to update builddefs"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ $(use_enable nls gettext) \
+ --libexecdir=/usr/$(get_libdir) \
+ --bindir=/bin \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install install-dev install-lib || die
+ prepalldocs
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/libacl.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libacl.so
+}
diff --git a/sys-apps/acl/files/acl-2.2.42-nfs-glue.patch b/sys-apps/acl/files/acl-2.2.42-nfs-glue.patch
new file mode 100644
index 000000000000..81712ebff7b4
--- /dev/null
+++ b/sys-apps/acl/files/acl-2.2.42-nfs-glue.patch
@@ -0,0 +1,20 @@
+--- acl-2.2.42-CITI_NFS4_ALL-1.dif.orig 2007-09-20 01:54:06.000000000 -0400
++++ acl-2.2.42-CITI_NFS4_ALL-1.dif 2007-09-20 01:54:15.000000000 -0400
+@@ -1,17 +1,3 @@
+-diff --git a/debian/changelog b/debian/changelog
+-index 10f4787..54b8af9 100644
+---- a/debian/changelog
+-+++ b/debian/changelog
+-@@ -1,3 +1,9 @@
+-+acl (2.2.42.nfsv4-1) unstable; urgency=low
+-+
+-+ * Add support for NFSv4 ACLs
+-+
+-+ -- J. Bruce Fields <bfields@fieldses.org> Fri, 02 Sep 2006 00:22:07 -0400
+-+
+- acl (2.2.42-1) unstable; urgency=low
+-
+- * New upstream release
+ diff --git a/exports b/exports
+ index 59c1311..2296b7d 100644
+ --- a/exports
diff --git a/sys-apps/acl/files/acl-2.2.45-libtool.patch b/sys-apps/acl/files/acl-2.2.45-libtool.patch
new file mode 100644
index 000000000000..39a1e2743f40
--- /dev/null
+++ b/sys-apps/acl/files/acl-2.2.45-libtool.patch
@@ -0,0 +1,40 @@
+--- m4/package_utilies.m4
++++ m4/package_utilies.m4
+@@ -32,15 +32,7 @@ AC_DEFUN([AC_PACKAGE_UTILITIES],
+ AC_SUBST(make)
+ AC_PACKAGE_NEED_UTILITY($1, "$make", make, [GNU make])
+
+- if test -z "$LIBTOOL"; then
+- AC_PATH_PROG(LIBTOOL, glibtool,, /usr/bin)
+- fi
+- if test -z "$LIBTOOL"; then
+- AC_PATH_PROG(LIBTOOL, libtool,, /usr/bin:/usr/local/bin:/usr/freeware/bin)
+- fi
+- libtool=$LIBTOOL
+- AC_SUBST(libtool)
+- AC_PACKAGE_NEED_UTILITY($1, "$libtool", libtool, [GNU libtool])
++ AC_PROG_LIBTOOL
+
+ if test -z "$TAR"; then
+ AC_PATH_PROG(TAR, tar,, /usr/freeware/bin:/bin:/usr/local/bin:/usr/bin)
+--- include/builddefs.in
++++ include/builddefs.in
+@@ -17,6 +17,7 @@ LIBMISC = $(TOPDIR)/libmisc/libmisc.la
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++top_builddir = @top_builddir@
+ datarootdir = @datarootdir@
+
+ PKG_NAME = @pkg_name@
+--- m4/package_globals.m4
++++ m4/package_globals.m4
+@@ -8,6 +8,8 @@ AC_DEFUN([AC_PACKAGE_GLOBALS],
+ [ pkg_name="$1"
+ AC_SUBST(pkg_name)
+
++ AC_PROG_CC
++
+ . ./VERSION
+ pkg_version=${PKG_MAJOR}.${PKG_MINOR}.${PKG_REVISION}
+ AC_SUBST(pkg_version)
diff --git a/sys-apps/acl/files/digest-acl-2.2.45 b/sys-apps/acl/files/digest-acl-2.2.45
new file mode 100644
index 000000000000..f8ad595d5270
--- /dev/null
+++ b/sys-apps/acl/files/digest-acl-2.2.45
@@ -0,0 +1,6 @@
+MD5 af503d544ef91b50d85959fe3e1f53f7 acl-2.2.42-CITI_NFS4_ALL-1.dif 96775
+RMD160 704fff2c1b9698c10f6e9596a8ae7f763bd3cd37 acl-2.2.42-CITI_NFS4_ALL-1.dif 96775
+SHA256 71b8fb89e62dffd466a929c08ee598c8c376546e166bd4ed6109367b9ae4a30c acl-2.2.42-CITI_NFS4_ALL-1.dif 96775
+MD5 6c33d0ff98c6294eccfd737da8ef2501 acl_2.2.45-1.tar.gz 152771
+RMD160 10b6e54e908abd47e95b71b87df0870c5148bfc9 acl_2.2.45-1.tar.gz 152771
+SHA256 2a38087b64814242908452eda9fe2478b6f9100cf3083e0c9a9e2492579962ad acl_2.2.45-1.tar.gz 152771