summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-02-25 18:03:00 +0000
committerMichał Górny <mgorny@gentoo.org>2014-02-25 18:03:00 +0000
commit4a9affbc79184c5026ad524a785cf0860622d5b7 (patch)
treeac03ed36b2f9a8a54fa2e40adf44f5d8b008bfe3 /sys-apps
parentAdd new snapshot. Update ebuild to avoid build failure with USE="-kde" wrt bu... (diff)
downloadgentoo-2-4a9affbc79184c5026ad524a785cf0860622d5b7.tar.gz
gentoo-2-4a9affbc79184c5026ad524a785cf0860622d5b7.tar.bz2
gentoo-2-4a9affbc79184c5026ad524a785cf0860622d5b7.zip
Fix installing compat pkg-config files for multilib.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog6
-rw-r--r--sys-apps/systemd/systemd-210.ebuild12
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild12
3 files changed, 17 insertions, 13 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 4e45bf4889c4..b6abfc1865a3 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.228 2014/02/25 15:07:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.229 2014/02/25 18:03:00 mgorny Exp $
+
+ 25 Feb 2014; Michał Górny <mgorny@gentoo.org> systemd-210.ebuild,
+ systemd-9999.ebuild:
+ Fix installing compat pkg-config files for multilib.
*systemd-210 (25 Feb 2014)
diff --git a/sys-apps/systemd/systemd-210.ebuild b/sys-apps/systemd/systemd-210.ebuild
index 4414cc9a0dae..9b36f5992fae 100644
--- a/sys-apps/systemd/systemd-210.ebuild
+++ b/sys-apps/systemd/systemd-210.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-210.ebuild,v 1.1 2014/02/25 15:07:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-210.ebuild,v 1.2 2014/02/25 18:03:00 mgorny Exp $
EAPI=5
@@ -271,11 +271,6 @@ multilib_src_install() {
# Even with --enable-networkd, it's not right to have this running by default
# when it's unconfigured.
rm -f "${D}"/etc/systemd/system/multi-user.target.wants/systemd-networkd.service
-
- # install compat pkg-config files
- local pcfiles=( src/compat-libs/libsystemd-{daemon,id128,journal,login}.pc )
- emake "${mymakeopts[@]}" install-pkgconfiglibDATA \
- pkgconfiglib_DATA="${pcfiles[*]}"
else
mymakeopts+=(
install-libLTLIBRARIES
@@ -288,6 +283,11 @@ multilib_src_install() {
emake "${mymakeopts[@]}"
fi
+
+ # install compat pkg-config files
+ local pcfiles=( src/compat-libs/libsystemd-{daemon,id128,journal,login}.pc )
+ emake "${mymakeopts[@]}" install-pkgconfiglibDATA \
+ pkgconfiglib_DATA="${pcfiles[*]}"
}
multilib_src_install_all() {
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 674242e4962d..210eca4dedba 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.93 2014/02/25 15:07:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.94 2014/02/25 18:03:00 mgorny Exp $
EAPI=5
@@ -292,11 +292,6 @@ multilib_src_install() {
# Even with --enable-networkd, it's not right to have this running by default
# when it's unconfigured.
rm -f "${D}"/etc/systemd/system/multi-user.target.wants/systemd-networkd.service
-
- # install compat pkg-config files
- local pcfiles=( src/compat-libs/libsystemd-{daemon,id128,journal,login}.pc )
- emake "${mymakeopts[@]}" install-pkgconfiglibDATA \
- pkgconfiglib_DATA="${pcfiles[*]}"
else
mymakeopts+=(
install-libLTLIBRARIES
@@ -309,6 +304,11 @@ multilib_src_install() {
emake "${mymakeopts[@]}"
fi
+
+ # install compat pkg-config files
+ local pcfiles=( src/compat-libs/libsystemd-{daemon,id128,journal,login}.pc )
+ emake "${mymakeopts[@]}" install-pkgconfiglibDATA \
+ pkgconfiglib_DATA="${pcfiles[*]}"
}
multilib_src_install_all() {