summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-01-25 03:31:31 +0000
committerJeroen Roovers <jer@gentoo.org>2014-01-25 03:31:31 +0000
commit4ab2109a7813d0ccbcad84ed7683d56a23b3f9d2 (patch)
tree8e9a61b337ebcea58469802cb3665c150d6c3868 /sys-apps
parentAdd blockers against iwl3160-ucode, iwl3160-7260-bt-ucode. (diff)
downloadgentoo-2-4ab2109a7813d0ccbcad84ed7683d56a23b3f9d2.tar.gz
gentoo-2-4ab2109a7813d0ccbcad84ed7683d56a23b3f9d2.tar.bz2
gentoo-2-4ab2109a7813d0ccbcad84ed7683d56a23b3f9d2.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pv/ChangeLog9
-rw-r--r--sys-apps/pv/pv-1.5.1.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sys-apps/pv/ChangeLog b/sys-apps/pv/ChangeLog
index f3bb02a17c74..adc7530eec2d 100644
--- a/sys-apps/pv/ChangeLog
+++ b/sys-apps/pv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pv
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.76 2013/09/30 21:24:15 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/ChangeLog,v 1.77 2014/01/25 03:31:31 jer Exp $
+
+*pv-1.5.1 (25 Jan 2014)
+
+ 25 Jan 2014; Jeroen Roovers <jer@gentoo.org> +pv-1.5.1.ebuild:
+ Version bump.
30 Sep 2013; Jeroen Roovers <jer@gentoo.org> -pv-1.4.6.ebuild:
Old.
diff --git a/sys-apps/pv/pv-1.5.1.ebuild b/sys-apps/pv/pv-1.5.1.ebuild
new file mode 100644
index 000000000000..b1dd880dd8be
--- /dev/null
+++ b/sys-apps/pv/pv-1.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pv/pv-1.5.1.ebuild,v 1.1 2014/01/25 03:31:31 jer Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
+SRC_URI="http://www.ivarch.com/programs/sources/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+PV_LINGUAS=( de fr pl pt )
+IUSE+=" ${PV_LINGUAS[@]/#/linguas_}"
+
+DOCS=( README doc/NEWS doc/TODO )
+
+src_prepare() {
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+}
+
+src_configure() {
+ tc-export AR
+ local lingua
+ for lingua in ${PV_LINGUAS[@]}; do
+ if ! use linguas_${lingua}; then
+ sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
+ fi
+ done
+ econf $(use_enable debug debugging) $(use_enable nls)
+}
+
+src_test() {
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+ default
+}