summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2005-05-23 20:34:55 +0000
committerDaniel Drake <dsd@gentoo.org>2005-05-23 20:34:55 +0000
commit4d4e4b5894caa10681b4b757b7d16605a9fad859 (patch)
tree623f2beb402cb85d3a5c2b7ca8fea04485fccdc5 /sys-apps
parentRemoved KEYWORDS from eclass; this is managed in the ebuilds instead (diff)
downloadgentoo-2-4d4e4b5894caa10681b4b757b7d16605a9fad859.tar.gz
gentoo-2-4d4e4b5894caa10681b4b757b7d16605a9fad859.tar.bz2
gentoo-2-4d4e4b5894caa10681b4b757b7d16605a9fad859.zip
Don't check for kernel stuff if building for livecd
(Portage version: 1.589-cvs)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/hal-0.4.5-r2.ebuild6
-rw-r--r--sys-apps/hal/hal-0.4.7-r2.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/hal/hal-0.4.5-r2.ebuild b/sys-apps/hal/hal-0.4.5-r2.ebuild
index ee946a1dc24f..97a586631a9d 100644
--- a/sys-apps/hal/hal-0.4.5-r2.ebuild
+++ b/sys-apps/hal/hal-0.4.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.5-r2.ebuild,v 1.10 2005/05/09 03:04:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.5-r2.ebuild,v 1.11 2005/05/23 20:34:55 dsd Exp $
inherit eutils python linux-info versionator flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
LICENSE="|| ( GPL-2 AFL-2.0 )"
SLOT="0"
KEYWORDS="amd64 ia64 ppc ppc64 x86"
-IUSE="debug pcmcia doc"
+IUSE="debug pcmcia doc livecd"
RDEPEND=">=dev-libs/glib-2.4
>=sys-apps/dbus-0.22-r1
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
# We need to run at least a 2.6.10 kernel, this is a
# way to ensure that to some extent
pkg_setup() {
-
+ use livecd && return
linux-info_pkg_setup
kernel_is ge 2 6 10 \
|| die "You need a 2.6.10 or newer kernel to build this package"
diff --git a/sys-apps/hal/hal-0.4.7-r2.ebuild b/sys-apps/hal/hal-0.4.7-r2.ebuild
index b1e761064474..a97e1b510b1e 100644
--- a/sys-apps/hal/hal-0.4.7-r2.ebuild
+++ b/sys-apps/hal/hal-0.4.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.7-r2.ebuild,v 1.2 2005/04/24 10:27:20 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.4.7-r2.ebuild,v 1.3 2005/05/23 20:34:55 dsd Exp $
inherit eutils python linux-info versionator flag-o-matic
@@ -11,7 +11,7 @@ SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
LICENSE="|| ( GPL-2 AFL-2.0 )"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~ppc64"
-IUSE="debug pcmcia doc"
+IUSE="debug pcmcia doc livecd"
RDEPEND=">=dev-libs/glib-2.4
>=sys-apps/dbus-0.22-r1
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
# We need to run at least a 2.6.10 kernel, this is a
# way to ensure that to some extent
pkg_setup() {
-
+ use livecd && return
linux-info_pkg_setup
kernel_is ge 2 6 10 \
|| die "You need a 2.6.10 or newer kernel to build this package"