summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-01 23:27:58 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-01 23:27:58 +0000
commit557fbeadbee62f9991a5ae0a286e96985c421e4a (patch)
tree67dfd213d8c3c301178c16e52a81d40f089d64a9 /sys-apps
parentAdded x11-wm/pekwm imlib2 and themes use flag (diff)
downloadgentoo-2-557fbeadbee62f9991a5ae0a286e96985c421e4a.tar.gz
gentoo-2-557fbeadbee62f9991a5ae0a286e96985c421e4a.tar.bz2
gentoo-2-557fbeadbee62f9991a5ae0a286e96985c421e4a.zip
Version bump with patch to fix sorted top display #80296 by Andreas Kling.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/procps/ChangeLog8
-rw-r--r--sys-apps/procps/files/3.2.5-top-sort.patch39
-rw-r--r--sys-apps/procps/files/digest-procps-3.2.51
-rw-r--r--sys-apps/procps/procps-3.2.5.ebuild65
4 files changed, 112 insertions, 1 deletions
diff --git a/sys-apps/procps/ChangeLog b/sys-apps/procps/ChangeLog
index dc4912ac73f3..7ca550b6648f 100644
--- a/sys-apps/procps/ChangeLog
+++ b/sys-apps/procps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/procps
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.99 2005/01/26 23:13:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.100 2005/02/01 23:27:58 vapier Exp $
+
+*procps-3.2.5 (01 Feb 2005)
+
+ 01 Feb 2005; Mike Frysinger <vapier@gentoo.org> +files/3.2.5-top-sort.patch,
+ +procps-3.2.5.ebuild:
+ Version bump with patch to fix sorted top display #80296 by Andreas Kling.
*procps-3.2.4-r2 (26 Jan 2005)
diff --git a/sys-apps/procps/files/3.2.5-top-sort.patch b/sys-apps/procps/files/3.2.5-top-sort.patch
new file mode 100644
index 000000000000..b160bcc301a9
--- /dev/null
+++ b/sys-apps/procps/files/3.2.5-top-sort.patch
@@ -0,0 +1,39 @@
+Under certain conditions, top's display can break.
+This patch is by Curtis Doty, updated by Andreas Kling for 3.2.5.
+
+To reproduce bug:
+ - run top
+ - turn on color mode ('z')
+ - highlight sort column ('x')
+ - move sort column all the way to the left ('<')
+ - get drunk
+
+procps e-mail: http://sourceforge.net/mailarchive/forum.php?thread_id=6042978&forum_id=12454
+Redhat bug: http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=140975
+Gentoo bug: http://bugs.gentoo.org/show_bug.cgi?id=80296
+
+--- procps-3.2.5/top.c~ 2005-01-26 06:15:18.000000000 +0100
++++ procps-3.2.5/top.c 2005-02-01 09:23:35.000000000 +0100
+@@ -2952,12 +2952,10 @@
+ for (x = 0; x < q->maxpflgs; x++) {
+ char cbuf[ROWBUFSIZ], _z[ROWBUFSIZ];
+ FLG_t i = q->procflags[x]; // support for our field/column
+- const char *f = Fieldstab[i].fmts; // macro AND sometimes the fmt
++ const char *f = Fieldstab[i].fmts + ((x==0) && !Rc.mode_altscr);
+ unsigned s = Fieldstab[i].scale; // string must be altered !
+ unsigned w = Fieldstab[i].width;
+
+- int advance = (x==0) && !Rc.mode_altscr;
+-
+ switch (i) {
+ case P_CMD:
+ { char tmp[ROWBUFSIZ];
+@@ -3069,7 +3067,7 @@
+
+ } /* end: switch 'procflag' */
+
+- rp = scat(rp, cbuf+advance);
++ rp = scat(rp, cbuf);
+ } /* end: for 'maxpflgs' */
+
+ PUFF(
diff --git a/sys-apps/procps/files/digest-procps-3.2.5 b/sys-apps/procps/files/digest-procps-3.2.5
new file mode 100644
index 000000000000..0f9fb90c8e34
--- /dev/null
+++ b/sys-apps/procps/files/digest-procps-3.2.5
@@ -0,0 +1 @@
+MD5 cde0e3612d1d7c68f404d46f01c44fb4 procps-3.2.5.tar.gz 277365
diff --git a/sys-apps/procps/procps-3.2.5.ebuild b/sys-apps/procps/procps-3.2.5.ebuild
new file mode 100644
index 000000000000..7ea0408c31ef
--- /dev/null
+++ b/sys-apps/procps/procps-3.2.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-3.2.5.ebuild,v 1.1 2005/02/01 23:27:58 vapier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Standard informational utilities and process-handling tools"
+HOMEPAGE="http://procps.sourceforge.net/"
+SRC_URI="http://${PN}.sf.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix terminal breakage when sorting first column in top #80296
+ epatch "${FILESDIR}"/${PV}-top-sort.patch
+
+ # Clean up the makefile
+ # - we do stripping ourselves
+ # - punt fugly gcc flags
+ sed -i \
+ -e '/install/s: --strip : :' \
+ -e '/ALL_CFLAGS += $(call check_gcc,-fweb,)/d' \
+ -e '/ALL_CFLAGS += $(call check_gcc,-Wstrict-aliasing=2,)/s,=2,,' \
+ Makefile || die "sed Makefile"
+ use ppc && sed -i -e 's:-m64::g' Makefile
+
+ # mips 2.4.23 headers (and 2.6.x) don't allow PAGE_SIZE to be defined in
+ # userspace anymore, so this patch instructs procps to get the
+ # value from sysconf().
+ use mips && epatch ${FILESDIR}/${PN}-mips-define-pagesize.patch
+}
+
+src_compile() {
+ replace-flags -O3 -O2
+ emake \
+ lib64="$(get_libdir)" \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ make install ldconfig="true" DESTDIR="${D}" || die "install failed"
+
+ insinto /usr/include/proc
+ doins proc/*.h || die "doins include"
+
+ dodoc sysctl.conf BUGS NEWS TODO ps/HACKING
+}
+
+pkg_postinst() {
+ einfo "NOTE: With NPTL \"ps\" and \"top\" no longer"
+ einfo "show threads. You can use any of: -m m -L -T H"
+ einfo "in ps or the H key in top to show them"
+}