summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-16 09:11:09 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-16 09:11:09 +0000
commit5627572266a40a2595922835f0f350d914fb87c9 (patch)
treeab78c3966ba544cb757a108d509231320953428a /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-5627572266a40a2595922835f0f350d914fb87c9.tar.gz
gentoo-2-5627572266a40a2595922835f0f350d914fb87c9.tar.bz2
gentoo-2-5627572266a40a2595922835f0f350d914fb87c9.zip
Version bump.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/rlocate/ChangeLog7
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.4.01
-rw-r--r--sys-apps/rlocate/rlocate-0.4.0.ebuild45
3 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index 43c1dd259479..02eeabae1377 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.8 2006/01/14 00:24:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.9 2006/01/16 09:11:09 vapier Exp $
+
+*rlocate-0.4.0 (16 Jan 2006)
+
+ 16 Jan 2006; Mike Frysinger <vapier@gentoo.org> +rlocate-0.4.0.ebuild:
+ Version bump.
14 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+files/rlocate-0.3.3-linux-2.6.15.patch, rlocate-0.3.3.ebuild:
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.4.0 b/sys-apps/rlocate/files/digest-rlocate-0.4.0
new file mode 100644
index 000000000000..edad07e13c58
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.4.0
@@ -0,0 +1 @@
+MD5 58a301017766643473281f4e63972a96 rlocate-0.4.0.tar.gz 193642
diff --git a/sys-apps/rlocate/rlocate-0.4.0.ebuild b/sys-apps/rlocate/rlocate-0.4.0.ebuild
new file mode 100644
index 000000000000..fce1a035f73e
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.4.0.ebuild,v 1.1 2006/01/16 09:11:09 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.3.3-build.patch
+}
+
+src_compile() {
+ econf --enable-sandboxed --with-kernel=${KV_DIR} || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}