summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-17 03:41:42 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-17 03:41:42 +0000
commit5e13401e42f4c6d7c53e2ecf5e7c6b59668128a6 (patch)
tree1a5d9433f738144039d853fcf83eeb2be62f6e8a /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-5e13401e42f4c6d7c53e2ecf5e7c6b59668128a6.tar.gz
gentoo-2-5e13401e42f4c6d7c53e2ecf5e7c6b59668128a6.tar.bz2
gentoo-2-5e13401e42f4c6d7c53e2ecf5e7c6b59668128a6.zip
Version bump.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sg3_utils/ChangeLog9
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.31.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 11e3aeb45432..5f0e154cbd6e 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sg3_utils
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.70 2010/11/26 07:20:29 robbat2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.71 2011/06/17 03:41:42 jer Exp $
+
+*sg3_utils-1.31 (17 Jun 2011)
+
+ 17 Jun 2011; Jeroen Roovers <jer@gentoo.org> +sg3_utils-1.31.ebuild:
+ Version bump.
*sg3_utils-1.30 (26 Nov 2010)
diff --git a/sys-apps/sg3_utils/sg3_utils-1.31.ebuild b/sys-apps/sg3_utils/sg3_utils-1.31.ebuild
new file mode 100644
index 000000000000..94f5d942d7e1
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.31.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.31.ebuild,v 1.1 2011/06/17 03:41:42 jer Exp $
+
+inherit eutils
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog AUTHORS COVERAGE CREDITS README*
+ dodoc doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/scsi* || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${D}"/usr/$(get_libdir)/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}