summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Jones <carpaski@gentoo.org>2004-09-11 04:00:22 +0000
committerNicholas Jones <carpaski@gentoo.org>2004-09-11 04:00:22 +0000
commit606c64dbaab744a0362eb0f6cec5131a73898211 (patch)
treeeac8fbc3cad66bc1d05084d95a39a9a812d4dca3 /sys-apps
parentNew portage. (Manifest recommit) (diff)
downloadgentoo-2-606c64dbaab744a0362eb0f6cec5131a73898211.tar.gz
gentoo-2-606c64dbaab744a0362eb0f6cec5131a73898211.tar.bz2
gentoo-2-606c64dbaab744a0362eb0f6cec5131a73898211.zip
Fixing the argument-too-long errors in the ebuild.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/portage-2.0.51_pre22.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-apps/portage/portage-2.0.51_pre22.ebuild b/sys-apps/portage/portage-2.0.51_pre22.ebuild
index 2a0074887388..60cf5da6d4e0 100644
--- a/sys-apps/portage/portage-2.0.51_pre22.ebuild
+++ b/sys-apps/portage/portage-2.0.51_pre22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51_pre22.ebuild,v 1.1 2004/09/11 02:09:17 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.0.51_pre22.ebuild,v 1.2 2004/09/11 04:00:22 carpaski Exp $
IUSE="build multilib selinux"
@@ -330,12 +330,19 @@ pkg_postinst() {
if [ -d "${ROOT}usr/portage/distfiles" ]; then
chown -R root:portage "${ROOT}usr/portage/distfiles"
chmod 0664 "${ROOT}usr/portage/distfiles"/*
+
+ find "${ROOT}usr/portage/distfiles" -type f -maxlevel 1 -print0 | \
+ xargs -0 -n 500 chmod 0644
+
chmod 2775 "${ROOT}usr/portage/distfiles"
chmod 2775 "${ROOT}usr/portage/distfiles/cvs-src"
fi
if [ -d "${ROOT}/${PORTDIR}/distfiles" ]; then
chown -R root:portage "${ROOT}/${PORTDIR}/distfiles"
- chmod 0664 "${ROOT}/${PORTDIR}/distfiles"/*
+
+ find "${ROOT}/${PORTDIR}/distfiles" -type f -maxlevel 1 -print0 | \
+ xargs -0 -n 500 chmod 0644
+
chmod 2775 "${ROOT}/${PORTDIR}/distfiles"
chmod 2775 "${ROOT}/${PORTDIR}/distfiles/cvs-src"
fi